Comment ajouter des champs Liste de choix dans une table Microsoft Access

Traductions disponibles Traductions disponibles
Numéro d'article: 304462 - Voir les produits auxquels s'applique cet article
Novice : nécessite des connaissances de l'interface utilisateur sur les ordinateurs mono-utilisateur.

Pour une version de Microsoft Access 2000 de cet article, voir 304463.
Pour une version de Microsoft Access 97 de cet article, voir 304464.
Agrandir tout | Réduire tout

Sommaire

Résumé

Dans Microsoft Access, vous pouvez ajouter un champ à une table pour rechercher des informations dans une autre table. Vous utilisez généralement cette technique lorsque vous souhaitez créer des relations entre tables. Par exemple, vous avez peut-être une table Produits avec un champ de catégorie qui recherche du nom de la catégorie à partir d'une table Catégories. En utilisant cette technique, vous pouvez stocker la valeur de clé primaire uniquement dans la table Catégories, mais afficher le nom catégorie plus utile.

Cet article explique comment ajouter des champs Liste de choix à une table Microsoft Access. Tout d'abord, elle vous indique comment utiliser un Assistant pour ajouter le champ de recherche, et puis il explique comment ajouter le champ de recherche manuellement.

Plus d'informations

Utiliser un Assistant pour créer un champ liste de choix

  1. Démarrez Access.
  2. Dans le menu Aide , cliquez sur Exemples de bases de données , puis cliquez sur base de données exemple Les Comptoirs . Fermez le formulaire menu général lorsqu'elle apparaît.

    note Dans Access 2007, cliquez sur modèles dans le volet Catégories de modèles , cliquez sur Les Comptoirs 2007 et puis cliquez sur Télécharger .
  3. Dans le menu Affichage , cliquez sur objets de base de données , puis cliquez sur tables .

    note Dans Access 2007, dans le groupe tables de l'onglet Créer , cliquez sur Création de table .
  4. Double-cliquez sur Créer une table en mode Création pour créer une nouvelle table.

    note Dans Access 2007, ignorez cette étape.
  5. Tapez EmployeeLookup dans la première ligne sous nom du champ .
  6. Dans la colonne Type de données , sélectionnez Assistant Liste de choix .
  7. Sur la première page de l'Assistant Liste de choix, activez la case à cocher Je VEUX que la liste de choix recherche les valeurs dans une table ou une requête , puis cliquez sur suivant .
  8. Cliquez sur la table Employees dans la liste des tables, puis cliquez sur suivant .
  9. Double-cliquez sur le champ EmployeeID , le champ Nom et le champ FirstName (prénom) pour ajouter les champs à la liste des champs sélectionnés, puis cliquez sur suivant à deux reprises.
  10. Assurez-vous que la case à cocher Masquer la colonne de clé est activée, puis cliquez sur suivant .
  11. Cliquez sur Terminer à la dernière page de l' Assistant Liste de choix .
  12. Cliquez sur Oui pour enregistrer la table lorsque vous êtes invité, puis nommez la table TestLookupWizard.
  13. Cliquez sur Oui pour ajouter une clé primaire dans la table lorsque vous êtes invité.

    Notez que l'Assistant va créer une relation entre la nouvelle table et la table Employees dans la base de données Les Comptoirs.
  14. Dans le menu Affichage , cliquez sur mode Feuille de données .

    note Dans Access 2007, ouvrez la table dans la vue de feuille de données.
  15. Cliquez sur la flèche déroulante dans le champ EmployeeLookup .

    Notez que deux colonnes s'affichent dans la zone de liste modifiable.

Créer manuellement un champ liste de choix

  1. Démarrez Access.
  2. Dans le menu Aide , cliquez sur Exemples de bases de données , puis cliquez sur base de données exemple Les Comptoirs . Fermez le formulaire menu général lorsqu'elle apparaît.

    note Dans Access 2007, cliquez sur modèles dans le volet Catégories de modèles , cliquez sur Les Comptoirs 2007 et puis cliquez sur Télécharger .
  3. Dans le menu Affichage , cliquez sur objets de base de données , puis cliquez sur tables .

    note Dans Access 2007, dans le groupe tables de l'onglet Créer , cliquez sur Création de table .
  4. Double-cliquez sur Créer une table en mode Création pour créer une nouvelle table.

    note Dans Access 2007, ignorez cette étape.
  5. Tapez EmployeeLookup dans la première ligne sous nom du champ .
  6. Dans la colonne Type de données , cliquez sur nombre .
  7. Dans la fenêtre Propriétés du champ , cliquez sur l'onglet Liste de choix .
  8. Selon la liste DisplayControl , cliquez sur zone liste déroulante .
  9. Cliquez dans la zone de propriété RowSource (Contenu) , cliquez sur la flèche qui apparaît, cliquez sur employés dans la liste et puis cliquez sur Créer pour ouvrir le Générateur de requêtes.
  10. Double-cliquez sur le champ EmployeeID , le champ Nom et le champ FirstName (prénom) pour ajouter les champs dans la grille de la requête.
  11. Dans le groupe fermer dans l'onglet Création , cliquez sur Fermer pour quitter le concepteur de requête.
  12. Cliquez sur Oui lorsque vous êtes invité pour enregistrer les modifications apportées à la SQL instruction.
  13. Assurez-vous que que la propriété BoundColumn est définie sur 1 .

    note Cette propriété correspond au champ de la source de ligne est enregistrée dans le champ. Dans cet exemple, le champ EmployeeLookup stocke la valeur n° employé de la table Employés .
  14. Modifier la valeur de la propriété ColumnCount à 3 .

    note Cette valeur représente le nombre de champs qui sont sélectionnés dans la source de ligne.
  15. Tapez 0; 1; 1 dans la zone LargeurColonnes (ColumnWidths) .

    note La propriété ColumnWidths (LargeurColonne) est une liste délimitée par des points-virgules, de largeur pour chaque colonne de la source de ligne. Définir une largeur de colonne à 0 si vous voulez masquer la colonne.
  16. Tapez 2 » dans la zone ListWidth .
  17. Dans le menu Affichage , cliquez sur mode Feuille de données .

    note Dans Access 2007, ouvrez la table dans la vue de feuille de données.
  18. Cliquez sur Oui pour enregistrer la table lorsque vous êtes invité, puis nommez la table TestLookupWizard2.
  19. Cliquez sur Oui pour ajouter une clé primaire dans la table lorsque vous êtes invité.
  20. Cliquez sur la flèche déroulante dans le champ EmployeeLookup .

    Notez que deux colonnes s'affichent dans la zone de liste modifiable.

Propriétés

Numéro d'article: 304462 - Dernière mise à jour: jeudi 29 mars 2007 - Version: 5.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002
Mots-clés : 
kbmt kbinfo kbexpertisebeginner kbdesign kbdatabase kbhowto KB304462 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 304462
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com