SMART IOCTL nefunguje na pevném disku slave

Překlady článku Překlady článku
ID článku: 304572 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při použití volání SMART IOCTL pevný disk IDE, který je nakonfigurován jako slave-smart hlavního zařízení ATAPI volání nemusí pracovat správně. Pokud používáte software jiných výrobců ke sledování stavu inteligentní pevného disku v počítači a je nakonfigurován jako slave zařízení ATAPI-smart software nemusí být vědoma jednotky vůbec.

Příčina

K tomuto problému může dojít při ATAPI zařízení (například jednotky CD-ROM), který nepodporuje volání SMART IOCTL je nakonfigurována jako hlavní zařízení IDE. Důvodem je, že SMART IOCTL volání odkazy hlavní zařízení TargetID v SCSI Request Block, které vždy vrácena jako nula (0).

Řešení

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Není-li tato část uvedena, vyžádejte si tuto opravu hotfix od oddělení služeb zákazníkům a podpory společnosti Microsoft.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.Anglická verze této opravy má následující nebo vyšší atributy souborů:
   Date         Time   Version        Size    File name
   ----------------------------------------------------
   Sep-11-2001  16:45  5.0.2195.4324  86,768  Atapi.sys
				

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Další informace o získání opravy Hotfix pro systém Windows 2000 Datacenter Server získáte v následujícím článku databáze Microsoft Knowledge Base:
265173Program pro podporu serveru Datacenter a produkt Windows 2000 Datacenter Server
Další informace o instalaci více oprav hotfix pouze s jedním restartováním počítače naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
296861Instalace více aktualizací nebo oprav hotfix pro systém Windows s pouze jedním restartováním počítače
Další informace o instalaci systému Windows 2000 a Windows 2000 Hotfix současně klepněte na následující číslo článku databáze Microsoft Knowledge Base:
249149Instalace systému Microsoft Windows 2000 a oprav pro systém Windows 2000
Microsoft Windows 95 a WINDOWSNT SMART IOCTL specifikace API je k dispozici následující web:
http://www.microsoft.com/whdc/default.mspx

Vlastnosti

ID článku: 304572 - Poslední aktualizace: 28. února 2014 - Revize: 3.8
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
Klíčová slova: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbbug kbenv kbfix kbqfe kbwin2000presp3fix kbwin2000sp3fix KB304572 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:304572

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com