IOCTL SMART no funciona en disco duro de esclavo

Seleccione idioma Seleccione idioma
Id. de artículo: 304572 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

Síntomas

Cuando se utiliza una llamada de IOCTL SMART a un disco duro IDE está configurado como esclavo a un dispositivo maestro de ATAPI no inteligente, la llamada no funcionen correctamente. Si está utilizando software de terceros para supervisar el estado de disco de duro inteligente del equipo y se configura como esclavo a un dispositivo ATAPI de no inteligente, el software es posible que no sea consciente de la unidad en absoluto.

Causa

Este problema puede producirse cuando un dispositivo ATAPI (como una unidad de CD-ROM) que no admite llamadas IOCTL SMART está configurado como un dispositivo IDE principal. Esto es porque el IOCTL SMART llamar referencias un dispositivo principal TargetID en un bloque de solicitud SCSI, que siempre se devuelve como cero (0).

Solución

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.La versión en inglés de esta revisión debe tener los atributos de archivo siguientes o posteriores:
   Date         Time   Version        Size    File name
   ----------------------------------------------------
   Sep-11-2001  16:45  5.0.2195.4324  86,768  Atapi.sys
				

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener información adicional acerca de cómo obtener una revisión para Windows 2000 Datacenter Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
265173El programa Datacenter y el producto servidor de Windows 2000 Datacenter
Para obtener información adicional acerca de cómo instalar múltiples revisiones con un único reinicio, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
296861Utilizar QChain.exe para instalar varias revisiones con sólo un reinicio
Para obtener información adicional acerca de cómo instalar Windows 2000 y el hotfix de Windows 2000 al mismo tiempo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
249149Instalar Microsoft Windows 2000 y revisiones para Windows 2000
La especificación de API de Microsoft Windows 95 y Windows NT IOCTL SMART está disponible en el siguiente sitio Web de Microsoft:
http://www.microsoft.com/whdc/default.mspx

Propiedades

Id. de artículo: 304572 - Última revisión: lunes, 24 de febrero de 2014 - Versión: 3.8
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
Palabras clave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbbug kbenv kbfix kbqfe kbwin2000presp3fix kbwin2000sp3fix KB304572 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 304572

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com