Users can't change their office phone number when they set up Azure Multi-Factor Authentication

Problem

When a user tries to set up Azure Multi-Factor Authentication, the user can't select or change the Office Phone option. The user can't edit the phone number because the text box is unavailable (appears dimmed). Additionally, the user can't set the office phone as the preferred contact method.

Cause

This problem occurs for on-premises users who are synchronized from the on-premises Active Directory environment to Microsoft Entra ID.

Solution

Change the user's office phone number in the on-premises Active Directory.

More Information

For more information about Azure Multi-Factor Authentication, see Azure Multi-Factor Authentication.

Still need help? Go to Microsoft Community or the Microsoft Entra Forums website.