Artigo: 304849 - Última revisão: sexta-feira, 23 de Setembro de 2005 - Revisão: 3.5

Não é possível receber um notificações de correio electrónico novas no Outlook 2000 quando utilizar o NAT

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Para obter uma versão do Microsoft Outlook 2002 deste artigo, consulte 305572  (http://support.microsoft.com/kb/305572/ ) .

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Se utilizar (Network Address TRANSLATION), poderá não ver novas mensagens de correio electrónico ou receber notificações de novas mensagens de correio electrónico no Outlook 2000.

Causa

Este problema pode ocorrer num ambiente de NAT, Network Address TRANSLATION porque o Outlook 2000 nunca recebe UDP (pacotes de datagrama universal) que envia o Microsoft Exchange Server e não pode encaminhar os pacotes UDP para um computador com o Outlook 2000.

O computador que esteja a executar o Outlook 2000 regressa ao consulta o Exchange Server para novas mensagens de correio electrónico utilizando a chamada de procedimento remoto (RPC) para contornar este problema. No entanto, existe um erro de lógica com o Exchange Server e não responder ao pedido de consulta.

Resolução

Para resolver este problema, utilize os seguintes dois métodos para configurar o Outlook 2000 para utilizar consulta em vez de UDP para receber notificações de correio electrónico novas:
  1. Aplique a correcção associada ao computador que esteja a executar o Outlook 2000.
  2. Adicione manualmente as entradas de registo.

Como utilizar a correcção

Para resolver este problema, obtenha o service pack mais recente do Microsoft Office 2000. Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
276367  (http://support.microsoft.com/kb/276367/EN-US/ ) OFF2000: Como obter o Service Pack mais recente do Office 2000
importante : antes de instalar o Microsoft Office 2000 Service Pack 3 (SP-3), tem de ter o Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a) instalado pela primeira vez. Para obter o SR-1/SR-1a, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
245025  (http://support.microsoft.com/kb/245025/EN-US/ ) OFF2000: Como obter e instalar o Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a)


A versão portuguesa desta correcção deverá ter os seguintes atributos de ficheiro ou posteriores:
    Date        Time        Version     Size       File name
    ------------------------------------------------------
    07/06/2001  10:48:50pm  5.5.3160.0  594,192    Emsmdb32.dll
    07/06/2001  10:32:36pm  9.0.0.5505  5,328,946  Outllib.dll
				
A correcção também está disponível para language(s) seguinte: alemão, italiano

Como adicionar manualmente entradas de registo

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows


Nota : Se já foi instalado o Office 2000 (SP-3), não é necessário instalar a correcção. Se já foi instalado o Office 2000 (SP-3), siga estes passos para adicionar os valores de registo para aplicar as definições.

Para adicionar os valores de registo ao computador que esteja a executar o Outlook 2000, siga estes passos:
  1. Clique em Iniciar e, em seguida, clique em Executar .
  2. Na caixa Abrir , escreva Regedt32.exe e, em seguida, clique em OK .
  3. Localize a seguinte chave no registo:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\
  4. No menu Editar , clique em Adicionar chave e, em seguida, adicione a seguinte chave de registo:
    nome da chave : RPC
    classe : nenhum
  5. Clique em OK .
  6. Localize a seguinte chave no registo:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\RPC\
  7. No menu Editar , clique em Adicionar valor e, em seguida, adicione o seguinte valor de registo:
    nome do valor : ForcePolling
    tipo de dados : REG_DWORD
    valor : 1
  8. Localize a seguinte chave no registo:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\
  9. No menu Editar , clique em Adicionar chave e, em seguida, adicione a seguinte chave de registo:
    nome da chave : Office
    classe : nenhum
  10. Localize a seguinte chave no registo:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\
  11. No menu Editar , clique em Adicionar chave e, em seguida, adicione a seguinte chave de registo:
    nome da chave : 9.0
    classe : nenhum
  12. Localize a seguinte chave no registo:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\9.0\
  13. No menu Editar , clique em Adicionar chave e, em seguida, adicione a seguinte chave de registo:
    nome da chave : Outlook
    classe : nenhum
  14. Localize a seguinte chave no registo:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\9.0\Outlook\
  15. No menu Editar , clique em Adicionar chave e, em seguida, adicione a seguinte chave de registo:
    nome da chave : RPC
    classe : nenhum
  16. Localize a seguinte chave no registo:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\9.0\Outlook\RPC\
  17. No menu Editar , clique em Adicionar valor e, em seguida, adicione o seguinte valor de registo:
    nome do valor : ForcePolling
    tipo de dados : REG_DWORD
    valor : 1
  18. Saia do Editor de registo
  19. Reinicie o computador.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no início deste artigo.
Este problema foi corrigido pela primeira vez no Microsoft Office 2000 Service Pack 3 (SP-3).

Mais Informação

O Outlook 2000 utiliza o UDP e consulta para o notificar de novas mensagens de correio electrónico.

Com UDP, o Outlook 2000 envia o servidor o endereço do cliente IP (protocolo Internet) e notifica o servidor para enviar o UDP quando existem mensagens de correio electrónico que aguardam no servidor.

O mecanismo de consulta ocorre quando o Outlook 2000 é iniciado um thread que pede informações a partir do servidor cada 60 segundos com RPC, por predefinição, para quaisquer mensagens de correio electrónico pendentes.

A preferência predefinida para notificação de correio electrónico no Outlook 2000 é UDP e se esta acção falhar, em seguida, utiliza consulta. Define o valor de registo mencionadas anteriormente a utilizar consulta como a predefinição para notificação de correio electrónico novo ou não. O valor de 1 indica que consulta é utilizada como predefinição pelo Outlook 2000 e que UDP não será utilizado. A predefinição de tempo de consulta é 60 segundos e é definida no Exchange Server.

A informação contida neste artigo aplica-se a:
  • Microsoft Outlook 2000
Palavras-chave: 
kbmt kbhotfixserver kbqfe kbfunctions kbreceivemail kbemail kbbug kboffice2000sp3fix kbfix KB304849 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 304849  (http://support.microsoft.com/kb/304849/en-us/ )