Cómo dividir manualmente una base de datos de Access en Microsoft Access

Seleccione idioma Seleccione idioma
Id. de artículo: 304932 - Ver los productos a los que se aplica este artículo
Avanzado: requiere conocimientos avanzados de código, interoperabilidad y multiusuario.

Este artículo se refiere a un archivo de base de datos de Microsoft Access .mdb o .accdb.
Expandir todo | Contraer todo

Resumen

Por varias razones, puede decidir dividir una base de datos en una aplicación de cliente o en una aplicación de servidor. La base de datos de servidor contiene las tablas y está almacenada en un servidor de archivos. La base de datos de cliente que vincula a las tablas de servidor contiene todos los formularios, las consultas, los informes, las macros y los módulos. La base de datos de cliente se distribuye a las estaciones de trabajo de los usuarios.

En este artículo se describe cómo dividir manualmente la base de datos en lugar de con la utilidad Divisor de base de datos.

Más información

Para dividir la base de datos en Microsoft Office Access 2003 y en las versiones anteriores de Access, siga estos pasos:
  1. Cree una nueva base de datos de Access en blanco.
  2. En el menú Archivo, seleccione Obtener datos externos y haga clic en Importar.
  3. Busque y seleccione la base de datos que desea dividir.
  4. En la ficha Tablas, haga clic en Seleccionar todo y, después, haga clic en Aceptar.

    Observe que Access importa todas las tablas en la nueva base de datos, que es la base de datos de servidor.
  5. Almacene la nueva base de datos de servidor en un recurso compartido de red y asegúrese de que todos los usuarios tienen permisos completos en el recurso compartido.
  6. Cree una segunda base de datos de Access nueva en blanco.
  7. En el menú Archivo, seleccione Obtener datos externos y haga clic en Vincular tablas.
  8. Seleccione la base de datos de servidor recién creada.
  9. En la ficha Tablas, haga clic en Seleccionar todo y, después, haga clic en Aceptar.

    Observe que Access vincula las tablas de la base de datos de servidor a la base de datos de cliente.
  10. En el menú Archivo, seleccione Obtener datos externos y haga clic en Importar.
  11. Seleccione la base de datos original que está dividiendo y, a continuación, haga clic en Importar.
  12. En la ficha Formularios, haga clic en Seleccionar todo. Repita este paso en todas las fichas excepto en la ficha Tablas. Dado que ya ha vinculado a las tablas, ahora sólo necesita importar el resto de los objetos.
  13. Después de haber seleccionado todos los objetos excepto las tablas, haga clic en Aceptar.

    Observe que ahora tiene todas las tablas vinculadas y ha importado los objetos restantes.
Para dividir la base de datos en Microsoft Access 2007, siga estos pasos:
  1. Cree una nueva base de datos de Access en blanco.
  2. En la ficha Datos externos, haga clic en Access en el grupo Importar.
  3. En el cuadro de diálogo Obtener datos externos, haga clic en Examinar para buscar y seleccionar la base de datos que desea dividir, haga clic en la casilla Importar tablas, consultas, formularios, informes, macros y módulos en la base de datos actual. para activarla y, a continuación, haga clic en Aceptar.
  4. En el cuadro de diálogo Importar objetos, haga clic en Seleccionar todos en la ficha Tablas y, a continuación, haga clic en Aceptar.

    Observe que Access importa todas las tablas en la nueva base de datos, que es la base de datos de servidor.
  5. Almacene la nueva base de datos de servidor en un recurso compartido de red y asegúrese de que todos los usuarios tienen permisos completos en el recurso compartido.
  6. Cree una segunda base de datos de Access nueva en blanco.
  7. En la ficha Datos externos, haga clic en Access en el grupo Importar.
  8. En el cuadro de diálogo Obtener datos externos, haga clic en Examinar para seleccionar la base de datos de servidor que creó, haga clic en la casilla Vincular al origen de datos creando una tabla vinculada. para activarla y, a continuación, haga clic en Aceptar.
  9. En el cuadro de diálogo Importar objetos, haga clic en Seleccionar todos en la ficha Tablas y, a continuación, haga clic en Aceptar.

    Observe que Access vincula las tablas de la base de datos de servidor a la base de datos de cliente.
  10. En la ficha Datos externos, haga clic en Access en el grupo Importar.
  11. En el cuadro de diálogo Obtener datos externos, haga clic en Examinar para seleccionar la base de datos original que va a dividir, haga clic en la casilla Importar tablas, consultas, formularios, informes, macros y módulos en la base de datos actual. para activarla y, a continuación, haga clic en Aceptar.
  12. En el cuadro de diálogo Importar objetos, haga clic en Seleccionar todos en la ficha Formularios, repita este paso con todas las demás fichas excepto Tablas, porque ya ha vinculado a las tablas. Ahora sólo tiene que importar el resto de los objetos y, a continuación, hacer clic en Aceptar.

    Observe que ahora tiene todas las tablas vinculadas y ha importado los objetos restantes.
Notas

Esta base de datos es la base de datos de cliente. Puede distribuir esta base de datos de cliente en las estaciones de trabajo para que cada usuario tenga su propia copia.

Ahora ha dividido correctamente la base de datos, lo que mejorará el rendimiento. En este momento, cuando un usuario abre un formulario, se abre localmente en el equipo y no se envía a través de la red. Los únicos datos que vienen a través de la red son los de las tablas vinculadas.

Razones para dividir una base de datos

A continuación se enumeran las razones típicas para dividir una base de datos:
  • Comparte una base de datos con varios usuarios de una red.
  • Hay varias personas desarrollando la base de datos y no tiene instalado Microsoft Visual Source Safe.
  • No desea que los usuarios puedan realizar cambios en el diseño de las tablas.
La razón más común para dividir una base de datos es que se comparta con varios usuarios de una red. Si simplemente almacena la base de datos en un recurso compartido de red, cuando los usuarios abran un formulario, consulta, macro, módulo o informe, estos objetos tendrán que enviarse a través de la red a cada individuo que utilice la base de datos. Si divide la base de datos, cada usuario tiene su propia copia de los formularios, consultas, macros, módulos e informes. Por consiguiente, los únicos datos que se deben enviar por la red son los de las tablas.

Nota: para dividir la base de datos, puede utilizar también la utilidad Divisor de base de datos.

Propiedades

Id. de artículo: 304932 - Última revisión: lunes, 26 de noviembre de 2007 - Versión: 5.1
La información de este artículo se refiere a:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
Palabras clave: 
kbinfo kbexpertiseinter kbhowto KB304932

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com