Microsoft Access에서 Access 데이터베이스를 수동으로 분할하는 방법

기술 자료 번역 기술 자료 번역
기술 자료: 304932 - 이 문서가 적용되는 제품 보기.
고급: 전문적인 코드 작성, 상호 운용성 및 다중 사용자 기술이 필요합니다.

이 문서의 내용은 Microsoft Access 데이터베이스 파일(.mdb 또는 .accdb)에 적용됩니다.
모두 확대 | 모두 축소

요약

다양한 이유로 프런트 엔드 응용 프로그램이나 백 엔드 응용 프로그램으로 데이터베이스를 수동으로 분할하도록 결정할 수 있습니다. 백 엔드 데이터베이스는 테이블을 포함하며 파일 서버에 저장됩니다. 백 엔드 테이블에 연결되는 프런트 엔드 데이터베이스에는 모든 폼, 쿼리, 보고서, 매크로 및 모듈이 포함되어 있습니다. 프런트 엔드 데이터베이스는 사용자의 워크스테이션에 배포됩니다.

이 문서에서는 데이터베이스 분할 유틸리티를 사용하는 대신 데이터베이스를 수동으로 분할하는 방법에 대해 설명합니다.

추가 정보

Microsoft Office Access 2003과 이전 버전의 Access에서 데이터베이스를 분할하려면 다음과 같이 하십시오.
  1. 빈 Access 데이터베이스를 새로 만듭니다.
  2. 파일 메뉴에서 외부 데이터 가져오기를 가리킨 다음 가져오기를 누릅니다.
  3. 분할할 데이터베이스를 찾아 선택합니다.
  4. 테이블 탭에서 모두 선택을 누른 다음 확인을 누릅니다.

    Access에서 모든 테이블을 백 엔드 데이터베이스인 새 데이터베이스로 가져옵니다.
  5. 새 백 엔드 데이터베이스를 네트워크 공유에 저장하고 모든 사용자가 공유에 대한 모든 권한을 갖고 있는지 확인합니다.
  6. 두 번째 빈 Access 데이터베이스를 새로 만듭니다.
  7. 파일 메뉴에서 외부 데이터 가져오기를 가리킨 다음 테이블 연결을 누릅니다.
  8. 방금 만든 백 엔드 데이터베이스를 선택합니다.
  9. 테이블 탭에서 모두 선택을 누른 다음 확인을 누릅니다.

    Access에서 백 엔드 데이터베이스의 테이블을 프런트 엔드 데이터베이스에 연결합니다.
  10. 파일 메뉴에서 외부 데이터 가져오기를 가리킨 다음 가져오기를 누릅니다.
  11. 분할할 원래 데이터베이스를 선택한 다음 가져오기를 누릅니다.
  12. 탭에서 모두 선택을 누릅니다. 테이블 탭을 제외한 모든 탭에서 이 단계를 반복합니다. 이미 테이블을 연결했기 때문에 나머지 개체를 가져오기만 하면 됩니다.
  13. 테이블을 제외한 모든 개체를 선택한 후 확인을 누릅니다.

    이제 모든 테이블이 연결되었고 나머지 개체를 가져왔습니다.
Microsoft Office Access 2007에서 데이터베이스를 분할하려면 다음과 같이 하십시오.
  1. 빈 Access 데이터베이스를 새로 만듭니다.
  2. 외부 데이터 탭의 가져오기 그룹에서 Access를 누릅니다.
  3. 외부 데이터 가져오기 대화 상자에서 찾아보기를 눌러 분할할 데이터베이스를 찾아 선택하고 테이블, 쿼리, 폼, 보고서, 매크로 및 모듈을 현재 데이터베이스로 가져옵니다. 확인란을 선택한 다음 확인을 누릅니다.
  4. 개체 가져오기 대화 상자의 테이블 탭에서 모두 선택을 누른 다음 확인을 누릅니다.

    Access에서 모든 테이블을 백 엔드 데이터베이스인 새 데이터베이스로 가져옵니다.
  5. 새 백 엔드 데이터베이스를 네트워크 공유에 저장하고 모든 사용자가 공유에 대한 모든 권한을 갖고 있는지 확인합니다.
  6. 두 번째 빈 Access 데이터베이스를 새로 만듭니다.
  7. 외부 데이터가져오기 그룹에서 Access를 누릅니다.
  8. 외부 데이터 가져오기 대화 상자에서 찾아보기를 눌러 방금 만든 백 엔드 데이터베이스를 선택하고 연결 테이블을 만들어 데이터 원본에 연결 확인란을 선택한 다음 확인을 누릅니다.
  9. 개체 가져오기 대화 상자의 테이블 탭에서 모두 선택을 누른 다음 확인을 누릅니다.

    Access에서 백 엔드 데이터베이스의 테이블을 프런트 엔드 데이터베이스에 연결합니다.
  10. 외부 데이터가져오기 그룹에서 Access를 누릅니다.
  11. 외부 데이터 가져오기 대화 상자에서 찾아보기를 눌러 분할할 원래 데이터베이스를 선택하고 테이블, 쿼리, 폼, 보고서, 매크로 및 모듈을 현재 데이터베이스로 가져옵니다. 확인란을 선택한 다음 확인을 누릅니다.
  12. 개체 가져오기 대화 상자의 탭에서 모두 선택을 누르고 테이블 탭을 제외한 다른 모든 탭에서 이 단계를 반복합니다. 테이블을 이미 연결했기 때문에 이제 나머지 개체를 가져오기만 하면 됩니다. 이렇게 한 다음 확인을 누릅니다.

    이제 모든 테이블이 연결되었고 나머지 개체를 가져왔습니다.
참고

이 데이터베이스는 프런트 엔드 데이터베이스입니다. 각 사용자가 고유한 프런트 엔드 데이터베이스 사본을 가질 수 있도록 이 프런트 엔드 데이터베이스를 워크스테이션에 배포할 수 있습니다.

이제 데이터베이스를 성공적으로 분할했으므로 성능이 향상됩니다. 사용자가 폼을 열면 폼이 컴퓨터에서 로컬로 열리고 네트워크를 통해 전송되지 않습니다. 네트워크를 통해 전송되는 데이터는 연결된 테이블의 데이터뿐입니다.

데이터베이스를 분할하는 이유

데이터베이스를 분할하는 일반적인 이유는 다음과 같습니다.
  • 네트워크에서 여러 사용자와 데이터베이스를 공유합니다.
  • 몇 명의 사용자가 데이터베이스에서 개발하고 있고 Microsoft Visual Source Safe가 설치되어 있지 않습니다.
  • 사용자가 테이블의 디자인을 변경하지 못하게 하려고 합니다.
데이터베이스를 분할하는 가장 일반적인 이유는 네트워크에서 여러 사용자와 데이터베이스를 공유하기 때문입니다. 네트워크 공유에 데이터베이스를 저장하면 사용자가 폼, 쿼리, 매크로, 모듈 또는 보고서를 열 때 이러한 개체가 데이터베이스를 사용하는 각 사용자에게 네트워크를 통해 전송되어야 합니다. 데이터베이스를 분할하면 각 사용자가 고유한 폼, 쿼리, 매크로, 모듈 및 보고서 사본을 갖게 됩니다. 따라서 네트워크를 통해 전송되어야 하는 데이터는 테이블의 데이터뿐입니다.

참고 데이터베이스 분할 유틸리티를 사용하여 데이터베이스를 분할할 수도 있습니다.



Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 304932 - 마지막 검토: 2008년 1월 22일 화요일 - 수정: 5.2
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
키워드:?
kbinfo kbexpertiseinter kbhowto KB304932

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com