Como dividir um banco de dados do Access manualmente no Microsoft Access

Traduções deste artigo Traduções deste artigo
ID do artigo: 304932 - Exibir os produtos aos quais esse artigo se aplica.
Avançado: requer especialização em codificação, interoperabilidade e habilidades de multiusuário.

Este artigo se aplica a um arquivo (.mdb) ou a um arquivo (.accdb) do banco de dados do Microsoft Access.
Expandir tudo | Recolher tudo

Sumário

Por vários motivos, pode ser necessário dividir o banco de dados em um aplicativo front-end ou um aplicativo back-end. O banco de dados back-end contém as tabelas e é armazenado em um servidor de arquivo. O banco de dados front-end, que vincula as tabelas back-end, contém todos os formulários, as consultas, os relatórios, as macros e os módulos. O banco de dados front-end é distribuído para as estações de trabalho dos usuários.

Este artigo descreve como dividir manualmente o banco de dados em vez de usar o utilitário Divisor de banco de dados.

Mais Informações

Para dividir o banco de dados no Microsoft Office Access 2003 e em versões anteriores do Access, siga essas etapas:
  1. Crie um novo banco de dados em branco no Access.
  2. No menu Arquivo, aponte para Obter dados externos e clique em Importar.
  3. Localize e selecione o banco de dados que deseja dividir.
  4. Na guia Tabelas, clique em Selecionar tudo e clique em OK.

    Observe que o Access importa todas as tabelas para o novo banco de dados, ou seja, para o seu banco de dados back-end.
  5. Armazene o novo banco de dados back-end em um compartilhamento de rede e verifique se todos os usuários têm permissões completas para o compartilhamento.
  6. Crie um segundo banco de dados em branco no Access.
  7. No menu Arquivo, aponte para Obter dados externos e clique em Vincular tabelas.
  8. Selecione o banco de dados back-end que você acabou de criar.
  9. Na guia Tabelas, clique em Selecionar tudo e clique em OK.

    Observe que o Access vincula as tabelas no banco de dados back-end ao banco de dados front-end.
  10. No menu Arquivo, aponte para Obter dados externos e clique em Importar.
  11. Selecione o banco de dados original que você está dividindo e clique em Importar.
  12. Na guia Formulários, clique em Selecionar tudo. Repita essa etapa em todas as guias, exceto na guia Tabelas. Como todas as tabelas já foram vinculadas, será necessário importar apenas o restante dos objetos.
  13. Após selecionar todos os objetos, exceto as tabelas, clique em OK.

    Observe que todas as tabelas estão vinculadas e os objetos remanescente já foram importados.
Para dividir o banco de dados no Microsoft Office Access 2007, execute as seguintes etapas:
  1. Crie um novo banco de dados em branco no Access.
  2. Na guia Dados Externos, clique em Access no grupo Importar.
  3. Na caixa de diálogo Obter dados externos, clique em Procurar para localizar e selecionar o banco de dados que deseja dividir, marque a caixa de seleção Importar tabelas, consultas, formulários, relatórios, macros e módulos no banco de dados atual. e clique em OK.
  4. Na caixa de diálogo Importar objetos, clique em Selecionar tudo na guia Tabelas e clique em OK.

    Observe que o Access importa todas as tabelas para o novo banco de dados, ou seja, para o seu banco de dados back-end.
  5. Armazene o novo banco de dados back-end em um compartilhamento de rede e verifique se todos os usuários têm permissões completas para o compartilhamento.
  6. Crie um segundo banco de dados em branco no Access.
  7. Na guia Dados Externos, clique em Access no grupo Importar.
  8. Na caixa de diálogo Obter dados externos, clique em Procurar para selecionar o banco de dados que você criou, marque a caixa de seleção Vincular à fonte de dados criando uma tabela vinculada. e clique em OK.
  9. Na caixa de diálogo Importar objetos, clique em Selecionar tudo na guia Tabelas e clique em OK.

    Observe que o Access vincula as tabelas no banco de dados back-end ao banco de dados front-end.
  10. Na guia Dados Externos, clique em Access no grupo Importar.
  11. Na caixa de diálogo Obter dados externos, clique em Procurar para selecionar o banco de dados original que você está dividindo, marque a caixa de seleção Importar tabelas, consultas, formulários, relatórios, macros e módulos no banco de dados atual e clique em OK.
  12. Na caixa de diálogo Importar Objetos, clique em Selecionar tudo na guia Formulários, repita essa etapa em todas as outras guias, exceto na guia Tabelas, pois as tabelas já foram vinculadas. Agora você precisa importar somente o restante dos objetos e, em seguida, clicar em OK.

    Observe que todas as tabelas estão vinculadas e os objetos remanescente já foram importados.
Observações

Este banco de dados é o banco de dados front-end. É possível distribuir este banco de dados front-end para as estações de trabalho, a fim de que cada usuário tenha a sua própria cópia do banco de dados front-end.

A divisão do banco de dados realizada com sucesso, aperfeiçoará o desempenho. Agora quando um usuário abrir um formulário, o formulário será aberto localmente no computador dele e não será enviado pela rede. Os únicos dados que estarão na rede serão os dados contidos nas tabelas vinculadas.

Motivos pelos quais é aconselhável dividir o seu banco de dados

Razões típicas para dividir um banco de dados:
  • Você compartilha o seu banco de dados com vários usuários em uma rede.
  • Há diversas pessoas desenvolvendo o banco de dados e o Microsoft Visual Source Safe não está instalado.
  • Você não quer que os usuários façam alterações no design das tabelas.
A razão mais comum para dividir um banco de dados é o compartilhamento do banco de dados com vários usuários em uma rede. Se você simplesmente armazenar o banco de dados em um compartilhamento de rede, quando os usuários abrirem um formulário, uma consulta, uma macro, um módulo ou um relatório, esses objetos terão que ser enviados pela rede para cada pessoa que utiliza o banco de dados. Se você dividir o banco de dados, cada usuário terá a sua própria cópia dos formulários, consultas, macros, módulos e relatórios. Portanto, os únicos dados que estarão na rede serão os dados contidos nas tabelas.

Observação Para dividir o banco de dados, você também pode usar o utilitário Divisor de banco de dados.

Propriedades

ID do artigo: 304932 - Última revisão: segunda-feira, 3 de dezembro de 2007 - Revisão: 5.1
A informação contida neste artigo aplica-se a:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbinfo kbexpertiseinter kbhowto KB304932

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com