Scripts May Not Run Before Windows Explorer Starts Even Though the "Run Logon Scripts Synchronously" Setting is Enabled

Article translations Article translations
Article ID: 304970 - View products that this article applies to.
This article was previously published under Q304970
Expand all | Collapse all

SYMPTOMS

After you enable the Run logon scripts synchronously policy setting, Windows Explorer opens before the scripts run. The Explain tab in the Run logon scripts synchronously setting describes the setting as follows:
Directs the system to wait for the logon scripts to finish running before it starts the Windows Explorer interface program and creates the desktop.

CAUSE

This issue occurs because a logon performance enhancement is enabled by default in Windows XP. This enhancement causes the computer to not wait for Group Policy processing before the user environment is initialized.

RESOLUTION

To resolve this issue, disable the logon performance enhancement by enabling the Always wait for the network at computer startup and logon Group Policy setting:
  1. Open the appropriate Group Policy object for the computer or computers on which you want to implement the change.
  2. In the left pane, click to expand the following items:
    • Computer Configuration
    • Administrative Templates
    • System
    • Logon

  3. Double-click the Always wait for the network at computer startup and logon setting.
  4. Click Enable, and then click OK.

MORE INFORMATION

For additional information about the Fast Logon Optimization feature, click the following article number to view the article in the Microsoft Knowledge Base:
305293 Description of the Windows XP Professional Fast Logon Optimization Feature

Properties

Article ID: 304970 - Last Review: November 7, 2003 - Revision: 1.2
APPLIES TO
  • Microsoft Windows XP Professional
Keywords: 
kbenv kbgrppolicyprob kbprb KB304970

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com