Help and Support

文書番号: 305153 - 最終更新日: 2005年3月18日 - リビジョン: 5.1

Internet Explorer で .pdf ファイルを開こうとすると、Adobe Acrobat Reader で表示される代わりに、プレースホルダ アイコンのみの空白のページが表示される

この記事は、以前は次の ID で公開されていました: JP305153
すべて展開する | すべて折りたたむ

現象

Internet Explorer で .pdf (Portable Document Format) ファイルを開こうとしたときに、Adobe Acrobat Reader で表示されずに、プレースホルダ アイコンのみの空白のページが表示されることがあります。

原因

この現象は、.pdf ファイルへの URI (Uniform Resource Identifier) の最後が ".pdf" になっておらず、サーバーから返された content-type の MIME (Multipurpose Internet Mail Extensions) ヘッダーが "unknown/unknown" になっているか、content-length ヘッダーが返されなかった場合に発生します。URI の最後が ".pdf" になっていないケースは、スクリプトを通じてファイルが開かれた場合や、動的にファイルが生成された場合に発生します。ただし、Netscape スタイルのプラグインをサポートしている以前のバージョンの Internet Explorer では、content-type ヘッダーがない場合も .pdf ファイルを正常に開くことができます。

解決方法

この現象を回避するには、.pdf ファイルへのリンクを右クリックし、[対象をファイルに保存] をクリックして .pdf ファイルをローカルのコンピュータに保存します。.pdf ファイルをローカルに保存した後、そのファイルをダブルクリックすることによって、Adobe Acrobat Reader で開くことができます。

この問題を解決するには、Web サイトの作成者または管理者に問い合わせてください。Web サイトの作成者または管理者は、content-type ヘッダー (MIME タイプ) に "application/pdf" を設定し、適切な content-length ヘッダーを返すように Web サーバーを構成することによって、この問題を解決できます。この解決方法の詳細については、使用している Web サーバーのドキュメントを参照してください。

Microsoft Internet Information Server 4.0 またはインターネット インフォメーション サービス 5.0 で MIME タイプを追加、編集する方法については、次のマイクロソフト Web サイトを参照してください。
IIS の MIME タイプ
http://www.microsoft.com/japan/technet/prodtechnol/windows2000serv/technologies/iis/iis5/maintain/featusability/mimeiis.asp (http://www.microsoft.com/japan/technet/prodtechnol/windows2000serv/technologies/iis/iis5/maintain/featusability/mimeiis.asp)
HTTP ヘッダーの関連情報については、次のマイクロソフト Web サイトを参照してください。
HTTP ヘッダーのリファレンス
http://www.microsoft.com/japan/msdn/library/ja/act/htm/actml_ref_href.asp (http://www.microsoft.com/japan/msdn/library/ja/act/htm/actml_ref_href.asp)

状況

この動作は仕様です。

詳細

この動作の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
303401? (http://support.microsoft.com/kb/303401/ ) Internet Explorer をアップグレードした後 Netscape 形式のプラグインが動作しない

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 305153? (http://support.microsoft.com/kb/305153/EN-US/ ) (最終更新日 2005-01-05) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 6.0?を以下の環境でお使いの場合
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Professional x64 Edition
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
キーワード:?
kbprb KB305153
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Related Support Centers