Artigo: 305153 - Última revisão: sexta-feira, 20 de Maio de 2005 - Revisão: 5.1 O Internet Explorer abre uma página em branco com um ícone de marcador de posição em vez de um ficheiro .pdf no Adobe Acrobat Reader
Sintomas
O Internet Explorer pode apresentar uma página em branco com um ícone de marcador de posição em vez de apresentar um ficheiro em formato .pdf (Portable Document Format) com o Adobe Acrobat Reader.
Causa
Este comportamento ocorre porque o URI (Uniform Resource Identifier) do ficheiro .pdf não termina com ".pdf" (por exemplo, o ficheiro é aberto através de script ou é gerado de forma dinâmica) e o cabeçalho do tipo de conteúdo (tipo de extensões de correio da Internet de múltiplas finalidades [MIME, Multipurpose Internet Mail Extensions]) que é devolvido pelo servidor é "desconhecido/desconhecido" ou não é devolvido nenhum cabeçalho de comprimento do conteúdo. Note que as versões anteriores do Internet Explorer que suportam plug-ins do tipo do Netscape podem abrir o ficheiro .pdf sem um cabeçalho de tipo de conteúdo.
Resolução
Para contornar este comportamento, clique com o botão direito do rato na hiperligação para o ficheiro .pdf e clique em Guardar destino como para guardar o ficheiro no computador. Após efectuar este procedimento, pode fazer duplo clique no ficheiro .pdf guardado localmente para o abrir com o Adobe Acrobat Reader. Para resolver este comportamento, contacte o autor ou o administrador do Web site. Os autores ou administradores dos Web sites podem resolver este problema se configurarem os servidores da Web para enviarem um cabeçalho do tipo de conteúdo (tipo MIME) de "aplicação/pdf" para ficheiros .pdf e um cabeçalho de comprimento de conteúdo adequado. (Para obter informações sobre como efectuar este procedimento, consulte a documentação do servidor da Web que está a ser utilizado.) Para adicionar ou modificar tipos de MIME no Microsoft IIS (Serviços de informação Internet - Internet Information Services) 4.0 ou 5.0, consulte o seguinte Web site da Microsoft: MIME Types in IIS
Para obter informações sobre cabeçalhos de HTTP, consulte o seguinte Web site da Microsoft:
http://www.microsoft.com/technet/prodtechnol/windows2000serv/technologies/iis/maintain/featusability/mimeiis.mspx (http://www.microsoft.com/technet/prodtechnol/windows2000serv/technologies/iis/maintain/featusability/mimeiis.mspx) HTTP Headers Reference http://msdn.microsoft.com/library/default.asp?url=/library/en-us/act/htm/actml_ref_href.asp (http://msdn.microsoft.com/library/default.asp?url=/library/en-us/act/htm/actml_ref_href.asp) Ponto Da Situação
Este comportamento ocorre por predefinição.
Mais InformaçãoPara obter informações adicionais sobre este comportamento, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
303401
(http://support.microsoft.com/kb/303401/PT/
)
As extensões do tipo do Netscape não funcionam após a actualização do Internet Explorer A informação contida neste artigo aplica-se a:
| Outros Recursos Outros Sites de Suporte
ComunidadesObtenha Ajuda AgoraTraduções de Artigos
|






Windows Live
Facebook
Twitter
Linkedin
Digg it
Yahoo
Delicious
StumbleUpon
Yammer
Reddit
Technorati
FriendFeed
Email
Voltar ao topo