Aparece un error "No se puede mostrar la página" al superarse el tiempo de espera de la sesión del servidor SSL 3.0

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Id. de artículo: 305217 - Ver los productos a los que se aplica este artículo
Importante
Este artículo contiene información sobre cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986 Definición del Registro de Microsoft Windows
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Síntomas

Cuando Internet Explorer versión 5.5 Service Pack 1 o posterior intenta PUBLICAR (con POST) datos u OBTENER (con GET) datos desde una conexión HTTPS con el comando connect, Internet Explorer genera un mensaje de error que indica que la página no ha podido mostrarse. Este problema no se produce en Internet Explorer 5.5.

Causa

Este problema puede generarse cuando el servidor Web emite una alerta de cierre de SSL 3.0 si el puerto se cierra en el servidor, posiblemente debido a que se ha superado el tiempo de espera de la sesión. La alerta de cierre se envía a través de un paquete Zero Byte Encrypted; sin embargo, el mensaje de cierre completo se crea con dos paquetes diferentes. La alerta de cierre llega con los indicadores TCP ".AP..." (Ack Push) para comunicar al programa que la sesión de SSL 3.0 se está cerrando y otro paquete con los indicadores TCP ".A...F" (Ack Fin) para indicar a la capa TCP que cierre el puerto en el equipo cliente.

Como se produce la alerta de cierre y los indicadores RESET y FIN TCP no están definidos dentro de ese paquete, no hay ningún modo de que Wininet.dll determine que no se trata de datos del programa y, por este motivo, el puerto de mantenimiento de conexiones activas se deja abierto en el cliente hasta la siguiente activación de recepción de socket.

Esto provoca el problema, ya que Internet Explorer tiene dos puertos de mantenimiento de conexiones activas abiertos al servidor y el número de reintentos es igual a 2. Cuando se produce la recepción de socket tras el primer intento para enviar datos, la alerta de cierre de SSL 3.0 se procesa y el cierre TCP se procesa también ocasionando que el primer puerto de mantenimiento de conexiones activas se cierre y que el contador de reintentos que quedan disminuya en uno. Como el número de reintentos no es 0, existe otro intento de POST que emplea el segundo puerto de mantenimiento de conexiones activas. Sin embargo, esto tampoco funciona porque también se ha cerrado en el servidor (de nuevo la alerta de cierre de SSL 3.0 y los paquetes de cierre TCP para este segundo puerto tal como se procesaron en la recepción de socket para el puerto) y el contador de reintentos que quedan se reduce nuevamente. En este punto, el número de reintentos que quedan es 0 y se genera el mensaje de error que indica que la página no ha podido mostrarse.

Solución

Información de Service Packs

Se ha cambiado el código para intentar reducir el número de errores que se ven con las alertas de cierre de SSL 3.0 e Internet Explorer. Para aprovechar este cambio, obtenga el Service Pack más reciente para Microsoft Windows 2000. Para obtener más información al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910 Cómo obtener el Service Pack más reciente para Windows 2000

Información de revisiones

Ahora hay disponible una revisión que mitiga el problema, pero sólo es apropiada para corregir el problema descrito en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión puede ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, se recomienda que espere al próximo Service Pack de Internet Explorer 6 que contenga esta revisión.

Para solicitar esta revisión inmediatamente, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtenerla. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico de Microsoft, así como información acerca de los costos de soporte técnico, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota
En casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas y temas de soporte técnico adicionales que no reúnan las condiciones necesarias para la actualización en cuestión.

Importante
Instale la revisión acumulativa de febrero de 2003 para Internet Explorer antes de instalar esta corrección. Para obtener más información acerca de esta actualización, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
810847 Febrero de 2003, Revisión acumulativa para Internet Explorer
Si instaló esta corrección antes de instalar la revisión acumulativa de febrero de 2003 para Internet Explorer, debe reinstalar la corrección.

Internet Explorer 5.01 en Windows 2000 Service Pack 3

La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.

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FechaHoraVersiónTamañoNombre de archivo
13-Ene-200310:035.0.3513.1300461.072Wininet.dll

Internet Explorer 5.5 Service Pack 2

La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.

Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
13-Ene-200310:345.50.4925.1300482.064Wininet.dll

Internet Explorer 6

La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.

Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
13-Ene-200310:056.0.2725.1300583.680Wininet.dll

Internet Explorer 6 Service Pack 1

La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.

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FechaHoraVersiónTamañoNombre de archivo
13-Ene-200309:346.0.2800.1157585.728Wininet.dll

Solución

Puede utilizar uno de los métodos siguientes para evitar este problema:
  • Deshabilite las alertas de cierre de SSL 3.0 en el servidor.
  • Cambie el valor del tiempo de espera de mantenimiento de conexión Iplanet de 30 a 300 segundos.
Para obtener más información acerca de cómo configurar este valor, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
183110 WinInet limita las conexiones por servidor

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Advertencia
Pueden producirse graves problemas si modifica incorrectamente el Registro mediante el Editor del Registro o con cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Después de instalar la revisión, puede que todavía observe errores. La revisión sólo pretende atenuar el problema. Para intentar resolver los errores que pueden observarse después de instalar la revisión, establezca las claves DWORD siguientes en el Editor del Registro con un valor igual, como 4:
  • MaxConnectionsPerServer
  • MaxConnectionsPer1_0Server
Para ello, siga estos pasos:
  1. Haga clic en Inicio y en Ejecutar, escriba regedit y haga clic en Aceptar.
  2. Busque la siguiente subclave del Registro y haga clic en ella:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
  3. Si no ve las subclaves MaxConnectionsPerServer o MaxConnectionsPer1_0Server, agréguelas. Para ello, siga estos pasos:
    1. En el menú Edición, seleccione Nuevo y haga clic en DWORD.
    2. Escriba MaxConnectionsPerServer y presione ENTRAR.
    3. Escriba MaxConnectionsPer1_0Server y presione ENTRAR.
Nota
Si cambia esta configuración, puede hacer que WinInet vaya contra la recomendación de la especificación del protocolo HTTP. Sólo debe hacer esto si es necesario. Entonces, debería evitar explorar el Web de su forma habitual mientras esta configuración esté en vigor.

Microsoft está revisando este comportamiento y buscando una solución más viable para los futuros productos.

Para saber si está experimentando un problema con las alertas de cierre de SSL 3.0 en Internet Explorer, siga estos pasos:
  1. En el servidor, desactive SSL 3.0 y, a continuación, active SSL 2.0 para evitar que se envíen las alertas de cierre.
  2. En el cliente, configure el valor de MaxConnectionsPerServer en 1.
Microsoft proporciona información de contacto con otros proveedores para ayudarle a encontrar soporte técnico. Esta información de contacto puede cambiar sin previo aviso. Microsoft no ofrece ninguna garantía con respecto a la exactitud de esta información de contacto con otros proveedores.

Propiedades

Id. de artículo: 305217 - Última revisión: martes, 26 de diciembre de 2006 - Versión: 13.3
La información de este artículo se refiere a:
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0
Palabras clave: 
kbhotfixserver kbqfe kbwin2ksp4fix kbbug kbenv kberrmsg kbfix kbie550presp2fix KB305217

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