スタンバイからの再開後に USB デバイスが動作を停止する

文書翻訳 文書翻訳
文書番号: 305933 - 対象製品
この記事は、以前は次の ID で公開されていました: JP305933
すべて展開する | すべて折りたたむ

現象

コンピュータをスタンバイ状態から再開すると、すべてのポートで USB (Universal Serial Bus) デバイスが正しく検出されず、再列挙されなくなる場合があります。また、コンピュータがスタンバイ状態になっている間にデバイスを交換しても、コンピュータの再開後に新しいデバイスが正しく動作しないことがあります。

USB ホスト コントローラ ルート ハブに接続されたデバイスでは、この問題の発生する可能性が低くなります。デバイス マネージャを使用すると、デバイスがどのように接続されているかを確認できます ([表示] メニューの [デバイス (接続別)] をクリックし、[PCI バス] 以下にある USB ホスト コントローラ オブジェクトの階層を展開します)。デバイス マネージャは、コントロール パネルの [システム] ツールの [ハードウェア] タブから起動できます。

原因

この問題は、再開処理中に送信されるポートから USB バスへの通知が比較的遅い場合に、USB ハブ ドライバ (Usbhub.sys) がポートを認識しなくなるために発生します。

解決方法

この問題を解決するには、Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法
修正プログラム (英語版) の属性は次のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。
   日付            時刻    バージョン        サイズ   ファイル名
   -----------------------------------------------------
   22-Aug-2001  10:38  5.0.2195.4211  39,920  Usbhub.sys
				

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。 この問題は、Windows 2000 Service Pack 3 で最初に修正されました。

詳細

Windows 2000 Datacenter Server 用の修正プログラムを入手する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
265173 Datacenter Program と Windows 2000 Datacenter Server
複数の修正プログラムのインストールを 1 回の再起動のみで行う方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
296861 複数の Windows 更新プログラムまたは修正プログラムを同時にインストールし、再起動を 1 回で済ませる方法
Windows 2000 と Windows 2000 の修正プログラムを同時にインストールする方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
249149 Microsoft Windows 2000 および Windows 2000 ホットフィックスのインストール

プロパティ

文書番号: 305933 - 最終更新日: 2006年3月24日 - リビジョン: 3.2
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
キーワード:?
kbbug kbfix kbwin2000presp3fix kbqfe kbwin2000sp3fix kboswin2000fix kbhotfixserver KB305933
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com