Come creare aggiuntivi di COM di Office mediante VBA e Office Developer

Traduzione articoli Traduzione articoli
Identificativo articolo: 306130 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo viene descritto come visualizzare un form utente che l'apertura della prima quando si avvia Microsoft Excel o Microsoft Word. I componenti componente Object Model (COM) aggiuntivi forniscono un mezzo per centralizzare il codice comune in una compilato libreria a collegamento dinamico (DLL) che pu˛ essere facilmente implementata in Office in qualsiasi applicazione (ad esempio, Ŕ possibile accedere contatti di Microsoft Outlook da Excel, Word e Microsoft Access). Il modo pi¨ semplice per sviluppare una DLL COM in Microsoft Office consiste lavorare a un progetto componente aggiuntivo, che fornisce una finestra di progettazione e un riferimento alla libreria di IDTExtensibility2 .

Requisiti

In questo articolo si presume la conoscenza dei seguenti argomenti:

  • Creazione per le procedure, Applications Edition (VBA) in un'applicazione di Office di Visual Basic.
  • Lavorare con i form in VBA.
  • Personalizzazione barre degli strumenti di Office XP.

Creare un progetto componente aggiuntivo

╚ possibile creare un progetto di componente aggiuntivo in qualsiasi applicazione di Microsoft Office 2000 o Microsoft Office XP quando si dispone di Microsoft Office 2000 Developer o installati gli strumenti di Microsoft Office XP Developer. In questo esempio viene utilizzato Microsoft Word 2002.
  1. Avviare Microsoft Word 2002.
  2. Scegliere macro dal menu Strumenti , quindi Visual Basic Editor .
  3. In Visual Basic Editor (VBE), scegliere Nuovo progetto dal menu file .
  4. Nella finestra di dialogo Nuovo progetto , fare clic su Progetto componente aggiuntivo . Questo fornisce automaticamente Add-in Designer.
  5. Se la finestra proprietÓ non Ŕ visibile, scegliere Finestra ProprietÓ dal menu Visualizza .
  6. Nella finestra ProprietÓ, rinominare il progetto da AddInDesigner1 per WelcomeAddIn.
  7. Dal menu Inserisci , scegliere UserForm per inserire un form utente.
  8. Dalla casella degli strumenti, aggiungere un'etichetta e un pulsante di comando al modulo utente.
  9. Nella finestra ProprietÓ, modificarne gli attributi ai controlli di corrispondono ai valori nella tabella riportata di seguito:
    Riduci questa tabellaEspandi questa tabella
    controllo ProprietÓ valore
    EtichettaNomelblMessaggio
    DidascaliaBenvenuti
    Tipo di carattere14pt
    ProprietÓ AutoSizeTrue
    Controllo CommandButtonNomecmdOK
    DidascaliaOK
    Form utenteNomefrmWelcome

  10. Dal menu Inserisci , scegliere modulo per inserire un modulo standard.
  11. Aggiungere la seguente dichiarazione della variabile stringa globale al modulo standard:
    Public gstrUserName As String
    'This variable will be used to store the name of the user as defined
    'in the Options dialog boxes (from the Tools menu) in Word and Excel.
    					
  12. Nel modulo, aggiungere il codice riportato di seguito per creare una routine Sub pubblica denominata DisplayForm per visualizzare il form sullo schermo:
    Public Sub DisplayForm()
      frmWelcome.Show vbModal
    End Sub
    					
  13. Visualizzare la finestra del codice per il form frmWelcome e aggiungere il codice riportato di seguito all'evento UserForm_Initialize per concatenare la didascalia di etichetta con la variabile di stringa:
    lblMessage.Caption = lblMessage.Caption & " " & gstrUserName
    					
  14. Aggiungere il seguente codice all'evento Click per il controllo CommandButton cmdOK scaricare il modulo:
    Unload me
    					

Modificare le proprietÓ di progettazione aggiuntivo

Attenersi alla seguente procedura per modificare le proprietÓ della finestra di progettazione in modo che il componente aggiuntivo verrÓ avviata non appena viene avviato Microsoft Excel:
  1. In Esplora progetti, fare doppio clic sul componente per restituire alla progettazione del componente aggiuntivo.
  2. Nella scheda Generale della finestra di progettazione, modificare le proprietÓ della finestra di progettazione in base ai valori nella tabella seguente:
    Riduci questa tabellaEspandi questa tabella
    ProprietÓ valore
    Nome visualizzato addInFunFormMessage
    Descrizione addInQuesto contiene il codice Ŕ specifico di Excel
    ApplicazioneMicrosoft Excel
    Versione applicazioneMicrosoft Excel 10.0
    Caricamento inizialeAvvio

Implementare gli eventi di IDTExtensibility2

  1. Dal menu Visualizza scegliere codice per visualizzare il modulo di codice dietro la finestra di progettazione.
  2. Dal menu Strumenti , fare clic su riferimenti e impostare un riferimento a Microsoft Excel oggetto libreria.
  3. Nell'elenco a discesa oggetto , fare clic su AddinInstance . Nell'elenco a discesa routine , fare clic su OnConnection .

    Questo evento Ŕ utile per la creazione di un pulsante CommandBar o per associare il codice a un evento, ad esempio un evento di applicazione quando Ŕ connesso all'applicazione host.
  4. Aggiungere il codice riportato di seguito alla routine evento AddinInstance_OnConnection per memorizzare il nome utente nella variabile globale strUserName e chiamare la routine DisplayForm :
    gstrUserName = Application.UserName
    DisplayForm
    					
  5. In VBE, fare clic su Salva e denominare il progetto Welcome.vba.

Aggiungere una seconda finestra di progettazione

In questa procedura, viene aggiunto una seconda finestra di progettazione per implementare la stessa funzionalitÓ in Microsoft Word.
  1. Creare un altro progetto componente aggiuntivo in VBE. Per impostazione predefinita viene creato AddInProject2.
  2. In Esplora progetti, trascinare Aggiungi nuovo - in progettazione interfaccia ( AddInDesigner1 ) nel progetto componente aggiuntivo esistente. SarÓ presente due finestre di progettazione nel progetto.
  3. In Esplora progetti fare clic con il pulsante destro del mouse su AddInProject2 e quindi fare clic su Chiudi progetto per rimuovere il progetto appena creato.
  4. Quando viene visualizzato il messaggio riportato di seguito o simile
    AddInProject2 progetto Ŕ stato modificato. Salvarlo?
    Fare clic su No .
  5. Modificare le proprietÓ della finestra di progettazione per specificare Word 10 come l'applicazione di destinazione e caricare all'avvio .
  6. Aggiungere il codice riportato di seguito routine di evento AddinInstance_OnConnection nuovo Word della finestra di progettazione, corrisponde al codice di evento OnConnection della finestra di progettazione Excel precedentemente scritto:
    gstrUserName = Application.UserName
    DisplayForm
    					

Eseguire il debug del componente aggiuntivo

  1. Se si preferisce, Ŕ possibile aggiungere punti di interruzione appropriati al codice.
  2. In VBE, Ŕ necessario scegliere Esegui progetto dal menu Esegui per eseguire il componente aggiuntivo.
  3. Avviare Microsoft Excel. Quando viene avviato il progetto, potrai vedere una finestra di dialogo per la finestra di progettazione AddIn. Selezionare l'opzione per avviare un'applicazione e individuare Excel.exe. Se questa finestra di dialogo non viene visualizzato, fare clic su Start , scegliere programmi e quindi fare clic su Microsoft Excel per avviare Excel. VerrÓ visualizzato il form.
  4. Se COM Add-in Manager non Ŕ giÓ disponibile, aggiungere come indicato di seguito il comando di Inserire una barra degli strumenti:
    1. Nel menu Strumenti , fare clic su Personalizza .
    2. Nella finestra di dialogo Personalizza , nella scheda comandi trascinare il comando Inserire dalla categoria Strumenti su una barra degli strumenti o su oggetto CommandBarPopup Strumenti dal menu dei comandi.
  5. Fare clic sulla barra comando Inserire per visualizzare il COM aggiuntivo Manager (CAM). L'elenco nel CAM Visualizza tutti i componenti aggiuntivi caricati.
  6. Per verificare l'evento OnConnection , deselezionare l'iniziale aggiuntivo casella di controllo il CAM e quindi fare clic su OK . Visualizzare nuovamente il CAM, selezionare la casella di controllo iniziale e quindi fare clic su OK . Il form dovrebbe essere visualizzato nuovamente.
  7. Chiudere l'applicazione host (Word o Excel), quindi Interrompi progetto dal menu Run in VBE per interrompere l'esecuzione del progetto.

Verificare che il componente aggiuntivo Works

A questo punto Ŕ possibile compilare il componente aggiuntivo e verificarne il corretto funzionamento in un altro computer.
  1. Salvare il progetto in VBE. Questa Ŕ la versione modificabile. Lo stato compilato non consente di apportare modifiche.
  2. Dal menu file , fare clic su Crea Welcome.DLL .
  3. Consente di utilizzare il comando regsvr32 per registrare la DLL nel modo seguente:
    1. Dal menu Start , scegliere Esegui .
    2. Nella casella di testo Apri , digitare il testo riportato di seguito:
      regsvr32 < percorso > \Welcome.DLL
      dove < percorso > Ŕ il percorso file di sistema della DLL.
  4. Fare clic su OK per confermare la registrazione delle DLL.
  5. Eseguire Excel e/o Word. VerrÓ visualizzato il form. Se non viene visualizzato il form, scegliere COM AddIns dal menu Strumenti e quindi selezionare la casella di controllo iniziale .
Nota : il modo pi¨ semplice per distribuire la DLL consiste nell'utilizzare la creazione guidata di distribuzione di pacchetti di.

Risoluzione dei problemi

  • Assicurarsi di scrivere codice breve, efficace per quando il componente aggiuntivo viene caricato in memoria. Ad esempio, se l'evento OnConnection manipola i dati del database all'avvio, verranno considerare gli utenti che il computer non risponde (bloccato).
  • Prestare attenzione quando si utilizza un UserForm. Se l'utente fa clic sull'applicazione host, l'utente potrebbe pensare che l'utente ha perso il modulo perchÚ Ŕ nascosto dietro l'applicazione host. Invece i moduli rendere modale per risolvere il problema. Per rendere un form a scelta obbligatoria, utilizzare la costante vbModal come segue:
    frmMyUserForm.Show vbModal
    						
    per visualizzare dove si inserisce il codice in riferimento a questo esempio, vedere il codice nel passaggio 12 della sezione Create an Add-In Project.

Riferimenti

Fare riferimento al \Samples\Working con AddIns\VBA_COM_AddIn cartella del CD di Office XP Developer per un modello AddIn.

Per ulteriori informazioni sulla creazione di pulsanti CommandBar, visitare il seguente sito Web MSDN (informazioni in lingua inglese):
http://msdn.microsoft.com/en-us/library/aa140930.aspx

ProprietÓ

Identificativo articolo: 306130 - Ultima modifica: mercoledý 14 luglio 2004 - Revisione: 4.5
Le informazioni in questo articolo si applicano a:
  • Microsoft Office XP Developer Edition
  • Microsoft Office XP Professional
Chiavi:á
kbmt kbhowtomaster KB306130 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 306130
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com