Jak utworzyć przy użyciu języka VBA i deweloperów pakietu Office Office dodatków COM

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 306130 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

W tym artykule opisano sposób wyświetlania UserForm, z zadowoleniem przyjmuje użytkownik podczas uruchamiania programu Microsoft Excel lub Microsoft Word. Obiekt składnika Model (COM) dodatki zapewniają środki do centralizacji typowych kodu w skompilowanych Biblioteka dołączana dynamicznie (DLL), które można łatwo zaimplementować w każdym urzędzie aplikacji (na przykład, można uzyskać dostęp kontakty programu Microsoft Outlook z programu Excel Program Word i Microsoft Access). Najprostszym sposobem opracowanie DLL modelu COM w programie Microsoft Pakiet Office jest do pracy z dodatku projektu, który zawiera projektanta i odniesienie do IDTExtensibility2 Biblioteka.

Wymagania

W tym artykule założono, że czytelnik jest obeznany z następującymi tematy:

  • Tworzenie kodu języka Visual Basic dla procedury Applications (VBA) aplikacja pakietu Office XP.
  • Praca z językowi VBA.
  • Dostosowywanie pasków narzędzi pakietu Office XP.

Tworzenie projektu-dodatek

Można utworzyć projektu dodaj dowolny pakiet Microsoft Office 2000 lub Aplikacji pakietu Microsoft Office XP, gdy program Microsoft Office Developer 2000 lub zainstalowane narzędzia Microsoft Office XP Developer. W tym przykładzie użyto Program Microsoft Word 2002.
  1. Uruchom program Microsoft Word 2002.
  2. Z Narzędzia menu, wskaż Makro, a następnie kliknij przycisk Edytor Visual Basic.
  3. W języku Visual Basic Editor (VBE), kliknij przycisk Nowy projekt na Plik menu.
  4. W Nowy projekt okno dialogowe, kliknij przycisk Dodawanie w programie Project. Zapewnia to automatycznie Projektant dodatku.
  5. Jeśli okno właściwości nie jest widoczny, kliknij przycisk Okno właściwości na Widok menu.
  6. W oknie właściwości Zmień nazwę projektu z AddInDesigner1 do WelcomeAddIn.
  7. Z Wstaw menu, kliknij przycisk Run Aby wstawić UserForm.
  8. W przyborniku, Dodaj etykietę i przycisku polecenia Run.
  9. W oknie Właściwości zmień atrybuty Formanty są zgodne z wartościami w poniższej tabeli:
    Zwiń tę tabelęRozwiń tę tabelę
    FormantWłaściwościWartość
    EtykietaNazwalblMessage
    Podpis-Zapraszamy!
    Czcionkiodległe
    Autodopasowanie rozmiaruPRAWDA
    Formant CommandButtonNazwacmdOK
    PodpisOK
    RunNazwafrmWelcome

  10. Z Wstaw menu, kliknij przycisk Moduł Aby wstawić moduł standardowy.
  11. Dodaj następujący ciąg globalnego deklaracja zmiennej do Standardowy moduł:
    Public gstrUserName As String
    'This variable will be used to store the name of the user as defined
    'in the Options dialog boxes (from the Tools menu) in Word and Excel.
    					
  12. W module Dodaj następujący kod do utworzenia publiczne Procedurę typu Sub DisplayForm Aby wyświetlić formularz na ekranie:
    Public Sub DisplayForm()
      frmWelcome.Show vbModal
    End Sub
    					
  13. Wyświetlanie okna kodu formularza frmWelcome oraz dodawanie następującego kodu UserForm_Initialize Zdarzenie złączyć podpis etykiety z zmienna typu string:
    lblMessage.Caption = lblMessage.Caption & " " & gstrUserName
    					
  14. Dodaj następujący kod do Kliknij przycisk Zdarzenie format CommandButton cmdOK Aby zwolnić formę:
    Unload me
    					

Zmiana właściwości Projektant dodatku

Wykonaj następujące kroki, aby zmienić właściwości Projektant tak że dodatek zostanie uruchomione natychmiast po uruchomieniu programu Microsoft Excel:
  1. W programie Project Explorer kliknij dwukrotnie składnik do Wróć do Projektant dodatku.
  2. Na Ogólne Karta konstruktora, zmienić właściwości projektanta do są zgodne z wartościami w poniższej tabeli:
    Zwiń tę tabelęRozwiń tę tabelę
    WłaściwośćWartość
    Nazwa wyświetlana dodatekFunFormMessage
    Opis dodatkuZawiera kod, który jest specyficzne dla programu Excel
    AplikacjaProgram Microsoft Excel
    Wersja aplikacjiProgram Microsoft Excel 10.0
    Podczas ładowania początkowegoAutostart

Wdrożenie zdarzenia IDTExtensibility2

  1. Z Widok menu, kliknij przycisk Kod Aby wyświetlić moduł kodu za projektanta.
  2. Z Narzędzia menu, kliknij przycisk Odwołaniai ustawić odwołanie do obiektu programu Microsoft Excel Biblioteka.
  3. W Obiekt listy rozwijanej kliknij przycisk AddinInstance. W Procedura listy rozwijanej kliknij przycisk OnConnection.

    To zdarzenie jest przydatne przy tworzeniu przycisku Wyślij na pasku poleceń lub, aby skojarzyć kod zdarzenia, takiego jak zdarzeń aplikacji, gdy dodatek jest podłączony do aplikacji hosta.
  4. Dodaj następujący kod do AddinInstance_OnConnection procedurę zdarzenia do nazwy użytkownika są przechowywane w zmiennej globalnej strUserName oraz wywołanie DisplayForm Procedura:
    gstrUserName = Application.UserName
    DisplayForm
    					
  5. W programie VBE kliknij przycisk Zapisz, a nazwą projektu Welcome.vba.

Dodaj drugą projektanta

W tej procedurze dodać drugi projektanta do wdrożenia te same funkcje w programie Microsoft Word.
  1. Tworzenie innego projektu dodaj w programie VBE. Jest AddInProject2 Domyślnie tworzone.
  2. W Eksploratorze projektu przeciągnij nowy Projektant dodatku Interfejs)AddInDesigner1) do istniejącego projektu dodatek. Będą dwa projektantów w projekcie.
  3. W programie Project Explorer kliknij prawym przyciskiem myszy AddInProject2, a następnie kliknij przycisk Zamknij projekt Aby usunąć nowo utworzonego projektu.
  4. Po otrzymaniu wiadomości następujące lub podobne
    AddInProject2 projektu zostały zmodyfikowane. Czy chcesz Czy chcesz go zapisać?
    Kliknij przycisk Nr.
  5. Zmień właściwości Projektant do określenia Program Word 10 w aplikacji docelowej, a następnie załaduj na Autostart.
  6. Dodaj następujący kod do nowego projektanta programu Word AddinInstance_OnConnection Procedura zdarzenia, który jest taki sam, jak uprzednio napisany kod dla projektanta programu Excel OnConnection zdarzenie:
    gstrUserName = Application.UserName
    DisplayForm
    					

Debugowania dodatku

  1. W razie potrzeby dodaj odpowiednie punkty przerwań do Kod.
  2. W programie VBE kliknij przycisk Uruchom program Project z Uruchom menu uruchamiania dodatku.
  3. Uruchom program Microsoft Excel. Po rozpoczęciu projektu może zostać wyświetlony okno dialogowe Projektant dodatek. Kliknij opcję, aby uruchomić aplikację, i odszukaj plik Excel.exe. Jeśli nie ma tego okna dialogowego, kliknij przycisk Start, wskaż polecenie Programy, a następnie kliknij przycisk Program Microsoft Excel Aby uruchomić program Excel. Twoje UserForm powinny być wyświetlane.
  4. Jeśli Menedżer dodatków COM nie jest jeszcze dostępne, dodawanieDodatki COM polecenie do paska narzędzi w następujący sposób:
    1. Na Narzędzia menu, kliknij przycisk Dostosowywanie.
    2. W Dostosowywanie w oknie dialogowym pole Polecenia Karta, przeciągnij Dodatki COM polecenie Narzędzia kategorii na pasku narzędzi lub na Narzędzia menu CommandBarPopup obiekt.
  5. Kliknij przycisk Dodatki COM pasek poleceń, aby wyświetlić COM Add-In Manager (CAM). Na liście CAM Wyświetla wszystkie dodatki, które są ładowane.
  6. Aby przetestować OnConnection zdarzenia, wyczyść -Zapraszamy! Dodawanie w pole wyboru CAM, a następnie kliknij OK. Ponownie wyświetlić CAM, wybierz opcję -Zapraszamy! Zaznacz pole wyboru, a następnie kliknij przycisk OK. UserForm powinien pojawić się ponownie.
  7. Zamknij aplikację hosta (Word lub Excel), i Kliknij przycisk Zatrzymaj projektu z Uruchom menu w programie VBE, aby zatrzymać wykonywanie projektu.

Sprawdzić, czy dodatek działa

Teraz można skompilować dodatek i sprawdzić, czy działa na inny komputer.
  1. Zapisz projekt w programie VBE. Jest to wersja do edycji. Stanie skompilowanym nie pozwala dokonać modyfikacji.
  2. Z Plik menu, kliknij przycisk Tworzenie Welcome.DLL.
  3. Użyj regsvr32 polecenie, aby zarejestrować biblioteki DLL w następujący sposób:
    1. Z systemu Windows Start menu, kliknij przycisk Uruchom.
    2. W Otwórz Tekst wpisz następujący tekst:
      regsvr32Ścieżka> \Welcome.DLL
      w przypadku gdyŚcieżka> to ścieżka systemu plików do biblioteki DLL.
  4. Kliknij przycisk OK Aby potwierdzić rejestrację biblioteki DLL.
  5. Uruchom program Excel lub Word. Twoje UserForm powinny być wyświetlane. Jeśli użytkownik nie widać sieci UserForm, kliknij przycisk Dodatki COM z Narzędzia menu, a następnie wybierz -Zapraszamy! pole wyboru.
UWAGA: Najłatwiejszy sposób dystrybuowania biblioteki DLL jest użycie pakietu i Kreatora wdrażania.

Rozwiązywanie problemów

  • Upewnij się, że pisanie kodu krótkie, skuteczne dla kiedy dodatek jest ładowany do pamięci. Na przykład jeśli Twój OnConnection zdarzenia manipulowanie danymi bazy danych podczas uruchamiania, użytkownicy będą traktować czy komputer przestał odpowiadać (dwustronne).
  • Użyj pakietowi, należy zachować ostrożność. Jeśli użytkownik kliknie Aplikacja hosta użytkownik może założyć że on lub ona utracił formularza ponieważ jest ukryty za aplikacji hosta. Zamiast tego utworzyć formularze modalne, aby rozwiązać ten problem. Aby utworzyć formularz modalny, użyj vbModal stała w następujący sposób:
    frmMyUserForm.Show vbModal
    						
    Aby zobaczyć, gdzie znajdzie ten kod w odwołaniu w tym przykładzie, wyświetlany jest kod w kroku 12 Utwórz dodatek Projekt sekcja.

Materiały referencyjne

Odnoszą się do \Samples\Working z AddIns\VBA_COM_AddIn folder na dysku CD pakietu Office XP Developer szablonu dodatek.

Aby uzyskać dodatkowe informacje o tworzeniu przycisków Wyślij na pasku poleceń odwiedź następującą witrynę Microsoft Developer Network (MSDN) w sieci Web:
http://msdn.microsoft.com/en-us/library/aa140930.aspx

Właściwości

Numer ID artykułu: 306130 - Ostatnia weryfikacja: 23 czerwca 2011 - Weryfikacja: 2.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office XP Developer Edition
Słowa kluczowe: 
kbhowtomaster kbmt KB306130 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:306130

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com