Como consultar e exibir dados do excel usando o ASP.NET, ADO.NET e Visual translation from VPE for Csharp .NET

Traduções deste artigo Traduções deste artigo
ID do artigo: 306572 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Este artigo passo a passo demonstra como exibir dados de uma planilha do Excel por meio de uma página ASP.NET (.aspx) usando o Visual translation from VPE for Csharp. NET.


Criar planilha do Excel exemplo

  1. Iniciar o Microsoft Excel e, em seguida, crie uma nova planilha.
  2. Adicione as seguintes informações para a nova planilha para criar um banco de dados do Excel simples:
    Recolher esta tabelaExpandir esta tabela
    UMB
    1NomeSobrenome
    2ScottCamargo
    3PaulaJordânia
    Observação : Embora os dados começarem com célula neste exemplo, você pode adicionar dados a todas as células adjacentes da planilha.
  3. Realce as linhas e colunas onde os dados residem.
  4. No menu Inserir , aponte para nome e, em seguida, clique em Definir .
  5. Na caixa de texto nomes na pasta de trabalho , digite myRange1 e, em seguida, clique em OK .
  6. No menu arquivo , clique em Salvar . Na lista Salvar em , selecione a raiz do servidor da Web (que é normalmente C:\InetPub\Wwwroot\). Na caixa de texto nome do arquivo , digite ExcelData.xls . Clique em OK .
  7. No menu arquivo , clique em Sair .

Criar o exemplo de ASP.NET usando Visual translation from VPE for Csharp .NET

Este exemplo de código demonstra como consultar e exibir informações em uma planilha do Excel. O código a seguir usa a planilha que você criou na seção anterior.
  1. Abra o Microsoft Visual Studio .NET. O Visual Studio .NET integrado Development Environment (IDE) é exibida.
  2. No menu arquivo , aponte para novo e, em seguida, clique em Project .
  3. Na caixa de diálogo New Project , em de Tipos de projeto , clique em projetos translation from VPE for Csharp Visual . Em modelos , clique em ASP.NET Web Application .
  4. Na caixa de diálogo New Project , localize as caixas de texto nome e local . Observe que a caixa de texto nome não estará disponível (aparece esmaecido ou esmaecido). A caixa de texto local contém o seguinte texto (ou semelhante):
    http://localhost/WebApplication1
    Substitua o texto na caixa de texto local com http://localhost/ExcelCSTest e, em seguida, clique em OK . Um novo projeto é criado, que inclui um Web Form chamada WebForm1.aspx.
  5. No IDE do Visual Studio .NET, localize a janela do Solution Explorer. Se você não é possível encontrá-la, clique em Solution Explorer , no menu Exibir .
  6. No Solution Explorer, clique com o botão direito do mouse em WebForm1.aspx e, em seguida, clique em View Designer para exibir o designer para a aparência da página. O designer permite que você adicionar controles e manipular a aparência da página.
  7. Localize a caixa de ferramentas. Dependendo das configurações Opções de IDE, a caixa de ferramentas pode aparecer como uma janela ou um botão (que geralmente aparece no lado esquerdo do IDE). Se você não pode localizar a caixa de ferramentas, clique em caixa de ferramentas no menu Exibir .

    Se a caixa de ferramentas aparece como um botão, mova o ponteiro sobre o botão para que o conteúdo da caixa de ferramentas sejam exibido.
  8. Quando o modo de exibição designer de um formulário da Web está ativo, a caixa de ferramentas está dividida em seções, incluindo o Web Forms, componentes, HTML e outras seções. Clique na seção Web Forms.
  9. Na seção Web Forms da caixa de ferramentas, clique em DataGrid e, em seguida, arraste-lo para o designer para WebForm1.
  10. Clique com o botão direito do mouse em WebForm1.aspx e, em seguida, clique em View Code para exibir a fonte do code-behind da página.
  11. Adicione as instruções a seguir na parte superior do código - behind de página, acima da seção de espaço para nome:
    using System.Data.OleDb;
    using System.Data;
    					
  12. Realce o código a seguir, clique o código com o botão direito do mouse e, em seguida, clique em Copiar . Em WebForm1.aspx.cs, cole o código do evento Page_Load :
    // Create connection string variable. Modify the "Data Source"
    // parameter as appropriate for your environment.
    String sConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;" +
    	"Data Source=" + Server.MapPath("../ExcelData.xls") + ";" +
    	"Extended Properties=Excel 8.0;";
    
    // Create connection object by using the preceding connection string.
    OleDbConnection objConn = new OleDbConnection(sConnectionString);
    
    // Open connection with the database.
    objConn.Open();
    
    // The code to follow uses a SQL SELECT command to display the data from the worksheet.
    
    // Create new OleDbCommand to return data from worksheet.
    OleDbCommand objCmdSelect =new OleDbCommand("SELECT * FROM myRange1", objConn);
    
    // Create new OleDbDataAdapter that is used to build a DataSet
    // based on the preceding SQL SELECT statement.
    OleDbDataAdapter objAdapter1 = new OleDbDataAdapter();
    
    // Pass the Select command to the adapter.
    objAdapter1.SelectCommand = objCmdSelect;
    
    // Create new DataSet to hold information from the worksheet.
    DataSet objDataset1 = new DataSet();
    
    // Fill the DataSet with the information from the worksheet.
    objAdapter1.Fill(objDataset1, "XLData");
    
    // Bind data to DataGrid control.
    DataGrid1.DataSource = objDataset1.Tables[0].DefaultView;
    DataGrid1.DataBind();
    
    // Clean up objects.
    objConn.Close();
    					
  13. No menu arquivo , clique em Salvar tudo para salvar os arquivos de projeto.
  14. No menu Build , clique em criar para criar o projeto. Esta opção prepara o código na página code-behind para que ela pode ser executada.
  15. No Solution Explorer, clique com o botão direito do mouse em WebForm1.aspx e, em seguida, clique em View in Browser para executar o código.

Explicação adicional de código

O exemplo de código neste artigo usa o Microsoft Jet OLE DB Provider para acessar a planilha do Excel. Esse código usa a seguinte seqüência de conexão para se conectar a planilha:
// Create connection string variable. Modify the "Data Source"
// parameter as appropriate for your environment.
String sConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;" +
	"Data Source=" + Server.MapPath("../ExcelData.xls") + ";" +
	"Extended Properties=Excel 8.0;";
				
como indicarem os comentários, você deve modificar as informações de caminho para a planilha do Excel específica. Além disso, você também deve definir o valor do parâmetro Propriedades estendidas para conectar-se ao arquivo corretamente.

Observe que a seqüência de caracteres de conexão usa a função Server.MapPath . Esta função toma um caminho que é um arquivo em relação ao Microsoft (IIS) e retorna um caminho de disco rígido para esse arquivo. Por exemplo, na seção Create Sample Excel Spreadsheet, criar ExcelData.xls no diretório raiz da Web, que está normalmente localizado em C:\inetpub\wwwroot. Isso também cria uma subpasta chamada ExcelCSTest dentro da pasta Wwwroot e um arquivo chamado WebForm1.aspx dentro da pasta ExcelCSTest.

Neste exemplo, o caminho do arquivo no disco rígido é da seguinte maneira:
     C drive
        - Inetpub
            - Wwwroot (which contains ExcelData.xls)
                - ExcelCSTest (which contains WebForm1.aspx)
				
IIS O caminho para os arquivos é o seguinte:
     Web Root (which contains ExcelData.xls)
        - ExcelCSTest (which contains WebForm1.aspx)
				
nesse caso, o caminho relativo da página WebForm1.aspx para o arquivo ExcelData.xls é "../ ExcelData.xls ". O "../ "caracteres informe IIS para subir um nível de pasta. Portanto, o código
Server.MapPath("../ExcelData.xls")
				
retorna a seguinte seqüência de caracteres:
C:\Inetpub\Wwwroot\ExcelData.xls
Você não precisará usar Server.MapPath . Você pode também rígido código essas informações para um caminho específico, ou você pode usar qualquer método para fornecer o local do arquivo do Excel no disco rígido.

Referências

Para obter informações adicionais sobre como acessar arquivos do Excel com o ASP.NET, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
307029COMO: Transferir dados XML para o Microsoft Excel 2002 usando o Visual translation from VPE for Csharp .NET
306023COMO: Transferir dados para uma pasta de trabalho do Excel usando o Visual translation from VPE for Csharp .NET
Para obter informações adicionais sobre como usar o ADO.NET, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
306636COMO: Conectar-se a um banco de dados e executar um comando usando o ADO.NET e Visual translation from VPE for Csharp .NET
314145COMO: Popular um objeto DataSet de um banco de dados usando o Visual translation from VPE for Csharp .NET
307587COMO: Atualizar um banco de dados de um objeto DataSet usando o Visual translation from VPE for Csharp .NET
Observação : os exemplos de empresas, organizações, produtos, nomes de domínio, endereços de email, logotipos, pessoas, lugares e acontecimentos aqui mencionados são fictícios. Nenhuma associação com real da empresa, organização, produto, nome de domínio, endereço de email, logotipo, pessoa, lugares ou eventos é intencional ou deve ser inferida.

Propriedades

ID do artigo: 306572 - Última revisão: terça-feira, 23 de novembro de 2004 - Revisão: 4.5
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft ASP.NET 1.1
  • Microsoft ASP.NET 1.0
  • Microsoft Visual C# .NET 2003 Standard Edition
  • Microsoft Visual C# .NET 2002 Standard Edition
  • Microsoft ADO.NET 1.1
  • Microsoft ADO.NET (included with the .NET Framework)
Palavras-chave: 
kbmt kbdatabase kbhowtomaster kbwebforms KB306572 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 306572

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com