Vorgehensweise beim Schreiben von Binärdateien an den Browser mit ASP.NET und Visual c#.NET

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 306654 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde zuvor veröffentlicht unter D306654
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

In diesem Artikel wird eine Beispielseite, die veranschaulicht, wie Binärdaten aus einer Datei abgerufen und dann zum Schreiben der Daten an den Browser mit ASP.NET und Visual c#. Obwohl dies Demo verwendet eine Adobe Acrobat (.pdf) Datei (welche Webanwendung Entwickler häufig verwenden), können Sie dieses Verfahren auf andere binäre Datei anwenden Formate.

Anforderungen

  • Microsoft.NET Framework
  • Microsoft Windows 2000 oder Windows XP
  • Microsoft Internet Informationsserver (IIS)

Erstellen Sie eine ASP.NET-Webanwendung mit Visual c#

In diesem Abschnitt veranschaulicht, wie eine neue ASP.NET-Webanwendung Webanwendung namens BinaryDemo erstellen:
  1. Öffnen Sie die Microsoft-Visual Studio.NET
  2. Klicken Sie im Menü Datei zeigen Sie auf neu, und klicken Sie dann auf Projekt.
  3. Klicken Sie unter Projekttypenauf Visual C#-Projekte. Klicken Sie unter Vorlagenauf ASP.NET-Webanwendungen.
  4. Geben Sie im Feld Name den text BinaryDemo erstellen. Geben Sie im Textfeld Speicherort den Servernamen ein. Wenn Sie die lokale verwenden Server, lassen Sie den Speicherort http://localhost.

Die PDF-Datei zum Projekt hinzufügen

Um Ihr Projekt so einrichten, dass Sie hinzufügen können, und führen Sie den Code in Das Dialogfeld Erstellen einer ASPX-Seite Abschnitt Gehen Sie folgendermaßen vor, müssen Sie zunächst eine Adobe Acrobat (.pdf) Datei, die den aktuellen hinzufügen Projekt. Dazu in Visual Studio.NET, gehen Sie folgendermaßen vor:
  1. Im Projektmappen-Explorer mit der rechten Maustaste des Projektknoten, klicken Sie auf Hinzufügen, und klicken Sie dann auf Vorhandenes Element hinzufügen.
  2. Navigieren Sie zum Speicherort einer .pdf-Datei auf Ihrem System.
  3. Klicken Sie auf um die Datei zu markieren, und klicken Sie dann auf Öffnen.
  4. In Visual Studio.NET-Projektmappen-Explorer mit der rechten Maustaste die Datei, und klicken Sie dann auf Umbenennen. Benennen Sie die .pdf-Datei, sodass es der Dateiname entspricht Acrobat.PDF, die im Code verwendet wird.
Darüber hinaus sicherstellen Sie, dass auf Adobe Acrobat Reader installiert ist der Client-Computer, von dem die .aspx-Seite angezeigt wird, so dass der browser richtig lesen und Darstellen der binären Daten. Sie können die Adobe Acrobat herunterladen. Reader von der folgenden Adobe-Website:
http://www.adobe.com

Die ASPX-Seite erstellen

  1. Fügen Sie eine neue .aspx-Seite namens BinaryData.aspx zu den aktuellen Projekt wie folgt:
    1. Klicken Sie im Projektmappen-Explorer den Projektknoten, Klicken Sie auf Hinzufügen, und klicken Sie dann auf Web Form hinzufügen.
    2. Nennen Sie die Seite "BinaryData.aspx", und klicken Sie dann auf Öffnen.

      Hinweis: Stellen Sie sicher, dass das Projekt gleichzeitig Ihrer Seite hinzugefügt wird Ebene wie die .pdf-Datei, die Sie im vorherigen Abschnitt hinzugefügt. Dies ist sehr wichtig, da der Code den relativen Pfad zunächst Verweis verwendet die PDF-Datei.
  2. Im Editor mit der rechten Maustaste "BinaryData.aspx", und klicken Sie dann auf Code anzeigen.
  3. Markieren Sie den folgenden Code der rechten Maustaste auf den Code und Klicken Sie dann auf Kopieren. Klicken Sie im Page_Load -Ereignis in der CodeBehind Seite auf Einfügen im Menü Bearbeiten , um den Code einzufügen:
    private void Page_Load(object sender, System.EventArgs e)
    	{
                 //Set the appropriate ContentType.
    	    Response.ContentType = "Application/pdf";
                 //Get the physical path to the file.
    	    string FilePath = MapPath("acrobat.pdf");
                 //Write the file directly to the HTTP content output stream.
    	    Response.WriteFile(FilePath);
                Response.End();
    	}
    					
  4. Klicken Sie im Menü Datei auf Alles speichern.
  5. Klicken Sie im Menü Erstellen auf Erstellen.
  6. Um den Code auszuführen, mit der rechten Maustaste "BinaryData.aspx" im Projektmappen-Explorer, und klicken Sie dann auf In Browser anzeigen. Wenn Sie aufgefordert werden, klicken Sie auf Öffnen , öffnen und die Datei im Browser zu rendern.
Hinweis: Wenn Sie den oben stehenden Code zur Unterstützung anderer Binärdateien verwenden möchten Dateitypen, müssen Sie den Wert in der ContentType -Zeichenfolge ändern, sodass es das entsprechende Dateiformat angibt. Die Die Syntax dieser Zeichenfolge wird als "Typ/Untertyp", wobei "Typ" ist in der Regel formatiert die allgemeine Inhaltskategorie und "Untertyp" ist der spezielle Inhaltstyp. Für eine vollständige Liste der unterstützten Inhaltstypen, finden Sie in der Dokumentation Ihres Webbrowsers oder der aktuellen HTTP-Spezifikation. Die folgende Liste nennt einige gemeinsame ContentType -Werte:
  • "Text/HTML"
  • "Image/GIF"
  • "Image/JPEG"
  • "Text/Plain"
  • "Application/Msword" (für Microsoft Word-Dateien)
  • "Application/X-Msexcel" (für Microsoft Excel -Dateien)

Informationsquellen

Weitere Informationen finden Sie unter den folgenden Themen in der .NET Framework Software Development Kit (SDK)-Dokumentation:
HttpResponse.WriteFile-Methode

HttpResponse-Klasse

.NET Framework SDK

.NET Framework-Klassenbibliothek
Weitere Informationen dazu, wie Sie diese Aufgabe Mithilfe von Microsoft Active Server Pages (ASP), klicken Sie auf die Artikelnummer unten, um Artikel in der Microsoft Knowledge Base:
276488 So verwenden Sie das ADODB.Stream-Objekt zum Senden von Binärdateien an den Browser über ASP
Microsoft stellt Kontaktinformationen von Drittanbietern finden Sie technischen Support. Diese Kontaktinformationen können ohne vorherige Ankündigung geändert werden. Microsoft garantiert nicht die Richtigkeit dieser Drittanbieter-Kontakt Informationen.

Die Produkte von Drittanbietern, die in diesem Artikel erörtert werden von Unternehmen, die unabhängig von hergestellt Microsoft. Microsoft übernimmt keine Garantie, konkludent oder anderweitig, hinsichtlich der Leistung oder Zuverlässigkeit dieser Produkte.

Eigenschaften

Artikel-ID: 306654 - Geändert am: Dienstag, 12. Juni 2012 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft ASP.NET 1.1
  • Microsoft ASP.NET 1.0
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C# .NET 2002 Standard Edition
Keywords: 
kbhowtomaster kbmt KB306654 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 306654
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com