Come scrivere i file binari nel browser utilizzando ASP.NET e Visual c#.NET

Traduzione articoli Traduzione articoli
Identificativo articolo: 306654 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I306654
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

Questa procedura dettagliata viene creata una pagina di esempio viene illustrato come recuperare i dati binari da un file e quindi scrivere il dati nel browser utilizzando ASP.NET e Visual c#. Sebbene questo (l'applicazione del file demo utilizza Adobe Acrobat (PDF) gli sviluppatori utilizzano spesso), è possibile applicare questa procedura per altri file binario formati.

Requisiti

  • Microsoft.NET Framework
  • Microsoft Windows 2000 o Windows XP
  • Microsoft Internet Information Server (IIS)

Creare un'applicazione ASP.NET utilizzando Visual c#

In questa sezione viene illustrato come creare una nuova pagina ASP.NET Web Applicazione denominata BinaryDemo:
  1. Aprire Microsoft Visual Studio.NET
  2. Scegliere Nuovodal menu File , quindi progetto.
  3. In Tipi di progetto, fare clic su Progetti di Visual c#. Fare clic su modelliASP.NET Web Application.
  4. Nella casella di testo nome digitare BinaryDemo. Nella casella di testo percorso digitare il nome del server. Se si utilizza il locale Server, lasciare il percorso http://localhost.

Aggiungere il File PDF al progetto

Per impostare il progetto in modo che è possibile aggiungere ed eseguire il codice Verrà visualizzata la finestra di dialogo Creare una pagina ASPX sezione a seguire, è innanzitutto necessario aggiungere un file di Adobe Acrobat (PDF) per la corrente progetto. Per eseguire questa operazione in Visual Studio.NET, attenersi alla seguente procedura:
  1. In Esplora soluzioni, pulsante destro del mouse sul nodo del progetto, fare clic su Aggiungie quindi fare clic su Aggiungi elemento esistente.
  2. Selezionare il percorso di un file PDF sul proprio sistema.
  3. Fare clic per selezionare il file e quindi fare clic su Apri.
  4. In Visual Studio.NET Esplora soluzioni, il pulsante destro del mouse il file e quindi fare clic su Rinomina. Rinominare il file PDF in modo che corrisponda al nome del file Acrobat. PDF utilizzato nel codice che segue.
Inoltre, assicurarsi che Adobe Acrobat Reader sia installato su il computer client da cui viene visualizzata nella pagina aspx in modo che il browser può correttamente leggere ed eseguire il rendering di dati binari. È possibile scaricare Adobe Acrobat Lettore dal seguente sito Web Adobe:
http://www.adobe.com

Creare la pagina ASPX

  1. Aggiungere una nuova pagina aspx chiamata BinaryData corrente progetto come segue:
    1. In Esplora soluzioni, pulsante destro del mouse sul nodo di progetto Fare clic su Aggiungie quindi fare clic su Aggiungi Web Form.
    2. Nome della pagina BinaryData. aspx, quindi scegliere Apri.

      Nota: Assicurarsi che la pagina viene aggiunto al progetto contemporaneamente livello del file PDF che è stato aggiunto nella sezione precedente. Questo è molto importante poiché il codice utilizza il percorso relativo al riferimento inizialmente il file PDF.
  2. Nell'editor di destro BinaryData. aspxe quindi scegliere Visualizza codice.
  3. Evidenziare il codice riportato di seguito, il pulsante destro del mouse nel codice, e quindi fare clic su Copia. Nell'evento Page_Load della pagina code-behind, scegliere Incolla dal menu Modifica per incollare il codice:
    private void Page_Load(object sender, System.EventArgs e)
    	{
                 //Set the appropriate ContentType.
    	    Response.ContentType = "Application/pdf";
                 //Get the physical path to the file.
    	    string FilePath = MapPath("acrobat.pdf");
                 //Write the file directly to the HTTP content output stream.
    	    Response.WriteFile(FilePath);
                Response.End();
    	}
    					
  4. Fare clic su Salva tuttodal menu File .
  5. Dal menu Genera scegliere Genera.
  6. Per eseguire il codice, il pulsante destro BinaryData. aspx in Esplora soluzioni e quindi fare clic su Visualizza nel Browser. Se richiesto, fare clic su Apri per aprire e visualizzare il file nel browser.
Nota: se si desidera utilizzare il codice precedente per il supporto di altri file binario tipi di file, è necessario modificare il valore della stringa ContentType in modo che specifichi il formato di file appropriato. Il sintassi della stringa in genere sono formattata come "tipo/sottotipo", dove "tipo" è la categoria generale del contenuto e "sottotipo" è il tipo di contenuto specifico. Per un completo elenco di tipi di contenuto supportati, fare riferimento alla documentazione del browser Web o la specifica HTTP corrente. Nell'elenco riportato di seguito sono indicati alcuni valori ContentType comuni:
  • "text/HTML"
  • "image/GIF"
  • "image/JPEG"
  • "text/plain"
  • "Application/msword" (per i file di Microsoft Word)
  • "Application/x-msexcel" (per Microsoft Excel file)

Riferimenti

Per ulteriori informazioni, consultare i seguenti argomenti nella .Documentazione di NET Framework Software Development Kit (SDK):
Metodo HttpResponse.WriteFile

Classe HttpResponse

.NET Framework SDK

.NET Framework Class Library
Per ulteriori informazioni su come eseguire questa operazione utilizzando Microsoft pagine ASP (ASP), fare clic sul numero dell'articolo sotto a vedere l'articolo della Microsoft Knowledge Base:
276488 Come utilizzare l'oggetto ADODB.Stream per inviare file binari al Browser tramite ASP
Microsoft fornisce informazioni di contatto di terze parti per facilitare la ricerca supporto tecnico. Le informazioni di contatto modifica senza preavviso. Microsoft non garantisce l'accuratezza di questo contatto di terze parti informazioni.

I prodotti di terze parti descritte in questo articolo sono realizzati da società indipendenti Microsoft. Microsoft non rilascia alcuna garanzia, implicita o in caso contrario, riguardanti il prestazioni o all'affidabilità di questi prodotti.

Proprietà

Identificativo articolo: 306654 - Ultima modifica: martedì 12 giugno 2012 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft ASP.NET 1.1
  • Microsoft ASP.NET 1.0
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C# .NET 2002 Standard Edition
Chiavi: 
kbhowtomaster kbmt KB306654 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 306654
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com