Messaggio di errore durante l'esplorazione del Web: Errore nello script della pagina

Traduzione articoli Traduzione articoli
Identificativo articolo: 306831 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Durante l?esplorazione di una pagina Web è possibile che venga visualizzato un messaggio di errore analogo al seguente:
Errore nello script della pagina.
Riga: riga
Carattere: carattere
Errore: Classe non registrata.
Oppure

Sulla barra di stato è possibile che venga visualizzato il seguente messaggio:
Operazione completata. Errori nella visualizzazione della pagina.
Se si fa doppio clic sul messaggio visualizzato sulla barra di stato, quindi si sceglie Mostra dettagli, viene visualizzato il messaggio di errore seguente:
Errore nello script della pagina.
Riga: riga
Carattere: carattere
Errore: Classe non registrata.

Cause

È possibile che si verifichi questo problema se il file Urlmon.dll non è registrato.

Risoluzione

Per risolvere il problema, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Nella casella Apri digitare Regsvr32 urlmon.dll, quindi scegliere OK.
  3. Quando viene visualizzato il messaggio DllRegisterServer in urlmon.dll riuscito, scegliere OK.
Se il problema persiste, attenersi alla seguente procedura:
  1. Aprire Java Virtual Machine. A questo scopo, visitare il seguente sito Web Java:
    http://www.java.com/it
  2. Chiudere tutte le istanze di Internet Explorer.
  3. Fare clic sul pulsante Start, scegliere Pannello di controllo e fare doppio clic su Opzioni Internet.
  4. Fare clic sulla scheda Avanzate.
  5. In Esplorazione deselezionare la casella di controllo Abilita estensioni dei browser di terze parti (sarà necessario riavviare il computer).
  6. Riavviare Internet Explorer.
Se il problema persiste, attenersi alla seguente procedura:
  1. Aprire Internet Explorer.
  2. Scegliere Opzioni Internet dal menu Strumenti.
  3. Fare clic sulla scheda Avanzate.
  4. In Esplorazione selezionare la casella di controllo Disattiva debug degli script.
  5. Scegliere OK per chiudere tutte le finestre, quindi riavviare il computer.

Informazioni

Per ulteriori informazioni sulla risoluzione di questo problema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
308260 Come risolvere i problemi creati dagli errori di script in Internet Explorer
Se il problema persiste, attenersi alla seguente procedura:
  1. Scaricare e installare Java Virtual Machine. A questo scopo, visitare il seguente sito Web Java:
    http://www.java.com/it
  2. Chiudere tutte le istanze di Internet Explorer, fare clic sul pulsante Start e scegliere Pannello di controllo.
  3. Fare clic su Rete e connessioni Internet e selezionare Opzioni Internet.
  4. Fare clic sulla scheda Avanzate.
  5. Deselezionare la casella di controllo Abilita estensioni dei browser di terze parti (sarà necessario riavviare il computer) nella sezione Esplorazione.
  6. Riavviare Internet Explorer. Se il problema non viene risolto, procedere al passaggio 7.
  7. Avviare Internet Explorer e scegliere Opzioni Internet dal menu Strumenti.
  8. Scegliere la scheda Avanzate, quindi selezionare la casella di controllo Disattiva debug degli script nella sezione Esplorazione.
  9. Scegliere OK per chiudere tutte le finestre.
  10. Riavviare il computer.

Proprietà

Identificativo articolo: 306831 - Ultima modifica: lunedì 11 febbraio 2008 - Revisione: 6.0
Le informazioni in questo articolo si applicano a
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 6.0 alle seguenti piattaforme
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Chiavi: 
kberrmsg kbprb KB306831
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com