Help and Support
 

powered byLive Search

"STOP 0x0000001E KMODE_EXCEPTION_NOT_HANDLED" Error Message from Aspi32.sys

Article ID:307128
Last Review:October 30, 2003
Revision:1.2
This article was previously published under Q307128

SYMPTOMS

When you are using Windows XP, the following error message may be displayed:
STOP 0x0000001E KMODE_EXCEPTION_NOT_HANDLED
The STOP screen lists Aspi32.sys as the source of the STOP error.

Back to the top

CAUSE

This behavior can occur if an older version of the Advanced SCSI Programming Interface (ASPI) layer is installed on your computer. By default, Windows XP does not include ASPI support.

Back to the top

RESOLUTION

To resolve this behavior, obtain and install ASPI version 4.57 or later. For information about how to do so, visit the following Adaptec Web site:
http://www.adaptec.com (http://www.adaptec.com)

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Back to the top

MORE INFORMATION

ASPI extends the capabilities and number of devices that the operating system supports. You can determine what version of ASPI you have by viewing the Version tab in the Properties dialog box of the Aspi.sys or Aspi32.sys file. These files are typically located in the Winnt\System32\Drivers folder.

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
275678 (http://support.microsoft.com/kb/275678/EN-US/) How to Troubleshoot a STOP 0x0000001E KMODE_EXCEPTION_NOT_HANDLED Error Message
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For information about how to contact Adaptec, Inc., click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:
65416 (http://support.microsoft.com/kb/65416/EN-US/) Hardware and Software Third-Party Vendor Contact List, A-K

60781 (http://support.microsoft.com/kb/60781/EN-US/) Hardware and Software Third-Party Vendor Contact List, L-P

60782 (http://support.microsoft.com/kb/60782/EN-US/) Hardware and Software Third-Party Vendor Contact List, Q-Z

Back to the top


APPLIES TO
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional

Back to the top

Keywords: 
kb3rdparty kberrmsg kbpending kbprb KB307128

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.