Help and Support
 

powered byLive Search

The SQL Server service and the SQL Server Agent Service fail to start on a stand-alone server

Article ID:307288
Last Review:February 22, 2007
Revision:4.3
This article was previously published under Q307288
On This Page

SYMPTOMS

On a stand-alone server the MSSQLSERVER service may fail to start, and the following error message displays:
An error 1068 - (The dependency service or group failed to start.) occurred while performing this service operation on the MSSQLServer Service.
Similarly, the SQLServerAgent service may also fail to start, and this error message displays:
An error 1068 - (The dependency service or group failed to start.) occurred while performing this service operation on the SQLServerAgent Service.
This problem occurs if both of the following conditions are met:
The server computer is in a workgroup and not part of a domain.
Both the MSSQLSERVER and SQLServerAgent services are set to use a domain account for the startup.

Back to the top

CAUSE

Because the computer is a stand-alone computer, the NetLogon service does not start on the server, hence no domain-wide logon authentications are possible.

Back to the top

RESOLUTION

To resolve the problem, use these steps:
1.Change the startup account of both the MSSQLSERVER and SQLServerAgent to use the Local System account.
2.Restart the computer.

Back to the top

MORE INFORMATION

On a stand-alone computer, the NetLogon Service should be set for "manual" startup.

Back to the top

REFERENCES

For additional information running the NetLogon service on a stand-alone computer, click the article number below to view the article in the Microsoft Knowledge Base:
182720 (http://support.microsoft.com/kb/182720/EN-US/) Event IDs 7024 and 3095 on Stand-Alone Server

Back to the top


APPLIES TO
Microsoft SQL Server 2000 Standard Edition
Microsoft SQL Server 7.0 Standard Edition
Microsoft SQL Server 2005 Standard Edition
Microsoft SQL Server 2005 Developer Edition
Microsoft SQL Server 2005 Enterprise Edition
Microsoft SQL Server 2005 Express Edition
Microsoft SQL Server 2005 Workgroup Edition

Back to the top

Keywords: 
kbinfo KB307288

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.