REVISIÓN: Office XP puede que no abra documentos de una carpeta Web que requiere certificados de cliente

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Síntomas

Cuando intenta abrir un documento de Office desde una carpeta Web remoto haciendo doble clic en el archivo en el Explorador de Windows (en Microsoft Windows 2000, el archivo aparece bajo Mis sitios de red; en Microsoft Windows 95, Microsoft Windows 98 o Microsoft Windows Millennium Edition, el archivo se muestra bajo Carpetas Web), la aplicación no podrá abrir el archivo. Este problema se produce cuando se cumplen las condiciones siguientes:
  • El servidor requiere Secure Sockets Layer (SSL) y un certificado de cliente para la autenticación a la carpeta Web.
  • El servidor utiliza Distributed Authoring and Versioning (DAV) para el protocolo de publicación y las no extensiones de servidor de FrontPage (FPSE).
  • El cliente ha instalado Office XP, que ha instalado una nueva versión del proveedor de OLE DB para Internet Publishing (MSDAIPP).
  • Se va a abrir el archivo en cuestión por una aplicación en el cliente que utiliza enlace de URL moniker (URLMON) para abrir el recurso de Web (por ejemplo, Office 2000 o Office XP).
Tenga en cuenta que este problema no se produce si copia primero el archivo a un destino local.

Causa

El problema está causado por una regresión en el proveedor OLE DB para Internet Publishing (MSDAIPP) que se incluye con Office XP.

Solución

Para resolver este problema, obtenga el Service Pack más reciente para Microsoft Office XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
307841OFFXP: Cómo obtener el Office XP Service Pack más reciente
El archivo siguiente está disponible para descargarlo del Centro de descarga de Microsoft:
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Download Pkmse54.exe now
Para obtener información adicional acerca de cómo descargar los archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
119591Cómo obtener Archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft exploró este archivo en busca de virus. con el software de detección de virus más reciente disponible en la fecha de publicación. Asimismo, el archivo se almacenó en servidores seguros que ayudan a impedir la realización de cambios no autorizados. La versión en inglés debe tener los siguientes atributos de archivo o posterior:
    *** Digital Signature from Microsoft Corporation ***
    
   DigSig       Timestamp  Version        Size    File Name     
   -----------------------------------------------------------
   Sep-12-2001  23:28      5.0.2919.6304  371 KB  Pkmse54.exe 
				

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados al principio de este artículo.
Este problema se corrigió por primera vez en el Service Pack 1 de Microsoft Office XP.

Más información

Pasos para reproducir este comportamiento

  1. En un servidor Web que es compatible con WebDAV y cliente autenticación de certificados para SSL, como Microsoft Windows 2000 Server con Microsoft Internet Information Services (IIS) versión 5.0, crear una carpeta virtual que ha de lectura, escritura y examinar el acceso y requiere certificados de cliente y SSL para la autenticación. Coloque varios documentos de Office en la carpeta de pruebas.Para obtener información adicional acerca de cómo configurar certificados de cliente en IIS 5.0, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
    228836Instalar un certificado nuevo para utilizarlo en SSL/TLS
    228984Utilizar Certificate Server 2.0 para generar un certificado de servidor para su uso con IIS 5.0
  2. Instalar un certificado que ha sido firmado por una entidad emisora de certificados es de confianza del servidor. Si utiliza Windows 2000 Server con los servicios de certificados instalados, el cliente puede solicitar un certificado de autenticación directamente desde ese servidor mediante el sitio Web de servidor de certificados, como sigue:
    http:// < nombre del servidor CA o IP > / certsrv
    Después de instalar el certificado, se permite el acceso a la carpeta Web en al cliente.

  3. En el equipo cliente, instalar Office XP.
  4. En Windows Explorer, desde Mis sitios de red (en Windows 2000 o Windows XP) o carpetas Web (Windows 98 o Windows Millennium Edition), haga clic en Agregar sitios de red o Agregar carpeta Web para iniciar al asistente.
  5. Complete el Asistente escribiendo la dirección URL a la carpeta Web (por ejemplo, https:// < IP o nombre del servidor > / somefolder ) y un nombre descriptivo. Haga clic en Finalizar para completar al asistente.
  6. Si se le pide que seleccione un certificado de cliente, seleccione el que es reconocido por el servidor o que se obtiene directamente desde ese servidor si se está ejecutando Servicios de Certificate Server. Si sólo tiene un certificado en su almacén personal, se le no pedirá.
  7. Después de que estás conectado, se muestra el contenido de la carpeta. Busque un documento de Office y haga doble clic en el elemento para abrirlo. Se inicia la aplicación de Office asociada, pero muestra un cuadro de diálogo que dice que no se puede abrir el archivo. Las aplicaciones que no utilicen URLMON pueden abrir archivos desde la carpeta; por ejemplo, mapas de bits de Windows Abrir en Paint sin errores.

Propiedades

Id. de artículo: 307560 - Última revisión: martes, 01 de marzo de 2005 - Versión: 4.6
La información de este artículo se refiere a:
  • Microsoft Office XP Professional with FrontPage
  • Microsoft OLE DB Provider for Internet Publishing 2.0
Palabras clave: 
kbmt kbdownload kbbug kbfix kbofficexpsp1fix kbprovider kbwebfolder KB307560 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 307560

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