CORRECÇÃO: O Office XP pode falhar abrir documentos de uma pasta da Web que requer certificados de cliente

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Sintomas

Quando você tentar abrir um documento do Office de uma pasta da Web remoto clicando duas vezes o arquivo no Windows Explorer (no Microsoft Windows 2000, o arquivo está listado em Meus locais de rede; no Microsoft Windows 95, Microsoft Windows 98 ou Microsoft Windows Millennium Edition (Me), o arquivo está listado em pastas da Web), o aplicativo não poderá abrir o arquivo. Esse problema ocorre quando todas as condições a seguir forem atendidas:
  • O servidor requer SSL (Secure Sockets LAYER) e um certificado de cliente para autenticação para a pasta da Web.
  • O servidor está usando Distributed Authoring and Versioning (DAV) para o protocolo de publicação e não FrontPage FPSE (extensões de servidor).
  • O cliente instalou o Office XP, que tenha instalado uma nova versão do provedor OLE DB para Internet Publishing (MSDAIPP).
  • O arquivo em questão está sendo aberto por um aplicativo no cliente que usa a ligação moniker de URL (URLMON) para abrir o recurso da Web (por exemplo, Office 2000 ou Office XP).
Observe que esse problema não ocorre se você copiar o arquivo primeiro para um destino local.

Causa

O problema é causado por uma regressão no provedor OLE DB para Internet Publishing (MSDAIPP) fornecido com o Office XP.

Resolução

Para resolver esse problema, obtenha o service pack mais recente para o Microsoft Office XP. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
307841OFFXP: Como obter o Office XP Service Pack mais recente
O seguinte arquivo está disponível para download no Centro de download da Microsoft:
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Download
Download Pkmse54.exe now
Para obter informações adicionais sobre como baixar arquivos de suporte da Microsoft, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
119591Como obter arquivos de suporte da Microsoft a partir de serviços online
Microsoft examinou esse arquivo em busca de vírus. Microsoft utilizou o mais recente software de detecção de vírus que estava disponível na data em que o arquivo foi publicado. O arquivo é armazenado em servidores com segurança avançada que ajudam a evitar qualquer alteração não autorizada no arquivo. A versão em inglês deve ter os seguintes atributos de arquivo ou posteriores:
    *** Digital Signature from Microsoft Corporation ***
    
   DigSig       Timestamp  Version        Size    File Name     
   -----------------------------------------------------------
   Sep-12-2001  23:28      5.0.2919.6304  371 KB  Pkmse54.exe 
				

Situação

A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados no começo deste artigo.
Esse problema foi corrigido primeiro no Microsoft Office XP Service Pack 1.

Mais Informações

Etapas para reproduzir o problema

  1. Em um servidor Web que ofereça suporte a WebDAV e cliente autenticação de certificado para SSL, como o Microsoft Windows 2000 Server com Microsoft (IIS) versão 5.0, crie uma pasta virtual que tem de leitura, gravação e procurar acesso e que requer certificados SSL e cliente para autenticação. Coloque vários documentos do Office na pasta de teste.Para obter informações adicionais sobre como configurar certificados de cliente no IIS 5.0, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
    228836Instalando um novo certificado para uso em SSL/TLS
    228984Usando o Certificate Server 2.0 para gerar um certificado de servidor para uso com o IIS 5.0
  2. Instale um certificado que foi assinado por uma autoridade de certificação é confiável para o servidor. Se você estiver usando o Windows 2000 Server com serviços de certificados instalado, o cliente pode solicitar um certificado de autenticação diretamente do servidor usando o certificado de servidor de site, da seguinte maneira:
    http:// < IP ou nome do servidor CA > / certsrv
    Depois que o certificado tiver sido instalado, o cliente é permissão para acessar a pasta da Web.

  3. No computador cliente, instale o Office XP.
  4. No Windows Explorer, de Meus locais de rede (no Windows 2000 ou Windows XP) ou pastas da Web (Windows 98 ou Windows Me), clique em Adicionar local de rede ou Adicionar pasta da Web para iniciar o assistente.
  5. Conclua o assistente, digitando a URL para a pasta da Web (por exemplo, https:// < IP ou nome de servidor > / somefolder ) e um nome amigável. Clique em Concluir para concluir o assistente.
  6. Se você for solicitado para selecionar um certificado de cliente, selecione aquele que é reconhecido pelo servidor ou que é obtida diretamente do servidor se estiver executando serviços de certificados. Se você tiver apenas um certificado em seu armazenamento pessoal, você não será solicitado.
  7. Depois que você está conectado, exibir o conteúdo da pasta. Localizar um documento do Office e clique duas vezes no item para abri-lo. O aplicativo associado é iniciado, mas exibe uma caixa de diálogo informando que o arquivo não pode ser aberto. Aplicativos que não estão usando URLMON podem abrir arquivos da pasta; por exemplo, bitmaps do Windows abrir no Paint sem erro.

Propriedades

ID do artigo: 307560 - Última revisão: terça-feira, 1 de março de 2005 - Revisão: 4.6
A informação contida neste artigo aplica-se a:
  • Microsoft Office XP Professional with FrontPage
  • Microsoft OLE DB Provider for Internet Publishing 2.0
Palavras-chave: 
kbmt kbdownload kbbug kbfix kbofficexpsp1fix kbprovider kbwebfolder KB307560 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 307560

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