[コンピュータのロックの解除] ダイアログ ボックスが表示されているとリモート シャットダウンによりログオフされる

文書翻訳 文書翻訳
文書番号: 307635 - 対象製品
この記事は、以前は次の ID で公開されていました: JP307635
すべて展開する | すべて折りたたむ

現象

[コンピュータのロックの解除] ダイアログ ボックスが表示されていると、Windows 2000 を実行しているコンピュータが、Shutdown.exe を使用したリモート要求などのシャットダウン要求に正しく応答しないことがあります。代わりに、現在ログオンしているユーザーがログオフされ、コンピュータは操作可能なままのように見えることがあります。しかし、その後のシャットダウン要求で "シャットダウンは既に実行中です" というエラー メッセージが生成されることがあります。この現象は、"コンピュータのロック" メッセージが表示されている場合には発生しません。

原因

シャットダウン関数により GINA (Graphical Identification and Authentication) のログオフ/シャットダウン フラグが設定されますが、それらは [コンピュータのロックの解除] ダイアログ ボックスの結果によって上書きされます。

解決方法

この問題を解決するには、Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法
修正プログラム (英語版) の属性は次のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。
   日付            時刻    バージョン          サイズ    ファイル名
   ----------------------------------------------------------
   30-Oct-2001  18:20  5.0.2195.4572    222,480  Gdi32.dll
   30-Oct-2001  18:20  5.0.2195.4272    731,920  Kernel32.dll
   25-Jun-2001  18:17  3.10.0.103        47,808  User.exe
   30-Oct-2001  18:20  5.0.2195.4314    402,192  User32.dll
   30-Oct-2001  18:20  5.0.2195.4345    371,984  Userenv.dll
   27-Sep-2001  15:00  5.0.2195.4426  1,731,536  Win32k.sys
   30-Oct-2001  18:17  5.0.2195.4575    178,960  Winlogon.exe
   30-Oct-2001  18:20  5.0.2195.4553    243,472  Winsrv.dll
				

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。 この問題は、Windows 2000 Service Pack 3 で最初に修正されました。

詳細

この問題は、グループ ポリシーによって Ctrl + Alt + Del (CAD) キーの SAS (Secure Attention Sequence) が無効になっている場合に最も顕著です。この場合、コンピュータがロックされるとすぐに [コンピュータのロックの解除] ダイアログ ボックスが表示されます。CAD が有効になっていると、Ctrl + Alt + Del キー (SAS) が押されるまで、"コンピュータのロック" 通知が最初に表示されます。

これは、パスワードによって保護されたスクリーン セーバーが中断されて [コンピュータのロックの解除] ダイアログ ボックスが表示される場合も同様ですが、スクリーン セーバー自体が実行されている場合にはこの問題は発生しません (その場合、シャットダウンは正常に行われます)。

CAD の SAS が有効な場合、2 分後にタイムアウトするため、ロックされたワークステーションが "コンピュータのロックの解除" 状態になる可能性は低くなります。

Windows 2000 Datacenter Server 用の修正プログラムの入手方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
265173 Datacenter Program と Windows 2000 Datacenter Server
複数の修正プログラムのインストールを 1 回の再起動のみで行う方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
296861 複数の Windows Update または修正プログラムを同時にインストールし、再起動を 1 回で済ませる方法
Windows 2000 と Windows 2000 の修正プログラムを同時にインストールする方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
249149 Microsoft Windows 2000 および Windows 2000 ホットフィックスのインストール

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 307635 (最終更新日 2003-12-04) を基に作成したものです。

プロパティ

文書番号: 307635 - 最終更新日: 2006年3月24日 - リビジョン: 3.5
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
キーワード:?
kbhotfixserver kbbug kbenv kberrmsg kbfix kbsecurity kbwin2000presp3fix kbwin2000sp3fix KB307635
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com