Remote Assistance invitation file does not contain correct port number

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Article ID: 307711 - View products that this article applies to.
This article was previously published under Q307711
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SYMPTOMS

Remote Assistance may not insert the correct port number in the invitation file.

CAUSE

This behavior can occur after the listening port that Remote Desktop uses is changed. When Remote Assistance creates the invitation file, the correct port number is not updated from the registry.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows XP with Service Pack 1 (SP1) or Windows XP with Service Pack 2 (SP2) installed before you apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP Professional, x86-based versions with Service Pack 1

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Cfgbkend.dll5.1.2600.168432,76811-May-200506:40x86SP1
Pchsvc.dll5.1.2600.168430,72011-May-200506:40x86SP1
Racpldlg.dll5.1.2600.168439,42411-May-200506:40x86SP1
Regapi.dll5.1.2600.168444,54411-May-200506:40x86SP1
Safrslv.dll5.1.2600.168441,47211-May-200506:40x86SP1
Sessmgr.exe5.1.2600.1684131,07211-May-200500:11x86SP1
Termsrv.dll5.1.2600.1684200,19211-May-200506:40x86SP1
Tscfgwmi.dll5.1.2600.168488,06411-May-200506:40x86SP1

Windows XP Professional, x86-based versions with Service Pack 2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Sessmgr.exe5.1.2600.2674141,31210-May-200523:53x86

WORKAROUND

To work around this behavior, use any of the following methods.
  • Use Windows Messenger to establish the Remote Assistance session. This method will often succeed because of the reverse connection method that Windows Messenger uses. For more information about using Windows Messenger for Remote Assistance, click the following article number to view the article in the Microsoft Knowledge Base:
    306556 How to obtain remote assistance using Windows Messenger
  • Edit the Remote Assistance invitation file to reflect the correct port number that Remote Assistance is using:
    1. Create a new invitation, and then save the invitation as a file.
    2. Open the file by using Notepad or another text editor.
    3. Find the "RCTICKET=" section. Note that this section looks similar to the following section
      RCTICKET="65538,1,10.10.10.1:3389;user name.domain name.com:3389
      where 10.10.10.1 is the IP address, user name.domain name.com is the fully qualified domain name or computer name, and 3389 is the port number.
    4. Change the port number from 3389 to the port that Remote Desktop has been configured to use.
    5. Save the file.
    6. Send the invitation to the recipient.

STATUS

This behavior is by design.

MORE INFORMATION

For more information about how to change the listening port for Remote Desktop, click the following article number to view the article in the Microsoft Knowledge Base:
306759 How to change the listening port for Remote Desktop
Note that the listening port for Remote Desktop is also used by Remote Assistance in establishing connections.

Properties

Article ID: 307711 - Last Review: August 29, 2007 - Revision: 3.2
APPLIES TO
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbprb KB307711

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