OFFXP: Mensaje de error después de instalar Office XP: Error en la biblioteca en tiempo de ejecución de Microsoft Visual C++

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Síntomas

Después de instalar Microsoft Office XP o uno de los programas de Office XP, es posible que aparezca uno de los siguientes mensajes de error:
Error en la biblioteca en tiempo de ejecución de Microsoft Visual C++ Programa:.. C:\ARCHIVOS DE PROGRAMA\COMMON FILES\SYSTEM\MOSEARCH\BIN\MOSDMN.EXE el programa no terminó normalmente
O bien
Error en la biblioteca en tiempo de ejecución de Microsoft Visual C++ Programa:.. C:\ARCHIVOS DE PROGRAMA\COMMON FILES\SYSTEM\MOSEARCH\BIN\MOSEARCH.EXE el programa no terminó normalmente

Causa

Este comportamiento se produce si un programa entra en conflicto con los archivos Mosdmn.exe y Mosearch.exe.

Los archivos Mosdmn.exe y Mosearch.exe forman parte de la característica "Soporte para búsqueda rápida" de Office XP. Esta característica es similar a la característica de Búsqueda rápida incluida en Microsoft Office 2000. Utiliza Servicios de Index Server de Office XP para crear un catálogo de los archivos de Office en el disco duro del equipo.

Solución

Para resolver el problema, utilice los métodos siguientes, según sea necesario, en el orden indicado.

Método 1: inicio limpio sólo con MoSearch

Los elementos de inicio Mosearch.exe (Microsoft Office Search Service) y Mosdmn.exe (Microsoft Office 10 Search Filter Daemon) pueden entrar en conflicto con algún otro programa (o programas) que se ejecute en segundo plano. Por lo tanto, realice un inicio limpio del equipo sólo con MoSearch seleccionado en el menú Inicio, para determinar si este programa es el origen del conflicto. Para ello, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, en Ejecutar.
  2. En el cuadro Abrir, escriba msconfig.exe y, a continuación, haga clic en Aceptar.
  3. En la ficha General, haga clic en Inicio selectivo.
  4. En la ficha Inicio, desactive todas las casillas de verificación excepto MoSearch.

    NOTA: en Microsoft Windows Millennium Edition (ME), deje también activada la casilla de verificación *StateMgr.
  5. Haga clic en Aceptar y, a continuación, haga clic en cuando se le pregunte si desea reiniciar el equipo.
  6. Si es posible reproducir el mensaje de error, repita los pasos anteriores. En el paso 3, desactive también las casillas de verificación Procesar archivo System.iniy Procesar archivo Win.ini.
Si no es posible reproducir el mensaje de error, ello indica que MoSearch tiene un conflicto con algún otro programa o programas que se ejecutan en segundo plano. Siga estos pasos para encontrar el programa conflictivo:
  1. Haga clic en Inicio y, a continuación, en Ejecutar.
  2. En el cuadro Abrir, escriba msconfig.exe y, a continuación, haga clic en Aceptar.
  3. En la ficha Inicio, active una de las casillas de verificación.
  4. Haga clic en Aceptar y, a continuación, haga clic en cuando se le pregunte si desea reiniciar el equipo.
  5. Si los pasos anteriores reproducen el mensaje de error, el último elemento agregado al menú Inicio es el que causa el conflicto. Si el mensaje de error no se reproduce, repita estos pasos hasta haber activado todas las casillas de verificación del menú Inicio.
  6. Si todas las casillas de verificación del menú Inicio están seleccionadas y el mensaje de error continúa sin reproducirse, vuelva a iniciar Msconfig y, a continuación, active las casillas de verificación Procesar archivo System.ini y Procesar archivo Win.ini.
Si estos pasos no le ayudan a encontrar y eliminar el conflicto, pase al método siguiente.

Método 2: desinstalar la característica "Soporte para búsqueda rápida"

Para desinstalar la característica "Soporte para búsqueda rápida" de todos los productos Office XP que estén instalados en el equipo, siga estos pasos.

Nota: esto sólo se aplica a los equipos en los que se ejecuta Microsoft Windows 98 o Microsoft Windows Millennium Edition.
  1. Cierre todos los programas de Office.
  2. Haga clic en Inicio, elija Configuración y, a continuación, haga clic en Panel de control.
  3. Haga doble clic en Agregar o quitar programas.NOTA: como hay varias versiones de Microsoft Windows, los pasos siguientes pueden ser diferentes en su equipo. Si es así, vea la documentación del producto para completarlos.

  4. En la ficha Instalar o desinstalar, haga clic en Microsoft producto de Microsoft Office XP, dondeproducto de Microsoft Office XP es el nombre del producto de Office en cuestión. Si está utilizando una versión independiente de uno de los programas de Office, haga clic en el producto correspondiente en la lista.
  5. Haga clic en Agregar o quitar.
  6. En el cuadro de diálogo Opciones del modo Mantenimiento, haga clic en Agregar o quitar funciones y, a continuación, en Siguiente.
  7. Haga clic en el signo más (+) junto a Herramientas de Office, elija el icono que se encuentra junto a Soporte para búsqueda rápida y, a continuación, haga clic en No disponible.
  8. Haga clic en Actualizar.
  9. Repita los pasos 2 a 8 para los demás productos de Office XP instalados en el equipo.
  10. Reinicie el equipo.
NOTA: después de realizar estos pasos, busque los archivos Mosearch.exe y Mosdmn.exe. No debería encontrarlos. Si los encuentra, puede eliminarlos de forma segura.

Más información

Para obtener información adicional acerca de los servicios de Index Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
282107 OFFXP: Introducción a la nueva característica de búsqueda de Office XP

Propiedades

Id. de artículo: 307817 - Última revisión: jueves, 18 de octubre de 2007 - Versión: 4.3
La información de este artículo se refiere a:
  • Microsoft Office XP (Setup) sobre las siguientes plataformas
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Standard Edition
Palabras clave: 
kbresolve kberrmsg kbprb KB307817
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El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

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