OFFXP: Mensagem de erro após a instalação do Office XP: Erro de tempo de execução da biblioteca de tempo de execução do Microsoft Visual C++!

Traduções de Artigos Traduções de Artigos
Artigo: 307817 - Ver produtos para os quais este artigo se aplica.
AVISO:Esta informação é preliminar e não foi confirmada ou testada pela Microsoft. Utilizar apenas com prudência. Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Depois de instalar o Microsoft Office XP ou um dos programas do Office XP, poderá visualizar uma das seguintes mensagens de erro:
Erro de tempo de execução da biblioteca de tempo de execução do Microsoft Visual C++! Programa:.. C:\PROGRAMAS\COMMON FILES\SYSTEM\MOSEARCH\BIN\MOSDMN.EXE terminado de forma anormal
- ou -
Erro de tempo de execução da biblioteca de tempo de execução do Microsoft Visual C++! Programa:.. C:\PROGRAMAS\COMMON FILES\SYSTEM\MOSEARCH\BIN\MOSEARCH.EXE terminado de forma anormal

Causa

Este comportamento ocorre se um programa estiver em conflito com os ficheiros Mosdmn.exe e Mosearch.exe.

Os ficheiros Mosdmn.exe e Mosearch.exe fazem parte da funcionalidade Suporte para procura rápida do Office XP. Esta funcionalidade é semelhante à funcionalidade Localizar Rápido do Microsoft Office 2000. A procura rápida utiliza o serviço de indexação do Office XP para criar um catálogo dos ficheiros do Office existentes no disco rígido do computador.

Resolução

Para resolver este problema, utilize os métodos que se seguem, conforme necessário, pela ordem apresentada.

Método 1: Efectuar um arranque limpo apenas com MoSearch

Os itens de arranque Mosearch.exe (serviço de procura do Microsoft Office) e Mosdmn.exe (daemon do filtro de procura do Microsoft Office 10) podem estar em conflito com outro(s) programa(s) em execução em segundo plano. Consequentemente, proceda ao arranque limpo do computador apenas com MoSearch seleccionado no menu Arranque para determinar se este programa é a origem do conflito. Para tal, siga estes passos:
  1. Clique em Iniciar e clique em Executar.
  2. Na caixa Abrir, escreva msconfig.exe e clique em OK.
  3. No separador Geral, clique em Arranque selectivo.
  4. No separador Arranque, clique para desmarcar todas as caixas de verificação excepto a relativa a MoSearch.

    NOTE: No Microsoft Windows Millennium Edition (Me), mantenha também seleccionada a caixa de verificação relativa a *StateMgr.
  5. Clique em OK e, em seguida, clique em Sim quando lhe for pedido para reiniciar o computador.
  6. Se conseguir reproduzir a mensagem de erro, repita os passos anteriores. No passo 3, clique para desmarcar também as caixas de verificação Processar o ficheiro System.ini e Processar o ficheiro Win.ini.
Se não conseguir reproduzir a mensagem de erro, isto indica que o MoSearch está em conflito com outro(s) programa(s) em execução em segundo plano. Siga estes passos para localizar o programa em conflito:
  1. Clique em Iniciar e clique em Executar.
  2. Na caixa Abrir, escreva msconfig.exe e clique em OK.
  3. No separador Arranque, clique para seleccionar uma das caixas de verificação.
  4. Clique em OK e, em seguida, clique em Sim quando lhe for pedido para reiniciar o computador.
  5. Se os passos anteriores reproduzirem a mensagem de erro, o último item adicionado ao menu Arranque está a causar o conflito. Se a mensagem de erro não for reproduzida, repita estes passos até ter seleccionado todas as caixas de verificação do menu Arranque.
  6. Se todas as caixas de verificação do menu Arranque estiverem seleccionadas e a mensagem de erro continuar a não ser reproduzida, inicie novamente o Msconfig e clique para seleccionar as caixas de verificação Processar o ficheiro System.ini e Processar o ficheiro Win.ini.
Se estes passos não o ajudarem a localizar e eliminar o conflito, avance para o método seguinte.

Método 2: Desinstalar a funcionalidade 'Suporte para procura rápida'

Para desintalar a funcionalidade Suporte para procura rápida de todos os produtos do Office XP instalados no computador, siga estes passos.

Nota Isto aplica-se apenas a computadores com o Microsoft Windows 98 ou o Microsoft Windows Millennium Edition.
  1. Saia de todos os programas do Office.
  2. Clique em Iniciar, aponte para Definições e, em seguida, clique em Painel de controlo.
  3. Faça duplo clique em Adicionar/remover programas.NOTA: uma vez que existem várias versões do Microsoft Windows, os passos que se seguem poderão ser diferentes no seu computador. Se for esse o caso, consulte a documentação do produto para concluir estes passos.

  4. No separador Instalar/desinstalar, clique em Microsoft Produto do Office XP, em queProduto do Office XP é o nome do produto específico do Office em questão. Se estiver a utilizar uma versão autónoma de um dos programas do Office, clique no produto adequado na lista.
  5. Clique em Adicionar/remover.
  6. Na caixa de diálogo Opções do modo de manutenção, clique em Adicionar ou remover funcionalidades e clique em Seguinte.
  7. Clique no sinal de adição (+) existente junto a Ferramentas do Office, aponte para o ícone existente junto a Suporte para procura rápida e clique em Não disponível.
  8. Clique em Actualizar.
  9. Repita os passos 2 a 8 para todos os outros produtos do Office XP instalados no computador.
  10. Reinicie o computador.
NOTA: Depois de efectuar estes passos, procure os ficheiros Mosearch.exe e Mosdmn.exe. Não deverá encontrá-los. Se os encontrar, pode eliminar estes dois ficheiros com segurança.

Mais Informação

Para obter informações adicionais sobre o serviço de indexação, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
282107 OFFXP: Overview of the New Search Feature in Office XP

Propriedades

Artigo: 307817 - Última revisão: 18 de outubro de 2007 - Revisão: 3.3
A informação contida neste artigo aplica-se a:
  • Microsoft Office XP (Setup) nas seguintes plataformas
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Standard Edition
Palavras-chave: 
kbresolve kberrmsg kbprb KB307817
Exclusão de Responsabilidade para Conteúdo sem Suporte na KB
Este artigo foi escrito sobre produtos para os quais a Microsoft já não fornece suporte. Por conseguinte, este artigo é oferecido "tal como está" e deixará de ser actualizado.

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com