OFFXP: Mensagem de Erro Após Instalar o Office XP: Erro de Tempo de Execução do Microsoft Visual C++ Runtime Library!

Traduções deste artigo Traduções deste artigo
ID do artigo: 307817 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi publicado anteriormente em BR307817
ATENÇÃO:Esta informação é preliminar e não foi confirmada ou testada pela Microsoft. Use somente com discrição.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Após instalar o Microsoft Office XP ou um dos programas do Office XP, você pode receber uma das seguintes mensagens de erro:
Erro de Tempo de Execução do Microsoft Visual C++ Runtime Library! Programa:.. C:\PROGRAM FILES\COMMON FILES\SYSTEM\MOSEARCH\BIN\MOSDMN.EXE encerramento anormal do programa
-ou-
Erro de Tempo de Execução do Microsoft Visual C++ Runtime Library! Programa:.. C:\PROGRAM FILES\COMMON FILES\SYSTEM\MOSEARCH\BIN\MOSEARCH.EXE encerramento anormal do programa

Causa

Este comportamento ocorrer se um programa entra em conflito com os arquivos Mosdmn.exe e Mosearch.exe.

Os arquivos Mosdmn.exe e Mosearch.exe fazem parte do recurso "Suporte para pesquisa rápida" no Office XP. Este recurso é similar ao recurso Localização Acelerada no MIcrosoft Office 2000. A pesquisa rápida utiliza o Serviço de Indexação do Office XP para criar um catálogo de arquivos do Office no disco rígido de seu computador.

Resolução

Para solucionar este problema, use os seguintes métodos, conforme for necessário, na ordem apresentada.

Método 1: Inicialização Limpa Somente com o MoSearch

Os itens de Inicialização Mosearch.exe (Microsoft Office Search Service) e Mosdmn.exe (Microsoft Office 10 Search Filter Daemon) podem estar em conflito com algum outro programa (ou programas) executado em segundo plano. Por isso, execute a inicialização limpa de seu comptador somente com o MoSearch selecionado no menu Iniciar para determinar se este programa é a origem do conflito. Para fazer isto, siga estes passos:
  1. Clique em Iniciar , e em seguida clique em Executar .
  2. Na caixa Abrir, digite msconfig.exe, e em seguida clique em OK .
  3. Na guia Geral , clique em Inicialização Seletiva .
  4. Na guia Inicialização , clique para limpar todas as caixas de seleção exceto a MoSearch .

    NOTA : No Microsoft Windows Millennium Edition (Me), deixe a caixa de seleção *StateMgr também selecionada.
  5. Clique em OK , e em seguida clique em Sim quando for solicitado para reiniciar o computador.
  6. Se a mensagem de erro puder ser reproduzida, repita os passos anteriores. No passo 3, clique também para limpar as caixas de seleção arquivo Process System.ini e arquivo Process Win.ini .
Se a mensagem de erro não puder ser reproduzida, isto indica que a MoSearch está em conflito com algum outro programa ou programas executados em segundo plano. Siga estes passos para localizar o programa em conflito:
  1. Clique em Iniciar , e em seguida clique em Executar .
  2. Na caixa Abrir, digite msconfig.exe, e em seguida clique em OK .
  3. Na guia Inicialização , clique para marcar uma das caixas de seleção.
  4. Clique em OK , e em seguida clique em Sim quando for solicitado para reiniciar o computador.
  5. Se as etapas anteriores reproduzirem a mensagem de erro, o último item adicionado ao menu Iniciar está causando o conflito. Se a mensagem de erro não for reproduzida, repita estes passos até que todas as caixas de seleção do menu Iniciar estejam selecionadas.
  6. Se todas as caixas de seleção do menu Iniciar forem selecionadas e a mensagem de erro ainda não for reproduzida, inicie o Msconfig novamente, e em seguida clique para marcar as caixas de seleçãoarquivo Process System.ini e oarquivo Process Win.ini.
Se estas etapas não ajudarem você a encontrar e eliminar o conflito, passe para o seguinte método.

Método 2: Desinstale o Recurso "Suporte para Pesquisa Acelerada"

Para desintalar o recurso "Suporte para pesquisa rápida" de todos os produtos do Office XP instalados em seu computador, siga estas etapas:
  1. Feche todos os programas do Office.
  2. Clique em Iniciar , aponte para Configurações , clique em Painel de Controle .
  3. Dê um duplo clique em Adicionar/Remover Programas .NOTA : Por causa de existirem diversas versões do Microsoft Windows, os seguintes passos podem ser diferentes em seu computador. Se for o caso, consulte a documentação do seu produto para concluir estas etapas.

  4. Na guia Instalar/Desinstalar , clique emMicrosoft produto Office XP , onde produto Office XP é o nome do produto específico do Office em questão. Se você estiver usando uma versão independente dos programas do Office, clique no produto apropriado na lista.
  5. Clique em Adicionar/Remover .
  6. Na caixa de diálogo Opções do Modo Manutenção , clique em Adicionar ou Remover Recursos , e em seguida clique em Avançar .
  7. Clique no sinal mais (+) ao lado de Ferramentas do Office , aponte para o ícone ao lado de Suporte para pesquisa rápida , e em seguida clique em Não Disponível .
  8. Clique em Atualizar .
  9. Repita os passos 2 a 8 para todos os outros produtos do Office XP instalados em seu computador.
  10. Reinicie o seu computador
NOTA : Após efetuar estes passos, procure os arquivos Mosearch.exe e Mosdmn.exe. Você não deve encontrá-los. Se encontrá-los, você pode excluir estes dois arquivos.

Mais Informações

Para obter informações adicionais sobre o Serviço de Indexação, clique no número do artigo abaixo para visualizá-lo na Base de Dados de Conhecimento da Microsoft:
282107 OFFXP: Overview of the New Search Feature in Office XP

Propriedades

ID do artigo: 307817 - Última revisão: quinta-feira, 18 de outubro de 2007 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft Office XP (Setup) nas seguintes plataformas
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Standard Edition
Palavras-chave: 
kbresolve kbdta kberrmsg kbprb KB307817
Aviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com