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You cannot log on to the computer after you run a repair process if SRP is installed

Article ID:307866
Last Review:March 9, 2007
Revision:3.0
This article was previously published under Q307866

SYMPTOMS

After you run the Windows NT repair process and choose the Verify Windows NT system files option, you may receive the following error message after you restart the computer and attempt to log on:
The System can not log you on (C00000DF).
Please try again or consult your system administrator.
When you follow the steps in one of the following articles to resolve this error message
196603 (http://support.microsoft.com/kb/196603/) Repair Windows NT after installation of Service Pack 4 and later
146887 (http://support.microsoft.com/kb/146887/) Repairing Windows NT after the application of Service Pack 3
You replace the following files in the %SystemRoot%\System32 folder:
Samsrv.dll
Samlib.dll
Winlogon.exe
Lsasrv.dll
Services.exe
Msv1_0.dll
After you replace these files, you may receive the following error message after you restart the computer:
Stop 0xC000021A (Fatal System Error)
The Windows Logon Process system process terminated unexpectedly
with a state of 0x00000080 (0x00000000, 0x00000000).
The system has been shut down.

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CAUSE

This problem occurs because the Security Rollup Package (SRP) hotfix (Q299444i.exe) does not update the CRC values in the %SystemRoot%\Repair\Setup.log file for the files that are installed. The files that are installed by the SRP must remain on the computer after you run the repair process so that you can log on to the computer.

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RESOLUTION

To resolve this problem, run Q307866.exe and then run Srpfixup.exe. When you run Srpfixup.exe, the current CRC values are verified for files that are necessary to start and log on to the computer. After the values are determined, the %SystemRoot%\Repair\Setup.log file is updated. This prevents the required files from being overwritten the next time that you run a repair process and select the Verify Windows NT System Files option.

Note This patch must be applied after you install SRP and before you try to run a repair process.

For more information about the Microsoft Security Tool Kit, visit the following Microsoft Web site:
http://www.microsoft.com/technet/security/tools/default.mspx (http://www.microsoft.com/technet/security/tools/default.mspx)

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WORKAROUND

To work around this problem, copy the following files from the appropriate source (from the SRP hotfix or from Microsoft Windows NT Service Pack 6a [SP6A]) to the appropriate folder.

Copy the following files from either the SRP or the SP6a folder to the appropriate location:
Copy to                                       From source
---------------------------------------------------------
%SystemRoot%\System32\Advapi32.dll           SRP
%SystemRoot%\System32\Crypt32.dll            SRP
%SystemRoot%\System32\Kernel32.dl            SRP
%SystemRoot%\System32\Lsasrv.dll             SRP
%SystemRoot%\System32\Ntoskrnl.exe           SRP
%SystemRoot%\System32\Ole32.dll              SRP
%SystemRoot%\System32\Rpclts1.dll            SRP
%SystemRoot%\System32\Rpcrt4.dll             SRP
%SystemRoot%\System32\Rpcss.exe              SRP
%SystemRoot%\System32\Samlib.dll             SRP
%SystemRoot%\System32\Samsrv.dll             SRP
%SystemRoot%\System32\Schannel.dll           SRP
%SystemRoot%\System32\Services.exe           SRP
%SystemRoot%\System32\Winlogon.exe           SRP
%SystemRoot%\System32\Wldap32.dll            SRP
%SystemRoot%\System32\Basesrv.dll            SP6a
%SystemRoot%\System32\Csrsrv.dll             SP6a
%SystemRoot%\System32\Csrss.exe              SP6a
%SystemRoot%\System32\Gdi32.dll              SP6a
%SystemRoot%\System32\Hal.dll                SP6a
%SystemRoot%\System32\Msv1_0.dll             SP6a
%SystemRoot%\System32\Ntdll.dll              SP6a
%SystemRoot%\System32\Rpcltc1.dll            SP6a
%SystemRoot%\System32\Rpcltscm.dll           SP6a
%SystemRoot%\System32\Security.dll           SP6a
%SystemRoot%\System32\User.exe               SP6a
%SystemRoot%\System32\User32.dll             SP6a
%SystemRoot%\System32\Userenv.dll            SP6a
%SystemRoot%\System32\Win32k.sys             SP6a
%SystemRoot%\System32\Winspool.drv           SP6a
%SystemRoot%\System32\Winsrv.dll             SP6a
%SystemRoot%\System32\Drivers\\ndis.sys      SP6a
%SystemRoot%\System32\Drivers\\nwlnkipx.sys  SP6a
%SystemRoot%\System32\Drivers\\nwlnkrip.sys  SP6a
					
If the boot partition is using the NTFS file system, you can use this workaround if you install a parallel installation of Windows NT on a separate partition or drive, or by moving the disk to another computer to access these folders. If you cannot do this, you can use the procedure that is described in the following Microsoft Knowledge Base article to make repairs:
164471 (http://support.microsoft.com/kb/164471/) Replacing system files using a modified Emergency Repair Disk
After you use these steps and log on to the computer, you must reapply SP6A, the SRP, and this hotfix to update the %SystemRoot%\Repair\Setup.log file. After the Setup.log file is repaired, update your Emergency Repair Disk (ERD) by using the Rdisk.exe utility.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
299444 (http://support.microsoft.com/kb/299444/) Post-Windows NT 4.0 SP6a Security Rollup Package (SRP)

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APPLIES TO
Microsoft Windows NT 4.0 Service Pack 6a
Microsoft Windows NT Workstation 4.0 Developer Edition

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Keywords: 
kbbug kbfix kbqfe kbenv kbhotfixserver KB307866

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