Windows XP のアップグレード時にユーザー プロファイルに関する問題

文書翻訳 文書翻訳
文書番号: 307910 - 対象製品
この記事は、以前は次の ID で公開されていました: JP307910
すべて展開する | すべて折りたたむ

概要

本件は Windows 98 にて複数のユーザプロファイルを作成した環境から Windows XP にアップグレードを行った場合にユーザプロファイルが移行できない場合があり、そのときに発生する現象について述べています。

再現手順
1. Windows 98 に Office 2000 SR1 以降の Office 製品(以下 Office)をインストールします。
2. 複数のユーザプロファイルを作成します。
3. 作成したユーザプロファイルのいずれかで、ログインします。
4. Windows XP にアップグレードします。

注 : ユーザプロファイルを作成後に Office をインストールした場合は発生致しません。

現象

Windows XP にアップグレード時やアップグレード後に発生す問題や現象を以下に記載致します。

1. Windows Installer 1.1 によって、コンピュータを Microsoft Windows 98 から Windows XP にアップグレードすると、ユーザー プロファイルが移行されないことがあります。この現象が発生すると、Windows XP アップグレード レポートに次のメッセージが表示されます。
アップグレードされない設定
共有されているユーザー アカウント
2. ユーザプロファイルが移行されません。この為、Windows XP 初回起動時の OOBE の画面にて、ユーザアカウントの作成画面が表示され、新しいユーザアカウントを作成しないといけなくなります。

3. ユーザプロファイルが移行されません。
移行されなかったユーザプロファイルは Windows XP がインストールされたドライブの
\Document and Settings\user_name.Windows 9x に保存されます。
(user_name : Windows 9x で私用していたユーザ名です。Windows 9x はアップグレード前の Windows 98 のバージョンになります。)


原因

本現象は、Office インストール時に Windows Installer がインストールされ、一部のシステム情報(レジストリ)がユーザプロファイルフォルダでなく、システム共有のフォルダを参照するよう設定される為です。

Windows Installer 1.1 をインストールした後、以下のレジストリが追加されます。
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
Local AppData = C:\WINDOWS\Local Settings\Application Data

解決方法

重要 : レジストリエディタの誤った使用は、システム全般に渡る重大な問題を引き起こす可能性があります。 こうした問題を解決するためには、 Windows をインストールしなおさなければいけません。Microsoft では、レジストリエディタを使することによって引き起こされた障害の解決については、一切保証しておりません。 レジストリエディタを使用する場合には、十分なテストを実施し、お客様の責任においてご利用ください。

以下の手順を作成したユーザアカウント全てで実行した後、Windows XP へのアップグレードを行うと、ユ ーザプロファイルを正常に移行できます。

1. 作成したユーザ名のどれかで Windows 98 にログインします。
2. 「スタート」メニューより「ファイル名を指定して実行」を選択します。
3. regedit と入力し OK ボタンをクリックします。
4. 以下ようにレジストリを編集します。

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
Local AppData = C:\WINDOWS\Profiles\user_name\Local Settings\Application Data

注 : user_name にはログオンしているユーザアカウント名を指定します。

状況

この現象は冒頭に記した製品の制限事項になります。

詳細

本現象は、弊社技術情報 Q307910 で記載されている原因と同一です。
再現手順でユーザプロファイルを作成後に Office をインストールした場合や、Office がインストールされていない(Windows Installer がインストールされていない)環境にて行った場合は、本件で述べています現象は、発生致しません。

また、本現象が発生する環境にて Windows 98 で作成したいずれかのユーザプロファイルでログオンして Windows XP にアップグレードを行った場合、Windows 98 でログオンしたユーザ環境が移行されますが、 その他のユーザアカウントは正常に移行されません。このとき、Windows XP へアップグレードし OOBE で新しいユーザアカウントを作成しますが、 ログオンしているユーザ以外のユーザプロファイルはこの画 面に指定したユーザアカウント名へ無作為に関連付けられます。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 307910 (最終更新日 2001-09-27) をもとに作成したものです。

プロパティ

文書番号: 307910 - 最終更新日: 2001年10月26日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
キーワード:?
kbenv kbsetup kbprb KB307910
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com