Message d'erreur après l'installation d'un scanneur Hewlett-Packard Série 4400 sur le port parallèle

Traductions disponibles Traductions disponibles
Numéro d'article: 307969 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F307969
Agrandir tout | Réduire tout

Symptômes

Vous pouvez recevoir un message d'erreur sur un écran bleu après avoir installé un scanneur Hewlett-Packard ScanJet 4400 ou 4470 sur le port parallèle.

Cause

Les scanneurs Hewlett-Packard de la Série 4400 qui ne possèdent pas de ROM d'ID de périphérique signalent une chaîne d'ID de périphérique non valide (uniquement des zéros) lors d'une requête d'ID de périphérique. Le pilote fourni par Microsoft ne peut pas valider la chaîne et un calcul de longueur de chaîne d'ID effectué ultérieurement sur une valeur USHORT provoque un dépassement négatif.

Résolution

Un correctif est désormais disponible auprès de Microsoft, mais il est conçu uniquement pour résoudre le problème décrit dans cet article et ne doit être appliqué qu'aux systèmes rencontrant ce problème spécifique. Ce correctif pourra être soumis à des tests ultérieurs afin d'assurer la qualité du produit. Par conséquent, sauf dans le cas où votre ordinateur serait sérieusement affecté par ce problème, Microsoft vous conseille d'attendre la sortie du prochain Service Pack Windows XP qui contiendra ce correctif.

Pour résoudre ce problème dès à présent, procurez-vous ce correctif auprès des services de Support technique de Microsoft. Pour obtenir les coordonnées téléphoniques du Support technique de Microsoft et des informations sur le coût de l'assistance, consultez le site Web suivant :
http://support.microsoft.com/directory/overview.asp
REMARQUE : Dans certains cas, les tarifs normaux relatifs aux appels de support technique ne seront pas appliqués si le membre de l'équipe de Support technique contacté détermine qu'une mise à jour spécifique peut résoudre votre problème. Les tarifs normaux de support seront appliqués à toute question de support supplémentaire, ainsi qu'aux problèmes qui ne relèvent pas de la mise à jour spécifique en question.

La version anglaise de ce correctif devrait avoir les attributs de fichier suivants ou ultérieurs :
   Date         Heure  Version      Taille  Nom de fichier
   -------------------------------------------------------
   21-Sep-2001  14:49  1.5.2600.14  76 160  Parport.sys

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "Liste des produits concernés par cet article".

Propriétés

Numéro d'article: 307969 - Dernière mise à jour: mercredi 29 mars 2006 - Version: 2.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professionnel
Mots-clés : 
kbqfe kbhotfixserver kbbug kbfix kbwinxppresp1fix kbwinxpsp1fix KB307969
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com