Article ID: 308215 - Last Review: December 3, 2003 - Revision: 2.0 PRB: VFP ODBC Driver Causes Various Errors in Microsoft ProductsThis article was previously published under Q308215 On This PageSYMPTOMS
When you use the Visual FoxPro ODBC driver to retrieve data, you may receive the following error messages in various Microsoft products:
ODBC Error: Cannot open file <drive letter>\<folder>\*.tmp
CAUSE
These errors occur because the System attribute is set at the TEMP folder of the computer. This error seems to occur only on Microsoft Windows NT 4.0, Microsoft Windows 2000, and Microsoft Windows XP operating systems.
RESOLUTION
From a command prompt, issue the ATTRIB -S C:\WINNT\TEMP command to remove the System attribute from the TEMP folder. This assumes that the C:\WINNT\TEMP folder is the default for the TEMP and TMP environment variables. To determine this, right-click the My Computer icon on the desktop, click Properties, click Advanced, and then click Environment Variables. Look at the TEMP and TMP variables in the System Variables list box to determine which folder the variables are pointing to and then issue the ATTRIB command on this folder.
MORE INFORMATIONSteps to Reproduce the Behavior
APPLIES TO
| Article Translations
|


Back to the top
