Identificativo articolo: 308260 - Ultima modifica: lunedì 11 febbraio 2008 - Revisione: 4.0

Come risolvere i problemi creati dagli errori di script in Internet Explorer

In questa pagina

Espandi tutto | Chiudi tutto

Sintomi

Quando si utilizza Internet Explorer, potrebbe essere visualizzato un messaggio di errore che fa riferimento agli errori di script.

Cause

Questo problema può essere causato da:
  • Driver delle schede video danneggiati o non aggiornati.
  • Un modulo di gestione di script danneggiato o non aggiornato.
  • Un componente DirectX non aggiornato.
  • Cartelle correlate a Internet danneggiate.

Risoluzione

NOTA: dopo avere seguito le istruzioni riportate in una sezione relativa alla risoluzione dei problemi, eseguire una verifica per determinare se l'errore di script è ancora presente. Se il problema è stato risolto, non passare alla sezione successiva. Se il problema persiste, passare alla sezione successiva.

Per risolvere errori di script in Internet Explorer versioni 4.x, 5.x e 6 per Windows 95, Windows 98, Windows 98 Seconda Edizione e Windows Millennium Edition (Me):

Per scaricare il modulo di gestione di script più recente

Dal seguente sito Web Microsoft scaricare il modulo di gestione di script più aggiornato:
http://msdn.microsoft.com/library/default.asp?url=/downloads/list/webdev.asp?id=23 (http://msdn.microsoft.com/library/default.asp?url=/downloads/list/webdev.asp?id=23)
NOTA: in Windows 95 per il corretto funzionamento di questi file, è necessario che sia in esecuzione Windows 95 OEM Service Release 2 (OSR2) o versione successiva oppure Internet Explorer 4.0 o versione successiva. Per Windows 95 senza Internet Explorer 4.0 o Windows 95 OSR2, è necessario installare l'aggiornamento DCOM prima di utilizzare questi file. Vedere la pagina di download DCOM nel sito Web Microsoft riportato di seguito per installare il file dei componenti DCOM, DCOM95 per Windows 95, versione 1.3 (informazioni in lingua inglese):
http://www.microsoft.com/com/resources/downloads.asp (http://www.microsoft.com/com/resources/downloads.asp)

Per disabilitare la funzionalità di scorrimento continuo

Internet Explorer 4.x

  1. Avviare Internet Explorer, quindi scegliere Opzioni Internet dal menu Visualizza.
  2. Nella scheda Avanzate deselezionare la casella di controllo Usa scorrimento continuo.
  3. Scegliere OK, quindi chiudere Internet Explorer.

Internet Explorer 5.x e Internet Explorer 6

  1. Scegliere Opzioni Internet dal menu Strumenti.
  2. Nella scheda Avanzate deselezionare la casella di controllo Usa scorrimento continuo.
  3. Scegliere OK, quindi chiudere Internet Explorer.

Per disabilitare la visualizzazione del contenuto della finestra durante l'operazione di trascinamento

NOTA: se Microsoft Plus! per Windows 95 o Windows 98 non è installato nei computer basati rispettivamente su Windows 95 o Windows 98, passare alla sezione "Per ridurre il numero di colori utilizzati da Windows".

Windows 95 e Windows 98

  1. Fare clic con il pulsante destro del mouse sul desktop, quindi scegliere Proprietà.
  2. Nella scheda Plus! deselezionare la casella di controllo Mostra contenuto della finestra durante l'operazione Trascina, quindi scegliere OK.

Windows 98 SE e Windows Me

  1. Fare clic con il pulsante destro del mouse sul desktop, quindi scegliere Proprietà.
  2. Nella scheda Effetti deselezionare la casella di controllo Mostra contenuto della finestra durante le operazioni di trascinamento, quindi scegliere OK.

Per ridurre il numero di colori utilizzati da Windows

Windows 95, Windows 98, Windows 98 SE e Windows Me

  1. Fare clic con il pulsante destro del mouse sul desktop, quindi scegliere Proprietà.
  2. Nella scheda Impostazioni, nella casella Colori o nella casella Tavolozza dei colori in Windows 95, fare clic su un'impostazione di valore inferiore a quella corrente, scegliere OK, quindi scegliere .
Ripetere questa procedura finché l'errore non sarà stato risolto o finché verrà impostata l'opzione dei colori più bassa.

Per ridurre l'area dello schermo

Windows 95, Windows 98, Windows 98 SE e Windows Me

  1. Fare clic con il pulsante destro del mouse sul desktop, quindi scegliere Proprietà.
  2. Nella scheda Impostazioni, nella casella Area dello schermo oppure nella casella Area del desktop in Windows 95, spostare il dispositivo di scorrimento Area dello schermo su un'area di dimensioni inferiori rispetto all'impostazione corrente, scegliere OK, quindi scegliere .
Ripetere questa procedura finché l'errore non sarà stato risolto o finché verrà impostata la risoluzione inferiore.

Per disattivare l'accelerazione hardware

  1. Fare clic con il pulsante destro del mouse su Risorse del computer, quindi scegliere Proprietà.
  2. Nella scheda Prestazioni fare clic su Grafica.
  3. Spostare il dispositivo di scorrimento Accelerazione hardware su Nessuna, scegliere OK, Chiudi, quindi scegliere .

Per disattivare Active Desktop

  1. Fare clic con pulsante destro del mouse sul desktop, quindi scegliere Proprietà.
  2. Nella scheda Web deselezionare la casella di controllo Visualizza Active Desktop come pagina Web, quindi scegliere OK.

Ulteriori metodi relativi a Windows 98 e 98 SE

  1. Fare clic sul pulsante Start (Avvio in Windows 95), scegliere Impostazioni, Active Desktop, quindi deselezionare l'opzione relativa alla visualizzazione come pagina Web.

    Oppure
  2. Fare clic con pulsante destro del mouse sul desktop, scegliere Active Desktop, quindi deselezionare l'opzione relativa alla visualizzazione come pagina Web.

Windows Me con Internet Explorer 5.5 e 6

  1. Fare clic con pulsante destro del mouse sul desktop, scegliere Proprietà, quindi fare clic sulla scheda Web. Deselezionare la casella di controllo Visualizza contenuto Web sull'Active Desktop, quindi scegliere OK.

    Oppure
  2. Fare clic con pulsante destro del mouse sul desktop, scegliere Active Desktop, quindi deselezionare l'opzione Mostra contenuto Web.
NOTA: se nessuna delle procedure descritte nelle precedenti sezioni consente di risolvere il problema, potrebbe essere necessario aggiornare il driver della scheda video. Per ulteriori informazioni su come ottenere un driver aggiornato per la scheda video in uso, contattare il produttore della scheda o del computer.

Per installare la versione corrente di Microsoft DirectX

Per ulteriori informazioni su come installare la versione corrente di Microsoft DirectX, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/windows/directx/default.mspx (http://www.microsoft.com/windows/directx/default.mspx)

Per eliminare le cartelle correlate a Internet: Preferiti e Cookies

Note

Profili utente: se si utilizzano i profili utente, il percorso delle cartelle Preferiti e Cookies cambia. È possibile utilizzare i profili utente per conservare le singole preferenze per ogni utente che accede al computer. Per determinare se nel computer sono in uso i profili utente, verificare la presenza di una cartella dei profili in C:\Windows. Se tale cartella è disponibile, conterrà una sottocartella per ogni utente che è connesso al computer e che ha memorizzato le impostazioni personali. Se i profili utente sono stati stabiliti automaticamente da Windows quando l'utente ha scelto di memorizzare le impostazioni durante la procedura di accesso iniziale, in questa sottocartella verrà conservata solo la cartella Cookies. Se i profili utente sono stati creati manualmente, anche altre opzioni tra cui la cartella Preferiti potranno essere salvate in questa sottocartella.

Percorsi della riga di comando: i percorsi elencati sono solo esempi. Il percorso delle cartelle Preferiti e Cookies vere e proprie può variare. Fare riferimento alla nota precedente relativa ai profili utente per determinare il percorso esatto delle cartelle.

Utilizzo di Smartdrv.exe: alcuni comandi riportati in questa sezione utilizzano Smartdrv.exe. Tuttavia Smartdrv.exe non è necessario ed è utilizzato solo per rendere più rapido il processo di eliminazione dei file.

Percorso delle cartelle

  • Se sono stati creati profili utente, il percorso per le cartelle Preferiti e Cookies è il seguente:
    C:\Windows\Preferiti

    E

    C:\Windows\Cookies
  • Se i profili utente sono stati creati automaticamente al primo accesso dell'utente al computer, il percorso per le cartelle Preferiti e Cookies è il seguente:
    C:\Windows\Preferiti

    E

    C:\Windows\Profiles\Nomeutente\Cookies
    dove Nomeutente è il nome con cui l'utente si è connesso al computer.
  • Se i profili utente sono stati creati manualmente e nel profilo è stata inclusa la cartella Preferiti, il percorso per le cartelle Preferiti e Cookies è il seguente:
    C:\Windows\Profiles\Nomeutente\Preferiti

    e

    C:\Windows\Profiles\Nomeutente\Cookies
    dove Nomeutente è il nome con cui l'utente si è connesso al computer.

Passaggio 1: avviare il computer in modalità prompt dei comandi

NOTA: in alcuni computer OEM una schermata iniziale può impedire di visualizzare il messaggio dell'avvio di Windows. In tal caso tenere premuto F8 o CTRL per due o tre secondi dopo l'avvio del computer.

Windows 95 e Windows 98

Riavviare il computer. Alla visualizzazione del messaggio "Avvio di Windows 95 in corso" o "Avvio di Windows 98 in corso" premere F8, quindi scegliere il comando Prompt dei comandi con supporto di rete dal menu di avvio.

Windows 98 SE

Riavviare il computer. Alla visualizzazione del messaggio "Avvio di Windows 98 in corso" premere CTRL, quindi scegliere il comando Prompt dei comandi con supporto di rete dal menu di avvio.

Windows Me

Inserire il disco di avvio di Windows Millennium e avviare il computer. Scegliere l'opzione Avviare il computer dall'unità CD-ROM dal menu di avvio. Al termine dell'avvio verrà visualizzato il prompt dei comandi riportato di seguito:
   A :
Digitare c: e premere INVIO. Dovrebbe ora essere visualizzato il prompt dei comandi riportato di seguito:
   C:\
NOTA: se si utilizza il comando deltree si verificherà una perdita di dati:

L'eliminazione delle cartelle relative ai preferiti e ai cookie porterà alla rimozione di tutti i collegamenti ai preferiti e ai cookie memorizzati. Quando si riavvia il computer le cartelle verranno create di nuovo, ma non il relativo contenuto.

Per conservare il contenuto delle cartelle Cookies e Preferiti, non eliminarle e continuare con il Passaggio 2.

Passaggio 2: salvare le cartelle Preferiti e Cookies

Per conservare il contenuto delle cartelle Cookies e Preferiti, utilizzare uno dei tre metodi riportati di seguito:
  • Metodo 1: rinominare le cartelle.
  • Metodo 2: copiare il contenuto delle cartelle in un'altra cartella per poter copiare di nuovo il contenuto nelle cartelle Cookies e Preferiti appena create.
  • Metodo 3: esportare le cartelle per poterle importare in un secondo momento.
Metodo 1: ridenominazione

Per rinominare le cartelle Preferiti e Cookies, digitare i comandi riportati di seguito e premere INVIO dopo ciascuna riga di comando:

IMPORTANTE: se si stabilisce di rinominare la cartella Preferiti e/o Cookies, non è necessario eliminarla nel Passaggio 3.
rename c:\windows\nuovonome preferiti
rename c:\windows\profiles\nomeutente\nuovonome cookies
Dove:
  • nomeutente è un nome utente singolo della directory dei profili.
  • nuovonome è il nuovo nome delle cartelle Preferiti e/o Cookies, ad esempio prefpr e cookprec.
Se sono stati creati i profili utente ed è necessario rinominare più cartelle, è possibile numerarle in sequenza. Ad esempio prefpr1, prefpr2, prefpr3 e così via. È consigliabile evitare di utilizzare un numero di caratteri superiore a otto per i nomi dei file.

Metodo 2: copia

Per copiare il contenuto delle cartelle in una nuova cartella per poter eliminare quella precedente, digitare le righe di comando riportate di seguito da un prompt dei comandi, quindi premere INVIO dopo ogni riga:
smartdrv.exe
md nuovonomecartella
copy c:\windows\cookies\*.* c:\windows\nuovonomecartella
smartdrv.exemd nuovonomecartellacopy c:\windows\prefer~1\*.* c:\windows\nuovonomecartella
dove nuovonomecartella è il nome della cartella in cui verrà copiato il contenuto delle cartelle Preferiti e/o Cookies, ad esempio nuopref nuocook.

Se sono stati creati i profili utente ed è necessario copiare il contenuto di più cartelle, è possibile numerarle in sequenza. Ad esempio nuopref1, nuopref2, nuopref3 e così via. È consigliabile evitare di utilizzare un numero di caratteri superiore a otto per i nomi dei file.

Metodo 3: esportazione

NOTA: questo metodo può essere utilizzato solo se è installato Internet Explorer 5 o versione successiva.

Per salvare le cartelle Preferiti e Cookies se è installato Internet Explorer 5 o versione successiva, vedere l'articolo della Microsoft Knowledge Base riportato di seguito:
221523  (http://support.microsoft.com/kb/221523/IT/ ) Description of the Internet Explorer 5 Import/Export Wizard
IMPORTANTE: se sono stati creati profili utente, è necessario accedere al computer utilizzando tutti i profili per esportare con successo tutte le cartelle Preferiti e Cookies con la procedura guidata prima di eliminarle e per assicurarsi che ogni file venga salvato con un nome univoco.

Passaggio 3: eliminare le cartelle correlate a Internet

IMPORTANTE: quando si riavvia il computer le cartelle verranno create di nuovo, ma non il relativo contenuto. Applicando questa procedura, tutti i collegamenti contenuti nella cartella Preferiti e tutti i cookie di siti Web precedentemente visitati verranno eliminati. Se si desidera ripristinare i collegamenti preferiti e i cookie di Internet in un secondo momento, è necessario che siano stati copiati, rinominati o esportati come descritto nel Passaggio 2.

Utilizzare il comando deltree come indicato al Passaggio 1 per eliminare i file delle cartelle Tempor~1, Cookies, Cronologia e Prefer~1. Tempor~1 e Prefer~1 seguono la convenzione di denominazione di MS-DOS 8.3 rispettivamente per le cartelle Temporary Internet Files e Preferiti ed è necessario utilizzarle quando si avvia il computer mediante il comando Prompt dei comandi con supporto di rete.
  1. Digitare i comandi riportati di seguito da un prompt dei comandi. Premere INVIO dopo ogni riga di comando e premere Y e successivamente INVIO se viene richiesto di confermare l'eliminazione di una cartella:
    smartdrv.exe
    deltree c:\windows\tempor~1
    deltree c:\windows\profiles\nomeutente\cookies
    deltree c:\windows\cronologia
    deltree c:\windows\prefer~1
  2. Riavviare il computer.
  3. Fare clic sul pulsante Start, scegliere Trova, quindi File o cartelle.
  4. Nella casella Nome digitare "programmi scaricati" (con le virgolette), quindi fare clic su Trova.
  5. Fare doppio clic sulla cartella Programmi scaricati, fare clic con il pulsante destro del mouse su un file di questa cartella, quindi scegliere Rimuovi. Dopo avere rimosso ogni file della cartella, riavviare il computer.

    IMPORTANTE: se non si intende reinstallare Microsoft Java Virtual Machine, non eliminare il file Win32 Classes dalla cartella Programmi scaricati se esistente.

Passaggio 4: ripristinare le cartelle Preferiti e Cookies

Non completare questo passaggio se non dopo avere tentato di ricreare l'errore. Se l'errore non si verifica più, leggere la nota IMPORTANTE riportata di seguito.

IMPORTANTE: se si verifica lo scenario seguente
  • Il contenuto di una o di entrambe le cartelle Preferiti o Cookies è danneggiato.
  • L'eliminazione di queste cartelle ha risolto il problema.
  • L'importazione nella nuova cartella Preferiti o Cookies riproduce l'errore.
è possibile utilizzare la soluzione riportata di seguito:

Isolare il file danneggiato importando o copiando i file della cartella Preferiti e/o Cookies uno per volta fino a trovare quello danneggiato, quindi ripetere il processo di copia o di importazione, ma non includere il file corrotto.

Metodo 1
  1. Fare clic con il pulsante destro del mouse su Start, scegliere Esplora, quindi trovare la cartella che contiene i collegamenti preferiti o i cookie precedenti, vale a dire la cartella creata nel Passaggio 2.
  2. Aprire la cartella, scegliere Modifica dal menu Strumenti, quindi Seleziona tutto per selezionare tutti i file della cartella.
  3. Fare clic con il pulsante destro del mouse in un punto qualsiasi dell'area selezionata, quindi scegliere Copia.
  4. Trovare e aprire le nuove cartelle Preferiti e Cookies in cui si desidera copiare il contenuto.
  5. Scegliere Modifica dal menu Strumenti, quindi Incolla per incollare tutti i file nella cartella.
  6. Ripetere questa procedura per ciascuna cartella Preferiti e Cookies rinominata o copiata nel Passaggio 2 e che ora si desidera ripristinare.
Metodo 2

Per copiare il contenuto delle cartelle create o rinominate nelle nuove cartelle Preferiti o Cookies, digitare le righe di comando riportate di seguito da un prompt dei comandi, quindi premere INVIO dopo ogni riga:
smartdrv.exe
copy c:\nuovacartella\*.* c:\windows\nuovacartellacreata
Dove:
  • nuovacartella è il nome della cartella creata nel Passaggio 2, in cui è stato copiato il contenuto delle cartelle Preferiti e Cookies, ad esempio nuopref e nuocook.

    NOTA: se sono stati creati i profili utente ed è necessario copiare il contenuto di più cartelle, è possibile numerarle in sequenza. Ad esempio nuopref1, nuopref2, nuopref3 e così via. È consigliabile evitare di utilizzare un numero di caratteri superiore a otto per i nomi dei file.
  • nuovacartellacreata rappresenta le nuove cartelle Preferiti e Cookies create per ogni utente della sottocartella dei profili utente dopo il riavvio del computer.
Metodo 3

NOTA: questo metodo può essere utilizzato solo se è installato Internet Explorer 5 o versione successiva.

Per importare le cartelle dei collegamenti Internet preferiti e dei cookie se è installato Internet Explorer 5 o versione successiva, vedere l'articolo della Microsoft Knowledge Base riportato di seguito:
221523  (http://support.microsoft.com/kb/221523/IT/ ) Description of the Internet Explorer 5 Import/Export Wizard
IMPORTANTE: se sono stati creati profili utente, è necessario accedere al computer utilizzando tutti i profili per importare con successo tutte le cartelle Preferiti e Cookies con la procedura guidata.

Le informazioni in questo articolo si applicano a
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 6.0 alle seguenti piattaforme
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Chiavi: 
kbtshoot kbenv kbprb KB308260
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
 

Traduzione articoli