OFF2000: Feilmeldinger forårsaket av Nimda-viruset når du åpner eller lagrer filer i Office-programmer

Artikkel-ID: 308360
Denne artikkelen ble tidligere utgitt under NO308360
Vis alt | Skjul alt

På denne siden

Symptom

Når du arbeider med en Microsoft Office 2000-programmene som er oppført i begynnelsen av denne artikkelen, oppstår ett av følgende symptomer:
  • Når du prøver å åpne eller lagre Microsoft Word-dokument, får du følgende feilmelding:
    Word har ikkje nok minne. Vil du lagre filnavn som berget filnavn?
  • Når du prøver å åpne en fil i Microsoft Access, Microsoft Excel eller Microsoft PowerPoint, får du følgende feilmelding:
    SDM-feil
  • Den Åpne dialogboksen vises ikke.
  • I FrontPage når du prøver å åpne eller lagre en fil, eller åpne et webområde ved hjelp av Fil -menyen, får du følgende feilmelding:
    Advarsel: FRetry SDM-feil
    Når du klikker OK, du får en annen melding som angir at servertilleggene ikke ble funnet og årsakene (for eksempel servertilleggene er installert, de er feilkonfigurert og så videre).
  • Hvis du dobbeltklikker en Office-fil, åpnes, og avslutter deretter umiddelbart.

Årsak

Disse symptomene kan forårsakes av Nimda-ormviruset (W32/Nimda@MM, W32.Nimda.A@mm eller dens varianter). Hvis du vil ha mer informasjon om denne ormen, kan du gå til følgende webområder:

Norton
http://securityresponse.symantec.com/avcenter/venc/data/W32.Nimda.a@mm.HTML
Microsoft tilbyr tredjeparts kontaktinformasjon for å hjelpe deg med å finne kundestøtten. Disse kontaktopplysningene kan endres uten varsel. Microsoft garanterer ikke nøyaktigheten av disse kontaktopplysningene om tredjeparter.

Løsning

Hvis du vil løse dette problemet, gjør du følgende:
  1. Hvis du vil avgjøre om datamaskinen har Nimda-viruset, kjøre antivirusprogramvare som inneholder den siste virussignaturfilen, og utfører deretter et grundig gjennomsøk av datamaskinen. Kontakt leverandøren av antivirus-programmet for å fjerne viruset.
  2. Hvis du har en kopi av Riched20.dll på datamaskinen, finne og gi nytt navn til denne filen til den navnet Riched20.old, og går videre til trinn 3. Hvis du ikke har en kopi av Riched20.dll på datamaskinen, går du til trinn 3.

    OBS!: Filen kan være skjult. For instruksjoner om hvordan du viser filen, kan du se i dokumentasjonen for operativsystemet.
  3. I Microsoft Windows Utforsker åpner du Msi-mappen på CD-ROMen for Office 2000.
  4. Hvis du bruker Microsoft Windows 95, dobbeltklikker Microsoft Windows 98 eller Microsoft Windows Millennium Edition (Me), du Instmsi.exe. Hvis du bruker Microsoft Windows NT 4.0, dobbeltklikker Microsoft Windows 2000 eller Microsoft Windows XP, du Instmsiw.exe.
  5. Klikk OK til meldingen som forteller deg at Windows Installer ble installert.
  6. Følg trinnene i "Trinn til å reparere Office" senere i denne artikkelen.

Fremgangsmåte for å reparere Office

OBS!: Fordi det finnes flere versjoner av Microsoft Windows, kan følgende være annerledes på din datamaskin. Hvis dette er tilfelle, kan du se i produktdokumentasjonen for å fullføre denne fremgangsmåten.
  1. Avslutt alle programmer som kjører.
  2. Klikk Start, pek på Innstillinger, og klikk deretter I Kontrollpanel.
  3. I I Kontrollpanel, dobbeltklikker du Legg til/fjern programmer -ikonet.
  4. I den Egenskaper for Legg til/fjern programmer i dialogboksen klikker du Office 2000-installasjonen, og klikk deretter Legg til/fjern.
  5. I den Office 2000 Vedlikeholdsmodus i dialogboksen klikker du Reparer Office.
  6. I den Installer på nytt/reparer Office 2000 i dialogboksen klikker du for å velge Reparer feil i Office, og klikk deretter Fullfør.
  7. Når Office-reparasjonen er avsluttet, kan du bli bedt om å starte Windows på nytt. Hvis du blir bedt om å gjøre dette, klikker du Ja å tillate at Windows starter på nytt.

Mer informasjon

Hvis du vil ha mer informasjon om problemer forårsaket av Nimda-ormen når du installerer eller installerer på nytt, kan du klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
308357 OFF: Installasjonsfeil 2889 forårsaket av Nimda-virusinfeksjon
308357 OFF: Installasjonsfeil 2889 forårsaket av Nimda-virusinfeksjon
Hvis du vil ha mer informasjon hvis du får en intern feil 2894 eller 2889, klikker du artikkelnummeret nedenfor for å vise artikkelen i Microsoft Knowledge Base:
236053 OFF2000: Intern feil 2894 under installasjon av Office
290234 OFFXP: Intern feil 2894 under installasjon av Office

Egenskaper

Artikkel-ID: 308360 - Forrige gjennomgang: 3. september 2012 - Gjennomgang: 1.0
Nøkkelord: 
kberrmsg kbprb kbmt KB308360 KbMtno
Maskinoversatt
Viktig: Denne artikkelen har blitt maskinoversatt, og dermed ikke oversatt av en person. For at alle artikler i vår database skal være oversatt til ditt språk, vil Microsoft benytte både personoversatte og maskinoversatte artikler. Det er viktig å merke seg at en maskinoversatt artikkel ikke alltid er perfekt. Det kan forekomme stave, strukturelle eller grammatiske feil. Microsoft er ikke ansvarlig for unøyaktigheter, feil eller skade ved bruk av innhold i artikkel som måtte forårsakes av feiloversettelse. Microsoft vil jevnlig oppdatere sitt maskinoversettelses programvare.
Den engelske versjonen av denne artikkelen er den følgende: 308360

Gi tilbakemelding