Article ID: 308405 - Last Review: January 31, 2007 - Revision: 6.3

TAPI Is Not Terminal Services Aware

This article was previously published under Q308405
Expand all | Collapse all

SYMPTOMS

Programs that control telephone systems through a serial interface (COM port) may not work when using Terminal Services.

Even though you can redirect a COM port to the client in the user session, a Telephony Application Programming Interface (TAPI) Telephone Service Provider (TSP) cannot access the COM port.

CAUSE

This problem occurs because TAPI and the TSPs run as services in Windows 2000 and TSPs cannot access COM ports that are mapped in a user session. Therefore, the services run in a different logon session than the user programs.

Redirected COM ports are mapped in the per-session object name space. For more information about this behavior, view the section about "Kernel Object Name Spaces" in the "Platform SDK: Terminal Services" Microsoft Developer Network (MSDN) chapter.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

Because of the infrastructure in the TAPI architecture, a TSP cannot be Terminal Services aware. There is no existing way to implement a TSP that is Terminal Services aware.

APPLIES TO
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Server Appliance Kit 2.0
Keywords: 
kbenv kbprb KB308405
 

Article Translations

 

Related Support Centers