CÓMO: Conectar una página HTML a una base de datos de Microsoft Access

Seleccione idioma Seleccione idioma
Id. de artículo: 308459 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E308459
Expandir todo | Contraer todo

En esta página

Resumen

Una página de acceso a datos es una página HTML que tiene un componente Web de Office incrustado. El componente Web de Office almacena información de conexión referente a un origen de datos. En este artículo se describe cómo utilizar páginas de acceso a datos para conectar una página HTML a las tablas de una base de datos.

Requisitos

Conocimientos previos requeridos:
  • Conceptos de base de datos
  • Familiaridad con los conceptos y la interfaz de usuario de Microsoft Access

Crear la base de datos de Microsoft Access

  1. Inicie Microsoft Access y, a continuación, cree una nueva base de datos en blanco denominada "HTMLAccess.mdb".
  2. Cree una tabla nueva denominada "Contactos" siguiendo estos pasos:
    1. Bajo Objetos, haga clic en Tablas.
    2. Haga doble clic en Crear una tabla utilizando el asistente . Se mostrará el cuadro de diálogo Asistente para tablas y se le preguntará el tipo de campos que desea crear.
    3. En la lista Tablas de ejemplo, haga clic en Contactos. Haga clic en el botón de la comilla angular (>) 10 veces para copiar los primeros 10 elementos de la lista Campos de ejemplo en la lista Campos en la nueva tabla. Haga clic en Siguiente.
    4. Acepte los valores predeterminados de la segunda página del Asistente y, a continuación, haga clic en Siguiente.
    5. Active la casilla de verificación Introducir datos en la tabla usando un formulario creado por el asistente y, después, haga clic en Finalizar.
  3. Compruebe que se ha creado una nueva tabla denominada "Contactos". Compruebe también que se ha creado un nuevo formulario denominado "Contactos".
  4. Incluya información referente a los dos contactos en el formulario (no tendrá que escribir valores de Id. del contacto). Utilice la tecla TAB para desplazarse de un campo al siguiente.
  5. Haga clic en el botón Cerrar en el formulario Contactos. Guarde el formulario como Contactos.

Método 1: crear la página de acceso a datos utilizando el Asistente

Para crear la página de acceso a datos usando el Asistente, siga estos pasos:
  1. Inicie Microsoft Access. Bajo Objetos, haga clic en Páginas. Haga doble clic en Crear una página de acceso a datos utilizando el asistente . Aparecerá el cuadro de diálogo Asistente para páginas.
  2. Compruebe que la tabla "Contactos" está seleccionada en el cuadro de lista Tablas/Consultas. Haga clic en el botón de la comilla angular doble (>>) para copiar todos los campos del cuadro de lista Campos seleccionados. Seleccione ContactID y haga clic en la comilla angular (<) para cancelar la selección de este campo. Haga clic en Siguiente.
  3. La segunda página del asistente le permite organizar sus datos en grupos, como por ejemplo, organizar los contactos por país. Para que el diseño sea sencillo, haga clic en Siguiente. En la tercera página se le pregunta la forma de ordenación de los registros. Haga clic en Siguiente.
  4. En la última página se le pide el título de la página HTML y se le permite aplicarle un tema a la página. Haga clic en Abrir la página y, a continuación, en Finalizar. Ya está creada y visible la página de acceso a datos.
  5. Use la barra de exploración situada en la parte inferior de la página de acceso a datos para moverse a través de los registros y crear dos contactos más.
  6. En el menú Archivo, haga clic en Guardar. Guarde la página de acceso a datos como "Contactos.htm", en la carpeta Mis documentos.
  7. Lea el mensaje que aparece y haga clic en Aceptar. Cierre la página de acceso a datos.

Método 2: crear la página de acceso a datos utilizando una página HTML existente

Para crear la página de acceso a datos usando una página HTML existente, siga estos pasos:
  1. Inicie el Bloc de notas y escriba el siguiente código HTML:
    <html>
      <head>
        <h1>Accessing Data through HTML and Access</h1>
      </head>
      <body>
        Looking at Excel Web Components to create a DAP
      </body>
    </hmtl>
  2. Guarde el archivo como MiHTML.htm, en la carpeta Mis documentos.
  3. En el Explorador de Windows, haga doble clic en MiHTML.htm. La página HTML aparece en Microsoft Internet Explorer. Salga de Internet Explorer.
Para crear el vínculo a la página de acceso a datos, siga estos pasos:
  1. Inicie Microsoft Access. Bajo Objetos, haga clic en Páginas. Haga doble clic en Modificar una página Web que ya existe . Aparecerá el cuadro de diálogo Buscar página Web. Haga clic en el archivo MiHTML.htm de la carpeta Mis documentos y, a continuación, haga clic en Abrir. La página HTML se abre en la vista Diseño.
  2. Haga clic al final de la línea "Mirar los componentes Web de Excel para crear una página de acceso a datos (DAP)" y, a continuación, presione la tecla ENTRAR para crear un párrafo nuevo.
  3. Cree un hipervínculo a la página HTML Contactos siguiendo estos pasos:
    1. En el menú Insertar, haga clic en Hipervínculo. Aparecerá el cuadro de diálogo Insertar hipervínculo.
    2. En el campo de texto Texto para mostrar, escriba Haga clic aquí para ver la página HTML Contactos
    3. Haga clic en el archivo HTML Contactos.htm en la carpeta Mis documentos.
    4. Haga clic en Aceptar para regresar a la página de acceso a datos.
  4. Haga clic al final del texto recién insertado y presione la tecla ENTRAR para crear una nueva línea en la página de acceso a datos.
Para modificar y probar la página de acceso a datos, siga estos pasos:
  1. Con la página de acceso a datos abierta en la vista Diseño, seleccione elementos de la Lista de campos. Si no puede ver Lista de campos, haga clic en Lista de campos en el menú Ver. En Lista de campos, expanda la tabla Contactos.
  2. Arrastre los campos Nombre y Apellidos a la página de acceso a datos, debajo de la última línea de texto. Se crearán dos pares de etiquetas y cuadros de texto, así como una barra de exploración de registros.
  3. Arrastre la tabla Contactos desde la Lista de campos hasta la página de acceso a datos y, a continuación, colóquela después del último cuadro de texto. Aparecerá el cuadro de diálogo Asistente para formato. Haga clic en Hoja de cálculo de Office y, a continuación, en Aceptar.
  4. Se mostrará el Asistente para relaciones. Acepte la relación y haga clic en Aceptar para regresar a la página de acceso a datos. Se creará y mostrará un componente de hoja de cálculo Web de Office.
  5. En el menú Ver, haga clic en Vista página para probar la página.
  6. Haga clic en Nuevo en la barra de exploración de registros, para borrar el contenido de los cuadros de texto Nombre y Apellidos. Escriba un nombre y apellidos nuevos. Haga clic en Guardar en la barra de exploración de registros. Los nuevos datos se mostrarán en el control de hoja de cálculo.
  7. Guarde y cierre la página de acceso a datos. En Microsoft Access, haga clic en Tablas y, a continuación, haga doble clic en la tabla Contactos. Compruebe que se agregaron nuevos datos a la tabla Contactos y salga de Microsoft Access.

Comprobación

Para abrir la página de acceso a datos, siga estos pasos:
  1. Abra Internet Explorer. En la carpeta Mis documentos, abra el archivo MiHTML.htm.
  2. Compruebe todas las partes de la página.
  3. Haga clic en el hipervínculo para comprobar que se vincula al archivo Contactos.htm.

    NOTA: antes de publicar esta página de acceso a datos en el servidor Web, compruebe que todas las rutas son correctas y cambie los hipervínculos a las direcciones URL.
Para cambiar una conexión, siga estos pasos:
  1. Inicie Microsoft Access. En la vista Diseño de la página de acceso a datos, abra el archivo MiHTML.htm.
  2. Si Lista de campos no está visible, haga clic en Lista de campos, en el menú Ver.
  3. En Lista de campos, haga clic en el icono de propiedades de conexión de Página, situado debajo de la barra de título del panel Lista de campos. Aparecerá el cuadro de diálogo Propiedades de Vínculo de datos.
  4. Compruebe que la conexión corresponde a la ruta correcta a la base de datos.
  5. Si actualiza la base de datos a Microsoft SQL Server, compruebe que el Proveedor OLEDB es el correcto en la ficha Proveedor.
  6. Haga clic en Aceptar para completar los cambios de propiedad de conexión.
Para cambiar una dirección URL, siga estos pasos:
  1. Seleccione el texto descriptivo para el hipervínculo.
  2. En el menú Insertar, haga clic en Hipervínculo. Aparecerá el cuadro de diálogo Modificar hipervínculo.
  3. Escriba la dirección URL en el cuadro Dirección y, a continuación, haga clic en Aceptar.

Referencias

Las páginas de acceso a datos de ejemplo están disponibles en la base de datos Neptuno.

NOTA: la base de datos Neptuno se instala con una instalación completa de Microsoft Office XP Professional.











Propiedades

Id. de artículo: 308459 - Última revisión: martes, 04 de diciembre de 2007 - Versión: 3.2
La información de este artículo se refiere a:
  • Microsoft Office XP Professional Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 6.0 sobre las siguientes plataformas
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
Palabras clave: 
kbhowtomaster KB308459

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com