Il comando MCI_PLAY non restituisce risposte per cinque secondi o pi¨

Traduzione articoli Traduzione articoli
Identificativo articolo: 308928 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Quando viene inviato un comando MCI_PLAY dalla funzione mciSendCommand a una periferica CD-ROM, alcune periferiche non rispondono per cinque secondi o pi¨.

Cause

In Windows XP la riproduzione audio digitale viene attivata installando un driver filtro chiamato Redbook.sys nello stack del driver della periferica CD-ROM. Tale driver emula le operazioni di riproduzione audio leggendo i dati dal CD audio in maniera digitale e inviandoli al flusso kernel. Questo processo funziona bene, ma sembra che MCI invii una richiesta PAUSE_AUDIO fra le tracce, quindi una ricerca per riposizionare la testina dell'unitÓ ottica, infine il comando PLAY_AUDIO per riprendere l'audio. Una volta completato un precedente comando PLAY_AUDIO, Redbook.sys imposta il suo stato interno come se non fosse in atto alcuna riproduzione. Quando poi si verifica la richiesta PAUSE_AUDIO, Redbook.sys non Ŕ in grado di gestirla perchÚ al momento non Ŕ in corso la riproduzione audio, quindi la invia al resto dello stack della periferica.

Quando il comando viene inviato allo stack della periferica, alcune unitÓ (non tutte) rinviano ABORTED_COMMAND al livello ATAPI in quanto l'unitÓ non Ŕ al momento impegnata nella riproduzione audio. Questo errore viene automaticamente (e correttamente) ritentato dai livelli superiori (Cdrom.sys, in questo caso) con una pausa di un secondo per consentire al firmware dell'unitÓ di eseguire il ripristino da questo genere di errore. In Windows la risposta ABORTED_COMMAND viene interpretata come errore grave, che non si verifica nelle unitÓ durante il normale funzionamento, compresa la ricezione di comandi non validi in un determinato momento. Questo comando viene pertanto inviato sei volte, con una pausa di un secondo fra l'una e l'altra, il che dÓ luogo a un ritardo di cinque secondi.

Risoluzione

Per risolvere il problema, procurarsi l'ultimo service pack per Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito (il contenuto potrebbe essere in inglese):
322389 Come ottenere il service pack pi¨ recente per Windows XP
La versione in lingua inglese di questa correzione deve avere i seguenti attributi di file (o successivi):
   Data      Ora    Versione     Dimensione  Nome file
   -----------------------------------------------------
   01/10/01  21.55  5.1.2600.14      55.936  Redbook.sys

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine di questo articolo. Questo problema Ŕ stato corretto per la prima volta nel Service Pack 1 per Windows XP.

Informazioni

╚ noto che il problema descritto in queste articolo riguarda le seguenti periferiche CD-ROM:
Goldstar LG CRD-8400B
CD-RW Kyushu-Matsushita UJDA330
CD-RW NEC 8500A
CD-RW TEAC CD-W28E
CD-ROM TEAC CD-224E

ProprietÓ

Identificativo articolo: 308928 - Ultima modifica: venerdý 31 marzo 2006 - Revisione: 2.3
Le informazioni in questo articolo si applicano a
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Chiavi:á
kbqfe kbhotfixserver kbbug kbfix kboswin2000fix kbwinxpsp1fix KB308928
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com