De opdracht MCI_PLAY retourneert geen antwoord voor vijf of meer seconden

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 308928 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Symptomen

Wanneer een MCI_PLAY-opdracht is verzonden door demciSendCommandnaar een cd-rom-apparaat, werken sommige cd-rom-apparaten niet reageren voor vijf of meer seconden.

Oorzaak

In Windows XP, digitaal afspelen ingeschakeld door een filter stuur programma genaamd Redbook. sys in de stuurprogrammastack voor cd-rom-apparaat installeren. Dit stuur programma emuleert het afspelen van audio bewerkingen door de gegevens van de audio-CD digitaal lezen en te verzenden naar de kernel streaming. Dit werkt prima, maar MCI lijkt een PAUSE_AUDIO tussen tracks, verzendt vervolgens verzendt seek de kop in het optisch station verplaatsen en verzendt vervolgens een opdracht PLAY_AUDIO audio hervatten. Redbook. sys wanneer het klaar is met een eerdere opdracht PLAY_AUDIO, stelt de interne status naar "afspelen". Vervolgens, wanneer de aanvraag PAUSE_AUDIO optreedt, Redbook. sys niet verwerkt dit verzoek omdat er wordt geen audio afgespeeld op het tijd stip en deze naar de rest van de apparaatstack verzendt.

Wanneer deze opdracht wordt verzonden naar de apparaatstack, melden sommige stations (niet alle) ABORTED_COMMAND op de laag ATAPI-omdat het station niet audio wordt afgespeeld. Deze fout wordt automatisch (en goed) herhaald door de bovenste lagen (in dit geval cdrom) met een pauze van één seconde om het station firmware herstellen van dit soort fout. Windows is van mening dat het antwoord ABORTED_COMMAND om een zeer ernstige fout, niet te worden gemeld door de stations in de normale werking, met inbegrip van de opdrachten die ongeldig op een bepaald moment in de tijd zijn krijgen. Deze opdracht is dus zes keer verzonden met een pauze van één seconde tussen elk leidt tot een vertraging van vijf seconden.

Oplossing

Dit probleem kunt oplossen, verkrijgen van het meest recente servicepack voor Windows XP. Voor meer informatie klikt u op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base:
322389Het meest recente Windows XP Service Pack ophalen

Informatie over hotfixes

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter bedoeld om alleen het probleem dat in dit artikel wordt beschreven. Deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet wellicht extra worden getest. Als u geen ernstige problemen ondervindt, is het daarom raadzaam te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix kan gedownload worden, is er een sectie 'Hotfix gedownload' aan het begin van dit Knowledge Base-artikel. Als deze sectie niet wordt weer gegeven, neem u contact op met Microsoft Customer Service and Support om de hotfix te verkrijgen.

OpmerkingAls u nog andere problemen optreden of als er oplossingen vereist zijn, moet u mogelijk een afzonderlijk service verzoek indienen. De normale ondersteunings kosten blijven gelden voor extra ondersteunings vragen die niet in aanmerking voor deze specifieke hotfix komen. Voor een volledige lijst met telefoonnummers van Microsoft Customer Service and Support of een afzonderlijk service verzoek maken, gaat u naar de volgende Microsoft-website:
http://support.Microsoft.com/contactus/?ws=support
OpmerkingHet formulier 'Hotfix downloaden beschikbaar' wordt weer gegeven de talen waarvoor de hotfix beschikbaar is. Als uw taal niet wordt weer gegeven, is omdat een hotfix niet voor die taal beschikbaar.

Bestandsinformatie

De Engelse versie van deze correctie moet de volgende bestands ken merken of hoger:
   Date         Time   Version      Size    File name
   ----------------------------------------------------
   01-Oct-2001  21:55  5.1.2600.14  55,936  Redbook.sys    
				

Status

Microsoft heeft bevestigd dat dit is een probleem in de Microsoft-producten die aan het begin van dit artikel worden vermeld.In Windows XP Service Pack 1 werd voor het eerst een correctie aangebracht voor dit probleem.

Meer informatie

Treedt het probleem dat wordt beschreven in dit artikel worden de volgende cd-rom-apparaten bekend:
Goldstar LG CRD-8400B
Kyushu Matsushita UJDA330 CD-RW
NEC 8500A CD-RW
CD-RW-TEAC CD-W28E
TEAC CD 224E CD-ROM
Opmerking Dit is een artikel voor snelle publicatie dat rechtstreeks is gemaakt vanuit de ondersteuningsorganisatie van Microsoft. De informatie in dit artikel wordt in de huidige vorm aangeboden in reactie op nieuw geconstateerde problemen. Aangezien artikelen van dit type zeer snel moeten worden gepubliceerd, kan de inhoud typografische fouten bevatten en kan de inhoud zonder voorafgaande kennisgeving worden gewijzigd. Raadpleeg de Gebruiksrechtovereenkomst voor overige aandachtspunten.

Eigenschappen

Artikel ID: 308928 - Laatste beoordeling: zondag 27 februari 2011 - Wijziging: 2.0
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Trefwoorden: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kboswin2000fix kbwinxpsp1fix kbmt KB308928 KbMtnl
Automatisch vertaald artikel
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende:308928

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com