O Comando MCI_PLAY Não Retorna Resposta por Cinco ou Mais Segundos

Traduções deste artigo Traduções deste artigo
ID do artigo: 308928 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Quando um comando MCI_PLAY é enviado pela função mciSendCommand para um dispositivo de CD-ROM, alguns dispositivos de CD-ROM não respondem por cinco ou mais segundos.

Causa

No Windows XP, o playback de áudio digital é ativado instalando uma unidade de filtro de nome Redbook.sys na pilha de driver do dispositivo de CD-ROM. Esse driver emula operações de playback de áudio lendo digitalmente os dados do CD de áudio e enviando-os ao streaming de kernel. Isso funciona bem, mas o MCI parece enviar um pedido de PAUSE_AUDIO entre as faixas, depois envia uma busca para reposicionar a cabeça na unidade ótica, e então envia um comando PLAY_AUDIO para continuar com o áudio. O arquivo Redbook.sys, ao finalizar um comando PLAY_AUDIO anterior, seleciona seu estado interno para "não está tocando". Então, quando ocorre o pedido PAUSE_AUDIO, o arquivo Redbook.sys não gerencia esse pedido porque não está tocando áudio no momento, e o envia para o restante da pilha de dispositivos.

Quando esse comando é enviado para a pilha de dispositivos, algumas unidade (não todas) indicam ABORTED_COMMAND na camada ATAPI porque a unidade não está reproduzindo áudio. As camadas superiores (nesse caso, Cdrom.sys) efetuam nova tentativa de correção automaticamente (e corretamente) com uma pausa de um segundo para permitir que o firmware da unidade se recupere desse tipo de erro. O Windows acredita que a resposta ABORTED_COMMAND seja um erro muito grave, que não deve ser comunicado por unidades em operação normal, incluindo a recepção de comandos inválidos num dado momento. Esse comando é portanto enviado seis vezes, com uma pausa de um segundo cada, resultando num atraso de cinco segundos.

Resolução

Para resolver esse problema, obtenha o service pack mais recente para o Windows XP. Para obter informações adicionais, clique no número abaixo para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
322389 How to Obtain the Latest Windows XP Service Pack
A versão em inglês desta correção deverá ter os seguintes atributos de arquivo ou posteriores:
   Data         Hora   Versão       Tamanho     Nome do arquivo
   ----------------------------------------------------
   01-Oct-2001  21:55  5.1.2600.14  55,936  Redbook.sys    
				

Situação

A Microsoft informa que este problema pode ocorre em seu(s) produto(s) listado(s) na secção "Aplica-se" deste artigo. Esse problema foi corrigido primeiro no Windows XP Service Pack 1.

Mais Informações

As seguintes unidades de CD-ROM são conhecidas por exibirem o problema descrito neste artigo:
Goldstar LG CRD-8400B
Kyushu-Matsushita UJDA330 CD-RW
NEC 8500A CD-RW
TEAC CD-W28E CD-RW
TEAC CD-224E CD-ROM

Propriedades

ID do artigo: 308928 - Última revisão: quinta-feira, 13 de abril de 2006 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Palavras-chave: 
kbqfe kbhotfixserver kbbug kbfix kboswin2000fix kbwinxpsp1fix KB308928

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com