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FP2000: Files of Type List for Database Drivers Is Empty

Article ID:308935
Last Review:June 27, 2007
Revision:2.8
This article was previously published under Q308935
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SYMPTOMS

When you try to add a new database connection to your Microsoft FrontPage Web, you may notice that the Files of type list in the Database Files In Current Web dialog box is empty.

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CAUSE

This behavior can occur when you install Microsoft Data Access Components (MDAC) version 2.5 on the Microsoft Windows NT 4.0-based server computer without having first installed MDAC 2.1.

Microsoft FrontPage uses the registry settings created by MDAC 2.1 to populate the Files of type list with the list of available database drivers. If you install MDAC 2.5 without first installing MDAC 2.1, these registry settings are not created and the Files of type list in FrontPage remains empty.

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RESOLUTION

To resolve this issue, reconfigure Microsoft Windows NT to use MDAC 2.1 SP2, and then reinstall MDAC 2.5. To do this, follow these steps.

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Download Microsoft Component Checker

Download Microsoft Component Checker (ComCheck). To do this, follow these steps:
1.Visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/data/aa937695.aspx#CCinfo (http://msdn2.microsoft.com/en-us/data/aa937695.aspx)
2.Click the Component Checker tool link.
3.In the File Download dialog box, click Save this program to disk, and then click OK.
4.In the Save As dialog box, select Desktop in the Save in box, and then click Save.

Note: The file name listed should be Cc.exe.
5.When the download process is complete, click OK.
6.Double-click the self-extracting Cc.exe file, and then extract the ComCheck tool to the C:\comcheck folder.

Note: You can start the ComCheck tool from the command line, or you can double-click the ComCheck.exe icon that is in the C:\Comcheck folder.

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Download the ListDLLs Utility

Download the ListDLLs utility. To do this, follow these steps.

Note: Although this third-party utility does not have to reconfigure MDAC, it may aid you in determining the background processes that must be stopped to reconfigure MDAC.
1.Visit the following Sysinternals Web site:
http://technet.microsoft.com/en-us/sysinternals/bb896656.aspx (http://technet.microsoft.com/en-us/sysinternals/bb896656.aspx)
2.Click the Download ListDLLs (x86-45KB) link.
3.In the File Download dialog box, click Save this program to disk, and then click OK.
4.In the Save As dialog box, select Desktop in the Save in box, and then click Save.

Note: The file name listed should be Listdlls.exe.
5.When the download process is complete, click OK.

Note: To use the ListDlls program, start a command prompt, and then type listdlls /? for a list of the command line switches.

Example: To list the DLL files in use by each process, type listdlls |more. Note the processes that use the DLL files that you want to release. End the process from within Windows Task Manager.

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Download MDAC 2.1 SP2

Download MDAC 2.1 SP2 (MDAC 2.1.2.4202.3 (GA)). To do this, follow these steps:
1.Visit to the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?familyid=0e1e4fae-4abe-4cf7-b522-2c4cfce25de6&displaylang=en (http://www.microsoft.com/downloads/details.aspx?familyid=0e1e4fae-4abe-4cf7-b522-2c4cfce25de6&displaylang=en)
2.Under Select an Install Option, click MDAC 2.1.2.4202.3 (GA) for x86 (typical install) English, and then click Go to Download.
3.In the File Download dialog box, click Save this program to disk, and then click OK.
4.In the Save As dialog box, click Desktop in the Save in box, click the Create New Folder button, name the folder MDAC2.1, double-click the MDAC2.1 folder, and then click Save.

Note: The file name listed should be Mdac_typ.exe. The file is saved in the new MDAC2.1 folder that you created on the Desktop.
5.When the download process is complete, click OK.

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Download MDAC 2.5 SP2

Download MDAC 2.5 SP2. To do this, follow these steps:
1.Visit to the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyID=46d81374-79d7-466e-a110-5b2fb9da20f6&DisplayLang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=46d81374-79d7-466e-a110-5b2fb9da20f6&DisplayLang=en)
2.Under Select an Install Option, click MDAC 2.5 SP2 (2.52.6019.2) for x86 - English, and then click Go to Download.
3.In the File Download dialog box, click Save this program to disk, and then click OK.
4.In the Save As dialog box, select Desktop in the Save in box, click the Create New Folder button, name the folder MDAC2.5, double-click the MDAC2.5 folder, and then click Save.

Note: The file name listed should be Mdac_typ.exe. The file is saved in the new MDAC2.5 folder that you created on the Desktop.
5.When the download process is complete, click OK.
6.Use the ComCheck tool to reconfigure Windows with MDAC 2.1.

For additional information about reconfiguring Windows by using the ComCheck tool, click the article number below to view the article in the Microsoft Knowledge Base:
307255 (http://support.microsoft.com/kb/307255/EN-US/) Info: Component Checker: Diagnose Problems and Reconfigure MDAC Installations

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Reinstall MDAC 2.5

1.Double-click the Mdac_typ.exe file in the MDAC2.5 folder that you created on the Windows desktop. Follow the instructions to install MDAC 2.5.
2.Restart the computer.
3.Verify that all stopped services are started.

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MORE INFORMATION

For additional information about troubleshooting MDAC, click the article number below to view the article in the Microsoft Knowledge Base:
232060 (http://support.microsoft.com/kb/232060/EN-US/) HOWTO: MDAC Setup Troubleshooting Guide
For additional support information about MDAC, visit the following Microsoft Web site:
http://msdn.microsoft.com/dataaccess (http://msdn.microsoft.com/dataaccess)
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.


Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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APPLIES TO
Microsoft FrontPage 2000 Standard Edition, when used with:
  Microsoft Windows NT 4.0

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Keywords: 
kbprb KB308935

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