Error when users reset Windows password in an Exchange environment: Unable to update the password

Original KB number:  3090164

Symptoms

Users in a Microsoft Exchange Server environment receive the following error message when they try to set a new password for Windows:

Unable to update the password. The value provided for the new password does not meet the length, complexity, or history requirements of the domain.

Note

The Exchange ActiveSync mailbox policy setting is configured to use the following password requirements:

AlphanumericPasswordRequired : False
PasswordEnabled              : True
PasswordRecoveryEnabled      : False
AllowSimplePassword          : True
MinPasswordLength            : 4
MaxPasswordFailedAttempts    : 10
PasswordExpiration           : Unlimited
PasswordHistory              : 0
MinPasswordComplexCharacters : 1

Cause

Local accounts must meet the following requirements when any password policy is set:

MinPasswordLength            : 6
MinPasswordComplexCharacters : 3

Resolution

This behavior is by design. The user must create a password that meets these complexity requirements.

More information

For more information, see the Exchange ActiveSync policy engine overview.