DLL ファイルの登録時にライブラリの読み込みが失敗する

文書翻訳 文書翻訳
文書番号: 309288 - 対象製品
すべて展開する | すべて折りたたむ

現象

Regsvr32.exe プログラムを使用して、Rsabase.dll、Rsaenh.dll、または Schannel.dll ファイルを登録するとき、以下のいずれかのエラー メッセージが表示されることがあります。
Regsvr32

LoadLibrary("file name.dll") failed.
- GetLastError の戻り値: 0x000001f
または
Regsvr32

LoadLibrary("file name.dll") failed.
- GetLastError の戻り値: 0x00000002
または
Regsvr32

LoadLibrary("file name.dll") failed.
- GetLastError の戻り値: 0x00000485
ここで、file name は登録する .dll ファイルの名前です。

原因

この問題は、Rsabase.dll、Rsaenh.dll、または Schannel.dll ファイルの依存ファイルが見つからないか、破損している場合に発生する可能性があります。

解決方法

この問題を解決するには、必要なファイルの新しいコピーを以下の一覧から抽出します。必要なファイルは、エラー メッセージ内に示されるファイルに依存します。
  • Schannel.dll ファイルの依存ファイル
    Msasn1.dll
    Msvcrt.dll
    Advapi32.dll
    Wsock32.dll
    Crypt32.dll
    Rpcrt4.dll
    Version.dll
    Kernel32.dll
    User32.dll
    Gdi32.dll
  • Rsabase.dll ファイルの依存ファイル
    Advapi32.dll
    Ole32.dll
    Kernel32.dll
    User32.dll
    Gdi32.dll
  • Rsaenh.dll ファイルの依存ファイル
    Advapi32.dll
    Ole32.dll
    Kernel32.dll
    Gdi32.dll
ファイルの抽出の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
129605 [HOWTO] 圧縮されたファイルから元の Windows ファイルを抽出する方法

詳細

Microsoft Internet Explorer で暗号強度の問題をトラブルシューティングする方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
261328 Internet Explorer で暗号強度が 0 ビットと表示される
ライブラリの読み込みの失敗に関するエラー メッセージの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
177855 エラー メッセージ : LoadLibrary(rsabase.dl) に失敗しました
Regsvr32 ツールの使用方法およびエラー メッセージの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
249873 Regsvr32 ツールの使用法とエラー メッセージについて

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 309288 (最終更新日 2003-12-05) を基に作成したものです。

プロパティ

文書番号: 309288 - 最終更新日: 2005年5月20日 - リビジョン: 2.0
この資料は以下の製品について記述したものです。
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
キーワード:?
kberrmsg kbprb KB309288
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"
サポート期間が終了した「サポート技術情報」資料に関する免責事項
この資料は、マイクロソフトでサポートされていない製品について記述したものです。そのため、この資料は現状ベースで提供されており、今後更新されることはありません。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com