You receive a "Microsoft Visio has encountered a problem and needs to close" error message that contains an error signature in Gdiplus.dll when you start Visio 2002 for the first time

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Article ID: 309455 - View products that this article applies to.
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Symptoms

When you start Microsoft Visio 2002 for the first time on your Microsoft Windows 98-based computer, you receive an error message that is similar to the following:
Microsoft Visio has encountered a problem and needs to close. We are sorry for the inconvenience.

To see what data this error report contains, click here.
When you view the data in the error report, the report contains an error signature that lists Gdiplus.dll next to ModName.

Cause

This issue may occur if third-party fonts are installed on your computer, and the fonts prevent Visio from starting correctly. For example, you may experience this issue if fonts from a Practitioners Publishing Company (PPC) product are installed on your computer.

Workaround

To work around this issue, follow these steps:
  1. Copy the third-party fonts from the Fonts folder to a new folder on your desktop. To do this, follow these steps:
    1. Right-click an empty area of the desktop, point to New, and then click Folder.
    2. Type Removed Fonts, and then press ENTER.
    3. Click Start, point to Settings, and then click Control Panel.
    4. Double-click Fonts.
    5. Copy the third-party fonts from the Fonts folder to the Removed Fonts folder. To do this, press and hold down the CTRL key, and then select each font. Click Copy on the Edit menu to copy the group of selected fonts.

      For example, if a Practitioners Publishing Company (PCC) product is installed on your computer, copy the following fonts to the Removed Fonts folder:
      • CentSchbook BT Bold
      • CentSchbook BT Bold Italic
      • CentSchbook BT Italic
      • CentSchbook BT Roman
      Note There may be additional Practitioners Publishing Company (PCC) fonts that are installed on the computer that you may have to copy to the Removed Fonts folder.
    6. Open the Removed Fonts folder, and then click Paste on the Edit menu.
  2. Delete the fonts that you copied to the Removed Fonts folder in step 1 from the Fonts folder. For example, if a Practitioners Publishing Company (PPC) product is installed on your computer, delete the following fonts from the Fonts folder:
    • CentSchbook BT Bold
    • CentSchbook BT Bold Italic
    • CentSchbook BT Italic
    • CentSchbook BT Roman
    Note There may be additional Practitioners Publishing Company (PPC) fonts that are installed on your computer that you may have to delete from the Fonts folder.

    To do this, right-click each font, and then click Delete. Click OK when you are prompted to confirm the deletion.

    Note If you delete fonts that are used by the operating system, fonts in Windows components may not be displayed correctly.
  3. Start Microsoft Windows Explorer, and then locate the following folder:
    Drive:\Program Files\Microsoft Office\Visio10\1033\Filters
  4. Right-click Isgdi32.ini, click Rename, type Isgdi32.old, and then press ENTER. If you are prompted to verify the change in the file name extension, click Yes.
  5. Restart the computer.
  6. Start Visio.

More information

To contact Practitioners Publishing Company (PPC), visit the following PPCnet Web site:
http://ppc.thomson.com/sitecomposer2/
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For more information about our policy on error-reporting and data collection, visit the following Microsoft Web site. The following Microsoft Web site provides additional information about Microsoft Error Reporting. It contains information about why the error data is collected, what type of data is collected, how data is stored, and who has access to the data:
http://oca.microsoft.com/en/dcp20.asp
For additional information about our privacy policy in application error reporting, click the following article number to view the article in the Microsoft Knowledge Base:
283768 Description of the end user privacy policy in application error reporting when you are using Office

Properties

Article ID: 309455 - Last Review: October 26, 2013 - Revision: 6.0
Applies to
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Visio 2002 Professional Edition, when used with:
    • Microsoft Windows 98 Standard Edition
Keywords: 
kbnosurvey kbarchive kbtshoot kberrmsg kbprb KB309455

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