PRB: Cuadrado muestra cuadros en Netscape Navigator 4.x redibujado cuando puede ver páginas ASP.NET

Seleccione idioma Seleccione idioma
Id. de artículo: 309548 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

Síntomas

Cuando se vuelve a dibujar texto en una página Web ASP.NET en Netscape Navigator 4. aparecen de cuadrados de x , en lugar de texto original. Este problema no se produce en Netscape 6.0 y versiones posteriores.

Causa

ASP.NET utiliza una codificación predeterminada de UTF-8. Este problema se produce porque Netscape Navigator 4. x encuentra problemas cuando vuelve a mostrar texto codificado en UTF-8.

Solución

Para evitar este problema, agregue el siguiente texto para cambiar la codificación de la página Web ASP.NET afectada:
<%
   Response.ContectEncoding = Encoding.ASCII
%>
				
para cambiar la codificación en todo el proyecto aplicación Web, cambie la línea siguiente en el archivo Web.config de
<globalization requestEncoding="utf-8" responseEncoding="utf-8" />
				
a:
<globalization requestEncoding="utf-8" responseEncoding="ascii" />
				

Más información

Puede producirse una actualización en las siguientes circunstancias:
  • Un menú ha superpuesto el texto y se quitó.
  • Otra ventana se coloca sobre el texto y se quita.
  • Cualquier otra instancia en el que texto está oculto detrás de algo.
Para reproducir este problema, ver una página ASP.NET en Netscape Navigator 4. x . La página ASP.NET debe representar texto desde un archivo de script incluido o modificar la página original mediante secuencias de comandos (que es, agregar o quitar una capa).

Propiedades

Id. de artículo: 309548 - Última revisión: viernes, 14 de febrero de 2014 - Versión: 2.2
La información de este artículo se refiere a:
  • Microsoft ASP.NET 1.0
Palabras clave: 
kbnosurvey kbarchive kbmt kbconfig kbbrowse kbprb kbreadme kbwebforms KB309548 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 309548

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com