文書番号: 310049 - 最終更新日: 2011年11月28日 - リビジョン: 6.0

Outlook でハイパーリンクをクリックすると、エラー メッセージが表示される

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目次

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現象

Microsoft Outlook でハイパーリンクをクリックすると、次のエラー メッセージが表示されることがあります。
このコンピューターに設定された制限のため、操作が取り消されました。システム管理者に問い合わせてください。

原因

新しいバージョンの Microsoft Internet Explorer?にアップグレードした後で、次のレジストリ キーが存在していないか、破損していることがあります。
HKEY_Local_Machine\Software\Classes\htmlfile\shell\open\command
このページでこの問題を解決するには、「Fix it で解決する」セクションに進んでください。自分でこの問題を解決する場合は、「自分で解決する」セクションに進んでください。

Fix it で解決する

この問題を自動的に解決するには、[この問題を解決する] リンクをクリックします。続いて [ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、このウィザードの手順に従います。

この問題を解決する
Microsoft Fix it 50388


注: このウィザードは英語版のみである場合がありますが、自動的な解決は英語版以外の Windows でも機能します。

注: 問題のあるコンピューターとは別のコンピューターを操作している場合、自動的な解決ツールをフラッシュ ドライブまたは CD に保存することで、問題のあるコンピューターで実行することができます。

自分で解決する

この問題を解決するには、別のコンピューターからレジストリ キーをインポートします。

注: この問題は、Internet Explorer の Web の設定をリセットすることにより解決できる場合があります。これを行うには、使用している Internet Explorer のバージョンに合わせて以下のいずれかの手順に従います。

Internet Explorer 6

  1. Internet Explorer を起動します。
  2. [ツール] メニューの [インターネット オプション] をクリックします。
  3. [プログラム] タブをクリックし、[Web の設定のリセット] をクリックします。[Web の設定のリセット] ダイアログ ボックスで、[はい] をクリックし、[OK] をクリックします。
  4. [インターネット プログラム] で、適切な電子メール プログラムが選択されていることを確認します。
  5. [Internet Explorer の起動時に、通常使用するブラウザーを確認する] チェック ボックスをオンにします。
  6. [適用] をクリックし、[OK] をクリックします。

    注: Internet Explorer を起動したときに、次のメッセージが表示されることがあります。
    Internet Explorer は、既定のブラウザーとして設定されていません。既定のブラウザーとして設定しますか?
    このメッセージが表示されたら、[はい] をクリックします。

Internet Explorer 7 および Internet Explorer 8

  1. Internet Explorer を起動します。
  2. [ツール] メニューの [インターネット オプション] をクリックします。
  3. [詳細設定] タブをクリックし、[リセット] をクリックします。
  4. [プログラム] タブをクリックし、[プログラムの設定] をクリックします。
  5. [既定のプログラムの設定] をクリックします。
  6. [Microsoft Outlook] チェック ボックスをオンにし、[このプログラムを既定として設定する] をクリックします。
  7. [OK] をクリックして [既定のプログラム] ダイアログ ボックスを閉じます。
  8. [インターネット オプション] ダイアログ ボックスで [プログラム] タブをクリックし、[既定の Web ブラウザー] の下の [既定とする] をクリックします。
  9. [OK] をクリックします。

Internet Explorer 9

  1. Internet Explorer を起動します。
  2. [ツール] メニューの [インターネット オプション] をクリックします。
  3. [詳細設定] タブをクリックし、[リセット] をクリックします。
  4. [プログラム] タブをクリックし、[プログラムの設定] をクリックします。
  5. [既定のプログラムの設定] をクリックします。
  6. [Microsoft Outlook] チェック ボックスをオンにし、[このプログラムを既定として設定する] をクリックします。
  7. [OK] をクリックして [既定のプログラム] ダイアログ ボックスを閉じます。
  8. [インターネット オプション] ダイアログ ボックスで [プログラム] タブをクリックし、[既定の Web ブラウザー] の下の [既定とする] をクリックします。
  9. [OK] をクリックします。

別のコンピューターからレジストリ キーをエクスポートしてインポートする

重要 このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを変更する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしてください。問題が発生した場合でも、レジストリを復元できます。レジストリのバックアップ方法および復元方法の詳細については、以下のサポート技術情報番号をクリックしてください。
322756? (http://support.microsoft.com/kb/322756/ja/ ) Windows でレジストリをバックアップおよび復元する方法
注: この方法は、使用しているブラウザーに応じて上記の手順を実行しても問題が解決しない場合にのみ使用してください。

別のコンピューターからレジストリ キーをエクスポートする

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスに「regedit」と入力し、[OK] をクリックします。
  3. 次のレジストリ キーを見つけます。
    HKEY_Local_Machine\Software\Classes\htmlfile\shell\open\command
  4. [Command] フォルダーをクリックします。
  5. [ファイル] メニューまたは [レジストリ] メニュー (オペレーティング システムによって異なります) の [エクスポート] をクリックします。
  6. ファイルを保存する場所をメモしておきます。レジストリ ファイルは、ハード ドライブに直接保存することも、フロッピー ディスクに保存することもできます。
  7. 固有のファイル名を入力し、[保存] をクリックします。
  8. レジストリ エディターを終了します。

レジストリ キーをインポートする

  1. エクスポートしたレジストリ キーを、問題の発生しているコンピューターのデスクトップにコピーします。
  2. .reg ファイルをダブルクリックします。

    次のメッセージが表示されます。
    drive: location file was copied to\file name.reg 内の情報をレジストリに追加しますか?
  3. [はい] をクリックし、[OK] をクリックします。

"HKEY_CLASSES_ROOT \.html" キーの文字列 (既定) が "htmlfile" であるかどうかを確認する

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスで「regedit」と入力し、[OK] をクリックします。
  3. 次のレジストリ キーを見つけます。
    HKEY_CLASSES_ROOT \.html
  4. [文字列 (既定)] の値が "htmlfile" であるかどうかを確認します。"htmlfile" ではない場合は、[(既定)] を右クリックし、[修正] をクリックします。[値のデータ] ボックスに「htmlfile」と入力し、[OK] をクリックします。
  5. レジストリ エディターを終了します。


この資料は以下の製品について記述したものです。
  • Microsoft Outlook 2010
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard Edition
キーワード:?
kbfixme kbregistry kberrmsg kbnofix kbprb kbmsifixme KB310049
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