Błąd zatrzymania podczas uaktualniania systemu Windows 2000: Bad_Pool_Caller 0xC2

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 310527 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Podczas uaktualniania komputera Compaq Professional Workstation AP550 z systemu Microsoft Windows 2000 Professional do systemu Windows XP mogą wystąpić następujące objawy:
  • Jeśli podczas instalacji zostanie wybrana opcja Tak, pobierz zaktualizowane pliki instalacji (zalecane) w oknie dialogowym Pobieranie zaktualizowanych plików instalacji, w oknie dialogowym Raport o zgodności systemu pojawi się następujący komunikat:
    Następujące elementy nie są zgodne z systemem Windows XP. Przed ponownym uruchomieniem Instalatora należy rozwiązać problemy ze zgodnością niektórych spośród tych elementów.

    Aby uzyskać więcej informacji o elemencie, zaznacz go i kliknij przycisk Szczegóły.

    Winnov Videum Software
    Kliknięcie przycisku Szczegóły spowoduje pojawienie się następującego komunikatu:
    To oprogramowanie jest niezgodne z tą wersją systemu Windows i musi zostać odinstalowane przed uaktualnieniem.

    Aby uzyskać listę urządzeń i aplikacji obsługiwanych przez tę wersję systemu Windows, zobacz listę zgodnego sprzętu i oprogramowania w witrynie firmy Microsoft w sieci Web.
  • Jeśli podczas instalacji zostanie wybrana opcja Nie, pomiń ten krok i kontynuuj instalowanie systemu Windows w oknie dialogowym Pobieranie zaktualizowanych plików instalacji, pojawi się następujący komunikat o błędzie na niebieskim ekranie:
    STOP 0xC2
    BAD_POOL_CALLER

Przyczyna

Ten problem może wystąpić, jeśli komputer zawiera kartę do przechwytywania wideo Winnov Videum AVI z zainstalowanym programem Videum w wersji 2.9.2 (to oprogramowanie zawiera plik Winnov32.sys w wersji 200.9.2812).

Rozwiązanie

Jeśli podczas instalacji zostanie wybrana opcja Tak, pobierz zaktualizowane pliki instalacji (zalecane) w oknie dialogowym Pobieranie zaktualizowanych plików instalacji, należy usunąć oprogramowanie Winnov Videum, korzystając z narzędzia Dodaj lub usuń programy w Panelu sterowania, i ponownie zainstalować system Windows XP.

Jeśli podczas instalacji zostanie wybrana opcja Nie, pomiń ten krok i kontynuuj instalowanie systemu Windows w oknie dialogowym Pobieranie zaktualizowanych plików instalacji, należy wykonać następujące czynności:
  1. Uruchom komputer w taki sposób, aby przejść do wiersza polecenia.

    Jeśli komputer korzysta z systemu plików FAT, uruchom komputer za pomocą dysku startowego systemu Microsoft Windows 95, Microsoft Windows 98 lub Microsoft Windows Millennium Edition. Jeśli komputer korzysta z systemu plików NTFS, uruchom komputer za pomocą Konsoli odzyskiwania.
  2. Usuń pliki: Winnov32.sys, Wnvkaud.sys, Wnvcom.sys oraz Wnkvid.sys znajdujące się w folderze %Windir%\System32\Drivers.
  3. Ponownie uruchom komputer z dysku twardego.
  4. Kliknij opcję Kontynuuj pracę z Instalatorem Windows XP.
Aktualizacja rozwiązująca ten problem jest teraz instalowana za pomocą funkcji Aktualizacje dynamiczne systemu Windows XP. Aby uzyskać dodatkowe informacje, kliknij numer artykułu poniżej w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
311220 Description of the Dynamic Update Feature in Windows XP Setup

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych na początku tego artykułu.

Więcej informacji

Aby uzyskać dodatkowe informacje, kliknij numer artykułu poniżej w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
311220 Description of the Dynamic Update Feature in Windows XP Setup
Aby uzyskać więcej informacji na temat karty graficznej Videum AVI, odwiedź następującą witrynę firmy Winnov w sieci Web:
http://www.winnov.com/?page=products&sub=videum
Firma Microsoft udostępnia informacje dotyczące sposobów kontaktowania się z innymi firmami, aby ułatwić uzyskanie niezbędnej pomocy technicznej. Informacje te mogą się zmienić bez powiadomienia. Firma Microsoft nie gwarantuje dokładności informacji dotyczących innych firm.

Produkty omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie daje żadnych gwarancji, domyślnych ani żadnego innego rodzaju, odnośnie do wydajności lub niezawodności tych produktów.

Właściwości

Numer ID artykułu: 310527 - Ostatnia weryfikacja: 17 lipca 2006 - Weryfikacja: 2.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Słowa kluczowe: 
kbenv kberrmsg kbbug kbfix KB310527

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com