Help and Support
 

powered byLive Search

"Drive's Contents Have Changed: Restarting" Message When You Use Disk Defragmenter

Article ID:310541
Last Review:March 24, 2008
Revision:2.0
This article was previously published under Q310541
On This Page

SYMPTOMS

When you use the Disk Defragmenter tool to defragment your hard disk, you may receive the following message:
Drive's Contents Have Changed: Restarting...

Back to the top

CAUSE

This issue can occur if a program (such as an antivirus program or a screen saver) is running on the drive when the Disk Defragmenter tool is running.

Back to the top

RESOLUTION

To work around this issue, use one of the following methods.

NOTE: To analyze or defragment a volume you must logon using an account with administrator privileges.

Back to the top

Clean Boot the Computer

A "clean" boot is a method of reducing problems that may occur because of your computer's environment. Many problems that may occur when you run Windows or other programs can occur because there are conflicting drivers, terminate-and-stay-resident programs (TSRs), or other settings that load when you start your computer. Windows XP includes a System Configuration Utility tool (Msconfig.exe) to make performing a clean boot easier.

For additional information about clean booting in Windows XP, click the article number below to view the article in the Microsoft Knowledge Base:
310353 (http://support.microsoft.com/kb/310353/EN-US/) How to Perform a Clean Boot in Windows XP

Back to the top

Use Safe Mode

Instead of performing a clean boot, you may want to restart your computer in Safe mode, and then start the Disk Defragmenter tool. After you run Disk Defragmenter, restart your computer.

To start the computer in safe mode:
1.Click Start, and then click Shut Down.
2.In the Shut Down Windows dialog box, click Restart, and then click OK.
3.Press F8 when your computer restarts.
4.In the Windows Advanced Options menu, use the arrow keys to select the appropriate safe mode option, and then press ENTER.
5.If you have a dual-boot or multiple-boot system, choose the installation that you need to access using the arrow keys, and then press ENTER.

Back to the top

MORE INFORMATION

For additional information about how to troubleshoot issues with Disk Defragmenter, click the article number below to view the article in the Microsoft Knowledge Base:
305781 (http://support.microsoft.com/kb/305781/EN-US/) HOW TO: Analyze and Defragment a Windows XP Disk
227463 (http://support.microsoft.com/kb/227463/EN-US/) Disk Defragmenter Limitations in Windows 2000 and Windows XP
231176 (http://support.microsoft.com/kb/231176/EN-US/) Running Windows Disk Defragmenter Requires Administrator Privileges

Back to the top


APPLIES TO
Microsoft Windows XP Professional x64 Edition
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional

Back to the top

Keywords: 
kbdefrag kberrmsg kbprb KB310541

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.