Numéro d'article: 310586 - Dernière mise à jour: jeudi 25 octobre 2007 - Version: 2.12

L'instance MSSearch Exchange n'est pas mise en ligne sur un cluster et l'événement ID 3055 et 10006 sont enregistrés

A noterCet article s'applique à un système d'exploitation différent de celui que vous utilisez. Le contenu de l'article qui ne vous concerne peut-être pas est désactivé.

Sommaire

Agrandir tout | Réduire tout

Symptômes

L'instance MSSearch Exchange n'est pas mise en ligne sur un cluster Microsoft Windows 2000 Server et les événements suivants sont consignés dans le journal des événements Applications :
Événement 1

Type d'événement : avertissement
Source de l'événement : recherche de Microsoft
Catégorie d'événement : rassembleur
L'ID d'événement : 3055
Description : le fichier de mappage propriété du rassembleur ne peut pas être ouvert. Erreur : 80070002. Les valeurs par défaut sont utilisées. Vous devrez copier le fichier de mappage de propriété à partir du CD-ROM d'installation, ou réinstallez le programme.

Événement 2

Type d'événement : Erreur
Source de l'événement : recherche de Microsoft
Catégorie d'événement : rassembleur
L'ID d'événement : 10006
Description : une erreur s'est produite lors de l'opération en ligne pour l'instance < Exchange Instance MS Search - (EXCLUVS1 D) >: 80070002 - le système ne peut pas trouver le fichier spécifié.

Selon la cause racine du problème, peut également s'afficher une ou plusieurs des messages d'erreur suivants :
Message d'erreur 1
80070002 Le système ne peut pas trouver le fichier spécifié.
Message d'erreur 2
80070005 L'accès est refusé.
Message d'erreur 3
80070006 Le handle n'est pas valide.
Message d'erreur 4
Message d'erreur 80070003 - le système ne trouve pas le chemin d'accès spécifié.

Cause

Lorsque l'instance Exchange MSSearch est mis en ligne, MSSearch recherche les fichiers de configuration présents dans le drive : dossier Exchange Virtual Server Name \EXCHSRVR\ExchangeServer_. Les noms de ces fichiers de configuration sont Clust0.0, Clust0.1, Clust1.0 et ainsi de suite.

Les fichiers de configuration contiennent des informations très importants sur le chemin d'accès intégral l'indexation de texte d'application, des chemins d'accès de catalogue, des chemins d'accès de l'index et plus. Ces fichiers sont spécifiques au cluster et au serveur virtuel Exchange.

Si l'instance Exchange MSSearch ne pouvez pas accéder les fichiers de configuration, l'instance MSSearch Exchange n'est pas mise en ligne et les messages d'erreur qui sont mentionnés dans la section « Symptômes » s'afficher.

Les messages d'erreur peuvent se produire si une des conditions suivantes est remplie :
  • Le dossier ExchangeServer_ Exchange Virtual Server Name ou son contenu a été supprimé ou renommé (erreur 80070002).
  • Le dossier ExchangeServer_Exchange Virtual Server Name ou son contenu a été copié à partir un serveur différent sur le serveur en cluster (erreur 80070003).
  • Le compte système et le compte administrateur ne devez pas les autorisations suffisantes dans le dossier ExchangeServer_ Exchange Virtual Server Name ou son contenu (erreur 80070005).
  • Le compte système et le compte d'administrateur n'ont pas suffisamment d'autorisations à la sous-clé de Registre
    HKLM\Software\Microsoft\Search\1.0
    ou à ses sous-clés (erreur 80070005 ou 80070006).

Résolution

Pour résoudre ce problème, vous devez tout d'abord déterminer la cause racine du problème à l'aide des utilitaires tels que File Monitor (Filemon.exe) et le moniteur du Registre (Regmon.exe). Pour obtenir ces utilitaires, reportez-vous au site Web suivant :
http://technet.microsoft.com/en-us/sysinternals/default.aspx (http://technet.microsoft.com/en-us/sysinternals/default.aspx)
Microsoft fournit des coordonnées de sociétés tiers afin de rechercher le support technique. Ces informations peuvent modifiées sans préavis. Microsoft ne garantit pas l'exactitude des informations tiers contact concernant.

Après avoir déterminé la cause racine du problème, appliquez l'une des méthodes suivantes pour résoudre ce problème, selon votre situation :

Restaurer à partir d'une sauvegarde

Si le dossier ExchangeServer_ Exchange Virtual Server Name ou son contenu ont été remplacés, supprimé ou modifié, restaurer le dossier ni son contenu à partir d'une sauvegarde valide.

Si le problème avec le Clust *. * fichiers uniquement, restaurer uniquement les fichiers.

Si il n'existe aucune sauvegarde valide du dossier ExchangeServer_ Exchange Virtual Server Name et son contenu, vous pouvez recréer le dossier ExchangeServer_ Exchange Virtual Server Name et ses fichiers de base.

Pour plus d'informations sur la façon recréer ce dossier et ses fichiers de base, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft. :
282122  (http://support.microsoft.com/kb/282122/ ) Serveur ne peut pas mettre la ressource Microsoft Search en ligne
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
830189  (http://support.microsoft.com/kb/830189/ ) Ordinateur Microsoft Exchange Server 2003 ne peut pas mettre la ressource Microsoft Search en ligne
Vous devrez peut-être recréer l'index de texte intégral sur les banques de serveur virtuel Exchange dans le Gestionnaire système Exchange.

Réinitialiser les autorisations de système de fichiers NTFS

important Assurez-vous que le compte système et le compte administrateur disposez des autorisations Full Control dans le dossier ExchangeServer_ Exchange Virtual Server Name et son contenu.

Le Clust *. * fichiers nécessitent également Full Control autorisations pour le compte de service de cluster.

Pour réinitialiser les autorisations NTFS, procédez comme suit :
  1. Ouvrez l'Explorateur Windows et recherchez le fichier ou le dossier que vous souhaitez modifier les autorisations pour.
  2. Cliquez avec le bouton droit sur le fichier ou dossier, cliquez sur Propriétés et puis cliquez sur l'onglet sécurité .
  3. Pour configurer les autorisations d'un nouveau groupe ou d'un utilisateur, cliquez sur Ajouter , tapez le nom du groupe ou l'utilisateur que vous souhaitez définir les autorisations pour en utilisant le format domainname \ name, puis cliquez sur OK .
  4. Pour modifier ou supprimer les autorisations d'un groupe existant ou d'un utilisateur, cliquez sur le nom de groupe ou de l'utilisateur, cliquez sur Autoriser ou sur Refuser sous autorisations pour chaque autorisation que vous souhaitez autoriser ou refuser, puis cliquez sur OK .

Réinitialiser les autorisations de Registre

important Assurez-vous que le compte système et le compte administrateur disposez des autorisations Full Control pour la sous-clé de Registre
HKLM\Software\Microsoft\Search\1.0
et toutes ses sous-clés.

Pour réinitialiser les autorisations de Registre, procédez comme suit :
important Cette section, la méthode ou la tâche, contient des étapes qui vous indiquent comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si modification incorrecte du Registre. Par conséquent, assurez-vous que ces étapes avec soin. Pour la protection supplémentaire, sauvegarder le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder et restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756  (http://support.microsoft.com/kb/322756/ ) Comment faire pour sauvegarder et restaurer le Registre dans Windows
  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedt32 et puis cliquez sur OK .
  2. Agrandissez la sous-arborescence
    HKEY_LOCAL_MACHINE
    dans la fenêtre de l'ordinateur local.
  3. Sous la sous-clé suivante, recherchez la sous-clé de Registre que vous voulez réinitialiser les autorisations pour :
    HKEY_LOCAL_MACHINE \SOFTWARE\Microsoft\Search\1.0
  4. Dans le menu sécurité , cliquez sur autorisations .
  5. Pour configurer les autorisations d'un nouveau groupe ou d'un utilisateur, cliquez sur Ajouter , tapez le nom du groupe ou l'utilisateur que vous souhaitez définir les autorisations pour en utilisant le format domainname \ name, puis cliquez sur OK .
  6. Pour modifier ou supprimer les autorisations d'un groupe existant ou d'un utilisateur, cliquez sur le nom de groupe ou de l'utilisateur, cliquez sur Autoriser ou sur Refuser sous autorisations pour chaque autorisation que vous souhaitez autoriser ou refuser, puis cliquez sur OK .
  7. Quittez l'Éditeur du Registre
important Le dossier valide et les fichiers doivent être établis. En outre, le compte système et le compte administrateur doivent avoir Full Control autorisations pour le dossier ExchangeServer_ Exchange Virtual Server Name, son contenu et les sous-clés de Registre ci-dessus.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange 2000 Enterprise Server
Mots-clés : 
kbmt kbprb kberrmsg kbinfo KB310586 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 310586  (http://support.microsoft.com/kb/310586/en-us/ )
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.