ID do artigo: 310586 - Última revisão: quinta-feira, 25 de outubro de 2007 - Revisão: 2.12

A instância do MSSearch Exchange não fica online em um cluster e o evento 3055 identificações e 10006 são registradas

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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Sintomas

A instância do MSSearch Exchange não fica online em um cluster do Microsoft Windows 2000 Server e os eventos a seguir são registrados no log de eventos do aplicativo:
Evento 1

Tipo de evento: aviso
Origem do evento: Microsoft Search
Categoria do evento: coletor
IDENTIFICAÇÃO de evento: 3055
Descrição: Não é possível abrir o arquivo de mapeamento de propriedade do coletor. Erro: 80070002. Os valores padrão estão sendo usados. Talvez seja necessário que copiar o arquivo de mapeamento de propriedades de um CD de instalação ou reinstalar o programa.

Evento 2

Tipo de evento: erro
Origem do evento: Microsoft Search
Categoria do evento: coletor
IDENTIFICAÇÃO de evento: 10006
Descrição: Erro durante a operação online por exemplo < MS Search Instância do Exchange-(D-EXCLUVS1) >: 80070002 - O sistema não é possível localizar o arquivo especificado.

Dependendo da causa raiz do problema, você também pode receber uma ou mais das seguintes mensagens de erro:
Mensagem de erro 1
80070002 O sistema não é possível localizar o arquivo especificado.
Mensagem de erro 2
80070005 Acesso negado.
Mensagem de erro 3
80070006 O identificador é inválido.
Mensagem de erro 4
Mensagem de erro 80070003 - O sistema não é possível encontrar o caminho especificado.

Causa

Quando a instância do MSSearch Exchange é colocada online, MSSearch procura arquivos de configuração que estão presentes na drive: pasta do Exchange Virtual Server Name \EXCHSRVR\ExchangeServer_. Os nomes desses arquivos de configuração são Clust0.0, Clust0.1, Clust1.0 e assim por diante.

Os arquivos de configuração contêm informações muito importantes sobre o caminho da indexação de texto completo do aplicativo, caminhos de catálogo, caminhos de índice e muito mais. Esses arquivos são específicos para o cluster e para o servidor virtual do Exchange.

Se a instância do MSSearch Exchange não conseguir acessar os arquivos de configuração, a instância do MSSearch Exchange não fica online e as mensagens de erro mencionadas na seção "Sintomas" são exibidas.

As mensagens de erro podem ocorrer se uma das seguintes condições for verdadeira:
  • A pasta ExchangeServer_ Exchange Virtual Server Name ou seu conteúdo foi removido ou renomeado (erro 80070002).
  • A pasta de ExchangeServer_Exchange Virtual Server Name ou seu conteúdo foi copiado de um servidor diferente para o servidor em cluster (erro 80070003).
  • A conta do sistema e a conta administrador não tem permissões suficientes para a pasta ExchangeServer_ Exchange Virtual Server Name ou ao seu conteúdo (Erro 80070005).
  • A conta do sistema e a conta administrador não tem permissões suficientes para a subchave de registro
    HKLM\Software\Microsoft\Search\1.0
    ou suas subchaves (Erro 80070005 ou 80070006).

Resolução

Para resolver esse problema, determine primeiro a causa raiz do problema usando os utilitários como o File Monitor (FileMon.exe) e Registry Monitor (Regmon.exe). Para obter esses utilitários, visite o seguinte site:
http://technet.microsoft.com/en-us/sysinternals/default.aspx (http://technet.microsoft.com/en-us/sysinternals/default.aspx)
A Microsoft fornece terceiros informações de contatos para ajudá-lo a encontrar suporte técnico. Essa informações de contatos podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações contatos de terceiros.

Depois de determinar a causa raiz do problema, use um dos seguintes métodos para resolver esse problema, dependendo da sua situação:

Restaurar a partir de um backup

Se a pasta ExchangeServer_ Exchange Virtual Server Name ou seu conteúdo foi substituído, excluído ou alterado, restaure a pasta ou seu conteúdo de um backup válido.

Se o problema estiver com o cluster 1. * arquivos restaurar somente, somente os arquivos.

Se não houver nenhum backup válido da pasta ExchangeServer_ Exchange Virtual Server Name e seu conteúdo, você pode recriar a pasta ExchangeServer_ Exchange Virtual Server Name e seus arquivos de núcleo.

Para obter mais informações sobre como recriar esta pasta e seus arquivos de núcleo, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
282122  (http://support.microsoft.com/kb/282122/ ) Servidor não é possível colocar o recurso Pesquisa Microsoft on-line
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
830189  (http://support.microsoft.com/kb/830189/ ) Computador com Exchange Server 2003 não é possível colocar o recurso Pesquisa Microsoft on-line
Talvez você precise recriar os índices de texto completo nos armazenamentos de servidor virtual do Exchange no Exchange System Manager.

Redefinir as permissões de sistema de arquivo NTFS

importante Verifique se a conta do sistema e a conta administrador tem permissões de controle total para a pasta ExchangeServer_ Exchange Virtual Server Name e seu conteúdo.

O cluster 1. * arquivos também exigem permissões de controle total para a conta do serviço de cluster.

Para redefinir as permissões de NTFS, execute estas etapas:
  1. Abra o Windows Explorer e localize o arquivo ou pasta que você deseja alterar permissões para.
  2. Clique com o botão direito do mouse no arquivo ou pasta, clique em Propriedades e, em seguida, clique na guia segurança .
  3. Para configurar permissões para um novo grupo ou usuário, clique em Adicionar , digite o nome do grupo ou usuário que você deseja definir permissões para usando o formato domainname \ name e em seguida, clique em OK .
  4. Para alterar ou remover permissões de um grupo ou usuário existente, clique no nome do grupo ou usuário, clique no Permitir ou Negar em permissões para cada permissão que você deseja permitir ou negar e, em seguida, clique em OK .

Redefinir as permissões do registro

importante Verifique se a conta do sistema e a conta administrador possuem permissões controle total para a subchave de registro
HKLM\Software\Microsoft\Search\1.0
e todas as suas subchaves.

Para redefinir as permissões do Registro, execute estas etapas:
importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows
  1. Clique em Iniciar , clique em Executar , digite regedt32 e, em seguida, clique em OK .
  2. Maximize a subárvore
    HKEY_LOCAL_MACHINE
    na janela do computador local.
  3. Sob a seguinte subchave, localize a subchave do registro que você deseja redefinir as permissões para:
    HKEY_LOCAL_MACHINE \SOFTWARE\Microsoft\Search\1.0
  4. No menu segurança , clique em permissões .
  5. Para configurar permissões para um novo grupo ou usuário, clique em Adicionar , digite o nome do grupo ou usuário que você deseja definir permissões para usando o formato domainname \ name e em seguida, clique em OK .
  6. Para alterar ou remover permissões de um grupo ou usuário existente, clique no nome do grupo ou usuário, clique no Permitir ou Negar em permissões para cada permissão que você deseja permitir ou negar e, em seguida, clique em OK .
  7. Feche o Editor do registro
importante Os arquivos e pasta válida devem ser estabelecidos. Além disso, a conta do sistema e a conta Administrador devem ter permissões de controle total para a pasta ExchangeServer_ Exchange Virtual Server Name, seu conteúdo e as subchaves de registro abovementioned.

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange 2000 Enterprise Server
Palavras-chave: 
kbmt kbprb kberrmsg kbinfo KB310586 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 310586  (http://support.microsoft.com/kb/310586/en-us/ )