Inaktivera en tjänst eller enhet som förhindrar start av Windows

Artikelöversättning Artikelöversättning
Artikel-id: 310602 - Visa produkter som artikeln gäller.
Visa alla | Dölj alla

Symptom

Om en tjänst eller drivrutin som startar automatiskt inte är kompatibel med den aktuella Windows-versionen, kan det hända att tjänsten eller drivrutinen hindrar Windows från att köras tillräckligt länge för att du ska kunna stänga av tjänsten eller inaktivera den inaktuella drivrutinen.

Orsak

Det här problemet kan uppstå om det finns maskinvara eller programvara som installerar en enhet eller tjänst som är inkompatibel med Windows.

Lösning

Lös problemet genom att starta Återställningskonsolen och logga in på datorn.
  1. Starta datorn med Windows-startdisketterna, eller med Windows-CD:n om datorn kan starta från CD-ROM-enheten.
  2. Reparera installationen genom att trycka på R när dialogrutan Välkommen till installationsprogrammet visas, och starta sedan Återställningskonsolen genom att trycka på C.
  3. Välj att installera Windows och logga in på datorn med administratörskontot.
  4. Skriv listsvc från mappen %SystemRoot%\System32 vid kommandotolken och tryck på RETUR.
  5. Leta upp tjänsten eller drivrutinen som orsakar problemet i listan.

    Obs! Om du väljer fel tjänst eller enhet kan det uppstå fler problem.
  6. Skriv disable namn på tjänst (namn på tjäst är namnet på tjänsten) och tryck på RETUR.

    Obs! Med kommandot disable skrivs tjänstens gamla starttyp ut innan den återställs till SERVICE_DISABLED. Därför bör du anteckna den gamla starttypen om det skulle bli nödvändigt att åter aktivera tjänsten.
  7. Skriv exit, så startar datorn om automatiskt. Låt datorn starta normalt.

Mer Information

Om du vill veta mer om hur du installerar och använder Återställningskonsolen klickar du på artikelnumret nedan och läser artikeln i Microsoft Knowledge Base:
229716 Beskrivning av Återställningskonsolen för Windows 2000 (Länken kan leda till en webbplats som är helt eller delvis på engelska)

Egenskaper

Artikel-id: 310602 - Senaste granskning: den 1 december 2007 - Revision: 2.1
Informationen i denna artikel gäller:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Professional x64 Edition
Nyckelord: 
kbenv kbprb KB310602

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com